RTSP on new V2 cams

I currently have a couple V2 cams that were purchased a couple months ago running the RTSP firmware and are working well. I bought two new V2 cams this week and am attempting to update them with the ‘demo_V2_RTSP_4.28.4.41.zip’ firmware from this post https://support.wyzecam.com/hc/en-us/articles/360026245231-Wyze-Cam-RTSP.

I am able to update the cams with the RTSP firmware on SD card but after update I believe they are bricked in a boot loop where the yellow light is constant on but I can hear a faint click every 2 seconds. The new cams no longer connect in the app after this. The only way I found to resolve this is to re-update the firmware back to the latest non-RTSP release through the SD card update.

Did the hardware change in the newer cameras that is no longer compatible with the RTSP?

1 Like

I don’t know how the RTSP firmware will handle it, but the production v2 firmware page has this warning which might transfer over to the RTSP firmware also:

The RTSP support page does say this "At this time, we are not committing to ongoing maintenance for RTSP firmware.. I would guess the hardware would evolve beyond what the firmware was made for.

WYZE has been saying that since the first release of the RTSP firmware.

1 Like

I recently bought a wyze cam 2 earlier this week to test out the rtsp functionality and it worked great. I ordered 2 more yesterday and I’m having the same problem. It’s weird, but maybe the hardware changed in between my two purchases. I talked to support but no help there.

Yep! Just relaying the old info to a new user.

I just bought a Wyze Cam v2 from Amazon only after confirming that RTSP was an available option for this camera, as my use case for it requires it. The first thing I did upon receiving it, was to attempt to install the RTSP firmware on the camera. The install seems to go fine, I get the faint blue light, etc, however, afterwards the camera is stuck in a boot loop. It clicks and the yellow light flashes off and right back on, then a few seconds later it clicks again. It just loops doing that over and over again every five seconds or so.

I reached out to Wyze support for help, but after >72 hours their response was for me to try reinstalling the same RTSP firmware again, which, of course, just results in the same issue.

I guess some cameras are bad. I ended up replacing the two that didn’t work for and flashing the firmware worked first try. There’s no point in wasting your time, either replace it, return it, or don’t use any unofficial firmware.

Is there any hope of RTSP being included in the standard firmware?

I want to be able run Agent DVR with my Wyze cameras and still be able to use the features in the Wyze app. Can the V3 do this?

What Wyze app features do you want to use that aren’t already working with the RTSP firmware?

Firmware updates via the Wyze app

I am having same issue, it keeps clicking every few seconds.

Did you end up replacing them with new ones you ordered or did you call support and have them replaced under warranty?

Same issue. I ordered a Wyze Cam V2 via Amazon a month ago and was able to flash it with the RTSP firmware. Worked great! Ordered two more from Wyze directly and they won’t flash…I just get the continuous clicking. If this firmware isn’t supported on these new builds, I’ll have to return them and find a different solution.

Hi, there is a hardware update due to discontinue hardware parts for v2. Currently the new v2 cameras cannot be flashed to RTSP cameras until we release an update for RTSP firmware. We are working on it now but don’t have a firm timeline. We will give an update once have more details. Thanks!


Thank you for the official ACK on this. Hopefully they can get this squared away soon. A timeline, even an estimate would be nice, because if it’s going to be too long, If it’s unknown, I am probably going to have to return the cams I have until it’s available.

Thank you, this is what ownership looks like!

Please keep updating, I’d planned to deploy RTSP in certain uses, but held back as nothing was close to officially supported.

@WyzeTao it would be very helpful if you listed specific serial number ranges or other criteria so people would know not to waste their time trying to flash cameras that won’t do RTSP.

1 Like

It won’t be very long, The guestimate is a few weeks but don’t quote me. :slight_smile: Sometimes engineering problem takes longer than we guessed. We would rather under promise and over deliver rather than vice versa.


@WyzeTao I just purchased a V2 cam with the understanding that RTSP was possible but I"m having the same issue as others in this thread. Is there any update here?

We had a test version out last week but it needed a modification. We will have a new test binary out for internal testing this week.