Wyze v2 trying to load rtsp issues

trying to load v2 rtsp firmware on a v2 picked up in a Wyze starter set that I found on clearance.

I have loaded all my cams with RTSP firmware, and was trying to do the same to this new v2, but I am unable to get the cam to initiate a firmware load on plugin.

Instead of getting a solid lue light when holding the setup switch while powering up, the led never turns from yellow, and after about 5-10 seconds, it clicks a couple times and then says ready to connect.

I’ve never had any issues loading the rtsp firmware before, so not sure what to do. I need rtsp for my use case… Anyone have an idea how to get the firmware to load from SD if this happens?

I am using an 8GB sd card, formatting it and loading the demo.bin rtsp firmware as I have before.

1 Like

Bueller, bueller, bueller…

1 Like

Hi. For the last few days I’ve been trying to get RTSP support on one of my v2 cameras.

It took me several tries to successfully (?) get the camera to accept the RTSP firmware. I don’t know if it was something that I was doing or if it’s an issue with the camera or firmware.

You know how Wyze has backed down their official v2 firmware from (Nov 18, 2020) to (Oct 21, 2020)? I noticed that when I attempted to put the RTSP firmware on my v2 camera, when I use the Wyze app (iOS version), it now says that the camera is running version, so I can only presume that the firmware took.

However, I’m not 100% convinced that it is running the RTSP firmware as I don’t have any sort of RTSP option for that camera in the Wyze app.

So, I’m at a bit of a loss as to how successful the whole flashing process was.

I am curious to know how far you were able to get in the flashing process for the v2 camera that you’re having issues with…? Perhaps we could put our heads together and get our issues solved.

What version of RTSP firmware are you using, and what version of the Wyze app are you using (and under what platform).



Hey Jon, on the problem cams, I’ve been unable to load the RTSP at all as the boot loader functionality is unresponsive and the cams led never turns Blue on boot.

On the cams I was able to get the boot loader to function, they all took.

If you are unsure whether RTSP is functional, if when you go into the cameras settings, advanced option, at the bottom of the advanced section is the switch to enable RTSP, you’ll then set username and password, and finally generate your RTSP address to use in any clients you wish to use to view the RTSP feed. I use HomeAssistant and the RTSP stream is the only way to view a Wyze cam on HA.

On iOS devices you can use Remote4 App (free) to view the RTSP feed directly without needing the Wyze App. If you want set up a Linux VM, motionEye is a solid server to take the cams RTSP feed and do AI person/car/dog/etc detection, but your WiFi needs to be solid to handle more than 6 cam feeds, and I’d recommend using a dedicated AP on another channel to prevent slamming your available bandwidth for other devices.

Right now, I have three cams that refuse to initialize the firmware load on boot, I’ve got two other v2s that just cam in from Amazon that I’ll be setting up this weekend, so we’ll see.

1 Like

@alanizat - Thanks for the feedback and info.

I stepped away for the RTSP project for a couple days just to let my brain clear, and I eventually was successful in getting RTSP working on the Wyze v2.

Here are a few things I discovered:

  • I am not sure exactly what paths I took (it was a long and winding road), but some of the firmware that I pulled down from the Wyze site was not the correct software. With the original firmware I downloaded, it appeared to flash, but it didn’t work properly. I don’t know if the firmware was bad or the flash process was bad, but in the end, I was able to find good factory-default firmware as well as good RTSP firmware. Yay.

  • In addition to the above issue, one big problem was that I took a brand new v2 camera, and the first thing I did was install the RTSP firmware on it. The firmware appeared to flash, but the camera wasn’t seen in the Wyze iOS app. Here’s how I got around that issue: I flashed the original factory firmware (non-RTSP firmware) into the v2, then used the iOS app to get the camera on my local network, THEN I flashed the RTSP firmware onto the v2. At this point, once the v2 rebooted, it was able to connect to my network, my iOS app not only found the v2 camera but also now has the RTSP menu item. It makes me wonder if the RTSP firmware might not have the pieces that are needed to initially find and configure the v2…? But, not matter, as the above procedure worked.

So, I’m good to go with the camera. Now I need to look at Linux based RTSP software to do the transcoding so I can watch the camera on a web browser. I’ll take a look at motion Eye; thanks for the pointer.

As I make progress on this overall project, I’ll post updates here.

Thanks again for the feedback and info.


Alanizat, did you ever find a way to flash those problem Wyze Cams? I just have one Wyze Cam Pan that I want to use w/ RTSP but I’m seeing the same problem you describe. No matter how often I try, it never runs the boot loader.

Hey, I found the solution on another thread. I was using a 64GB exFat card. Apparently the boot loader only supports fat32 so I had to use a smaller card and format fat32. Worked on first attempt.