RTSP Firmware?

What “base” firmware do I need to use with the Cam to install the RTSP firmware over? As it stands, I did that but it tells me that I’m using incompatible firmware.

Here is the link to the rtsp page with the firmware. There is only one firmware version for the V2 and one for the pancam.

Does the info on this page help you?

1 Like

Yup, I know this, as evidenced by my initial post. But why does it say “your firmware is incompatible” on the RTSP on/off page?

I tried scrubbing the forums and couldn’t find any similar situations. What Wyze app version and device type and OS are you trying it with? Are you in a beta app? Able to post a screen shot?

I wonder if some new app features arnt jiving with the RTSP firmware, since it’s a one off beta firmware. The page I linked above says in the disclaimer on top: “Using the RTSP firmware will prevent the camera from supporting any future functions or features in the Wyze app.”

No one else chimed in with anything but another thing you can do is go the Wyze Support route by creating a support ticket and they may be able to get to the bottom of it with their tools.

Yup, I scrubbed as well, which is why I asked the question. I’ll toss it over to support. Thanks.

What firmware does the camera say it has installed on it? and what camera are you trying this on? what app and device are you using also? I am trying to recreate this on my end. Are you able to post a screen shot of this also?

Been using RTSP for a couple months now with NX witness streaming 24/7. Started with 9 cams (7 V2s and 2 Pan) and am down to 4 (3 V2s and 1 Pan). I first lost a Pan Cam RTSP stream a couple weeks ago. Cam still works but all efforts to stream failed except with App or Tinycam. No RTSP. Then the other Pan Cam lost it’s RTSP stream, and shortly afterward, while reviewing footage via the App on my phone, it just died (perpetual blinking yellow LED). So now only two V2s streaming on NX witness. Having threw in the towel Wyze wise, and after researching other wired cheap cams, I realized how many were using the same App and firmware under different names, because Wyze is just a PR company acting much like a franchise with their products and software. And RTSP doesn’t fit their Apple like closed system business model.

WYZE uses hardware sourced from others but the app and firmware is designed by them

1 Like

Reviewed with support and it’s a new potential bug in a beta/alpha build of the app. It’s on the list to fix.


I’ve downloaded the RTSP firmware, saved (demo.bin) to a 32GB SD card that was formatted in the PanCam, went through the firmware update process (e.g. SD card in, hold Reset button down while inserting power cable, wait for blue light, release) and process seems to finish correctly. However, when I go to the iOS app (V2.11.41) and look for RTSP in “Advanced Settings” it’s not there. I’ve contacted Wyze support, but, so far, no reply. Do I understand from your post that their latest RTSP firmware (e.g. demo.bin) has some kind of bug that’s preventing me from getting this done??? Thanks!

What Wyze app version do you have? I believe that is what they are referring to, rather than the firmware.

iOS app (V2.11.41). The app shows I’m using firmware version

I don’t think the flash took because the RTSP firmware for the pan is version

Thanks for that! I’ve tried many times to get this to work and, each time, it looks like it works. I’ve seen comments on this forum that someone(s) think that some PanCam models are incapable of flashing to the RTSP firmware. What do you think of that idea? If that’s not it, I’m not sure what else to try. The flashing process goes exactly as described by Wyze with the blue light and all. Not sure what else I need to watch for???

Just jumping in with a few random thoughts…

Maybe try flashing to one of the older firmware versions on the Wyze site, see if that takes, if so try RTSP again from there?

Maybe try a stronger power cube ( 2 Amp for tablets ) and a short cable to make sure the flashing has enough oomph?

Maybe FAT32 format the SD card in a PC first using the full format and NOT the “Quick Format” option? Then do as before - it all sounded right.

i am trying to flash my pan to RTSP right now so i’ll update with what i find out.

Interesting suggestions…thanks! I’ll give them a try.

I was able to get it to update. Followed each rule from the RTSP flash page. Some other things I did was use a 32 gig card, formatted it in the camera and did the safe eject in app before I plugged the card into my computer to move the firmware over, and triple checked that I renamed the file correctly. Even though the file extension of .bin isn’t shown, it is labeled that way, confirmed by checking the file properties. When I did the webcam firmware I found out the hard way that demo.bin.bin isn’t demo.bin. :slight_smile:.
Edit/ and i made sure to use 5v 2a power brick


I used a 5V, 2.4A power source with a 1-foot cable and was able to go back one firmware version to I properly ejected the SD card from the PanCam and installed the RTSP firmware onto the SD card using Windows 10. All went fine without any errors. I re-inserted the SD card back into the PanCam and tried the flashing. All steps went as before, but when I checked, the PanCam was still running firmware Summary: I’m able to go back to earlier versions of firmware, but not to the RTSP version.

Just wondering…is it possible for you to post the demo.bin file you successfully flashed to your PanCam?