Having trouble with RTSP firmware

I joined the beta to ensure I have the newest bits.

I downloaded the firmware for my Pan Cam and confirmed through the app that it was applied.
I am using V2.2.35 of the app. But when I go to Advanced Settings I do not see an RTSP section.

Am I missing something?
Thanks for the help.

Fyi, you are posting in the beta forum, Rtsp firmware has not been released to beta

1 Like

Apparently it has for iOs


Update to latest TestFlight app (I don’t have Android to test the beta there). Upgrade the firmware on the cameras. Check the advanced settings of the individual cameras and enable the RTSP setting and you’ll be linked to the firmware download.

I’m testing it now. So far, so good."

On android Apparently I needed to update my app.
After that was done I was notified of firmware upgrade.

Yeah I think you’re right, I didn’t see the latest update 2.3.12. I was gonna check for myself but the update won’t run on Android Q, I’m sol until they fix it.

My understanding was that the rtsp firmware was only available via manual flashing, is it also available via the app?

Interesting, I started with the FAQ that Ken linked above.

But I did update testflight and I now see the RTSP feature in the App. I enabled it and got myself a link. But the link doesn’t work.

I’m still using the camera firmware.

@gemniii Did you get it to work? What camera firmware are you using?

Depending on what software you use, you may have to adjust the link it gives you. I think when I used VLC, the link was good but when using blue iris, I had to remove the username and password from the link

RE:getting it to work
Have not tried the flash yet. Firmware (w/o RTSP) upgrade to on V2 and on Pan went fine.

Sorry if this was answered elsewhere.

If using this firmware, will the standard WyzeCam software work with the RSTP firmware?

I would like to be able to use both at different times (Even better concurrently!).

Yes, the standard Wyze software still works. I just loaded the manual firmware this AM, and have my cameras now hooked up to my Synology. So far, it is working great!

update worth noting if you have the motion detection turned on from the wyze app, you WILL get the green motion boxes show up on the RTSP stream. For me I like this, but other might now so fyi.

1 Like

Reading the info it may not work with future WyzeCam software.

I REALLY hope they keep both. I would hate to lose all the nice features the Wyze app brings, but I want RTSP for long term recording storage too.

1 Like

I got it working with BlueIris now.


App software is V2.3.11 (iOS) and camera firmware is

As I understand it, with RTSP you can not control the Pan? That would have to be ONVIF?

No problem updating a V2 Wyze Cam (not pan) to the new firmware, turned on RTSP, entered some credentials, it generated a url that I dropped into Zoneminder. Now I have a RTSP stream directly from Wyze Cam to ZM, no problem at all!!

I’m getting major latency issues and jitter. Anyone else not have smooth rtsp playback?

Does RTSP work on v1?

No, RTSP integration only works on V2 and Pan cameras due to hardware limitations in the V1s.

1 Like

Same. It sometimes misses an entire second of video at a time. I’ve tried adjusting framerate all the way from 15 FPS to 5 FPS. Issue is consistent across VLC and Shinobi while the same camera is smooth in the app.

my experience with rtsp:
the picture quality is nice but there is a definite lag. Seems like people moving in it are going in slow motion and then speed up. It is also behind by about 3 seconds.

1 Like

Same here, it lags bad