Second V2 cam fails to update to RTSP

I got two new Wyze Cam V2. I followed the instructions to successfully update the first to rtsp.

I put the same micro usb straight into the second cam. It starts the update but then gets stuck in what appears to be a boot loop, clicking every second or so, yellow light flashes on and off as it does.

I can successfully revert the camera to stock firmware using the same process.

Im not sure if the firmware version affects the ability to update to rtsp, but Ive successfully flashed and, but with no change to the failure to update to rtsp.

I have tried re-downloading the rtsp firmware ( Although it makes no sense that should have any affect since the same card and file worked on the first camera. Its a brand new class 10 mirco usb card. It can revert the camera to stock no problem.

Anyone any ideas? I need to get this working reliably as I have two more cameras to flash to rtsp.

Welcome to the forums! How new are the cameras? There are posts in the forums about it but some hardware components in new batches if cameras are not compatible with the RTSP firmware. The website for the RTSP firmware states the following:

NOTE: The firmware files listed below are NOT compatible with recently purchased Wyze Cam v2 hardware. We are working on an updated RTSP version that will resolve this.

Hi, thanks for your quick reply. The cameras arrived today (in Australia, delivered from the States).

I did see that note. At first I thought it was all Cam V2s that weren’t compatible, but when the first V2 camera upgraded OK I assumed either I hadn’t understood or the note was outdated (as there’s no date on it).

Seems odd one works and one doesn’t in the same delivery, But it would explain the problem, assuming the cameras are different hardware (although apparently otherwise identical). Perhaps I have to just wait …

1 Like

This thread covers it a bit more:

Seems they are working on a fix and someone mentioned that the newer cameras that won’t flash have a different FCC ID, which I confirmed with the two pack that I bought. One would flash and the one that wouldn’t has the newer FCC ID.

1 Like

Thankyou for that info and the link. Ive gone ahead and flashed my two other cameras which are older than August, both of which worked flawlessly.

1 Like