Robot Vacuum Software Dissapointment

One tip I can offer when setting up your vacuum for the first time is the following:

You need to use the Wyze app on your mobile device to setup the vacuum. If you’re using a smartphone, you need to be connected to the same 2.4GHz WiFi router as the vacuum. Also, you need to turn off the cellular mobile data to your smartphone, as you will be connecting directly to the WiFi of the vacuum during the installation process and later back to your WiFi. You don’t want your phone to connect to your cellular data connection during the installation process, just back to your home WiFi. I had this issue and resolved it by deactivating my cellular data connection before starting the vacuum setup process.

The Wyze Robot Vacuum is fine for an unfurnished, uncarpeted space if it is able to maintain a wifi connection but in a real world setting, it is lost. I thought it could outperform my Vacmaster, it can not. It is constantly trapped inside a standard chair or hung up on a register or shag carpet.

I received my vacuum yesterday and am not disappointed with it at all. It’s weird to see someone disappointed when they haven’t yet received one, but judging on the small number of negative comments. Yes the docking station moved slightly, but so easily fixed with a couple of pieces of double sided tape or Velcro.

When I set it off yesterday afternoon on the first run, it took it a while to map the house. It started off in what seemed completely random directions, but my guess is that it was getting the lay of the land. Once it had a pretty good idea of the layout, it set off cleaning in linear patterns.

I was amazed at what it picked up. I did at one point have to rescue a sock that it had found and sucked up, but now wizened, I have made sure there are no cables or loose items on the floor to get trapped. I programmed it to go at 6am this morning and below is the image of it’s first run, and I think it has given pretty good coverage. I’ll check it later again after it has charged and set off again.

1 Like

We have had our Vac for only 2 days and just love it!! I gather some issues are out there, but we had a great experience first (complete house) and second run. Map looked great and it covered every accessible space. The room mapping could be more defined and it did seem to struggle a little under a few chairs, but so would I. A little disappointed in the instruction manual - it is not complete in several respects (Hepa filter, Exclusion zone instructions to name 2), but the product looks great so far.

I’d also like to chime in that I’ve had the vacuum now for a week and am thoroughly enjoying it. Weird to see a complaint post from someone who hasn’t received it yet, and most likely will end up returning it based on preconceptions.

It’s not perfect by any means, and I really hope the Wyze team continues to improve the mapping reliability as well as the virtual walls implementation. I have a support ticket in for these, but that by no means makes this vacuum “unusable”.

Set up is fairly simple and the vacuum does great at the initial mapping. The nice clean lines of a well organized cleaning speaks to the great development work in such unpredictable home layouts.

With that said, I hope that Wyze continues to devote resources to this newly released product because much work must be done to make it worth the investment. Overall, coming from a 5-year-old Roomba, I highly recommend this vacuum.

One tip during the first mapping is to make sure that all cords are up off the floor. It likes to get rapped up in them. The other is to pause it and clean the waste bin. If the lidar can’t see something because it is too low it will drive over it.

I haven’t seen a single person say they were gonna return it before receiving it. I think most people are hoping they won’t have to.

I’ve had my vacuum for a few days, and setup and initial mapping went well. My only complaint is that it has only one mode: Clean the whole house. I set up a schedule to clean only room 7, and when it executed, it cleaned the whole house. There is very little functionality in the app, other than the scheduling feature, and that doesn’t work correctly. I have no way to redesignate the multiple rooms that the vacuum has decided is a single room, or the single room that the vacuum thinks is three rooms. But since it only wants to clean the whole house, it really doesn’t matter. Hopefully, the software updates come soon so that this promised feature actually works.

I’ve had mine for a couple of days. Once I figured out how to set up on my phone it worked great.

Docking was initially a small issue. I have baseboards and quarter round around the house, as a result the docking station cannot remain flush to the wall. The engineers probably didn’t take baseboards into account when designing the unit.

When the unit attempts to dock, the top of the station tilts toward the wall and the vacuum cannot make solid contact with the charger.

I cut a piece of foam to fill the gap between the docking station and the wall. It now works perfectly.

1 Like

I owned a Roomba years ago, so I knew to police the area for cords and “sticking points”.
I missed one spot in the bedroom under the treadmill, and it found it. We had to turn it off/on to get it back going. It could not find its way back to the dock, when the battery ran low. It kept circling around where we had to reboot it. The map that was created after this fiasco looked bizarre, so I deleted it. It looked like some kind of dungeon, cave, or crypt. I am going to let it go one more time today after it fully charges AGAIN. It ran for 1.8 hours on quiet mode and did about 814 SFT. I would say about 1/2 the bottom floor of the house (and I shut the doors on several closets to limit it). If it works out, I may buy one for upstairs too. I forgot how much fun it was to watch these machines.

I cleared the map, and charged it fully, and it created a new map, which looks much better!
On the second run it did 831 SFT and ran for 1.5 hours before returning to the charging station successfully. I am assuming after it fully charges, it can continue to finish the rest of the map? It never asked me to save the map, it says on the bottom of the map screen: “Clean interrupted, it can continue later”. It is charging.

Summary: Am I glad I bought it? YES. Does everything work like it should? NO.

Wyze Robot Vacuum Review and Tips

Here are some getting started tips configuration options

I bought the [Wyze Robot Vacuum] as part of a kick starter for $199 that came with a free Wyze web cam version 3.

It was delivered yesterday and I have been having some fun and frustrations with it so I thought I would share.

The cool thing about this vacuum is the LIDAR sensor, a spinning laser on top of the vacuum. Every second, it spins around 6 times and measures the distance to 2,016 different points in the room to build a map. You can see, edit, and save the map in the Wyze app.

Here are some getting started tips

  1. But if you look at the[ support forum] users have had some difficulty getting the maps to complete and save. Here are some tips I found:
  2. Don’t place the charging dock on thick carpet, the robot with try 3 times to dock to the charger and fail then it deletes the map it was working on. If before the 3rd dock try you help it dock then the map might be saved
  3. Don’t try to start mapping until the batteries are fully charged, it won’t let you vacuum unless you have the batteries above 15% and will stop and try to charge when they reach 7%
  4. Don’t start trying to map your whole house. I found it best to shut most of the doors and pick up the stuff on the floors. I had a scare when the vacuum turned on when I was gone found its way into my office and got an audio cable rapped around a wheel. It powered it self down but then lost the map it was working on. In this case when it was off it might have worked if I did pick it up and put it back on its dock not sure.
  5. Don’t pick up the vacuum and move it, instead if possible use the app to pause and tell it to go charge.
  6. After it completes a few rooms and returns to charge it will ask if you want to save the map, say yes. Note I figured out there is a history of cleaning and one time when I turned it on after it got stuck it assumed it was starting at its dock location not where it got stuck. The problem was then it starting mapping over the top of the other map from the wrong place. Don’t worry just go into the history and delete that session with the bad map.
  7. Once a map was saved I wanted to create a virtual wall, which it turns out is really a virtual box block. It took me awhile to find out how you do it. From the Map you click on the round circle with a box inside it.
  8. After the vacuum has dock and the map is saved I let it charge and then opened up some of the doors.
  9. Scheduling cleaning of a room does not work for me, first it said you must complete the map. I did that then it let me schedule but will not let me select just one room, only the whole house. Also I only have three rooms listed on my map for the whole main floor. I wish I had some control over defining rooms and actually using them.

So how does it work?

The nice neat parallel vacuum lines are awesome. Leaves a perfect vacuum pattern in the rug. The White lines on the map show where the vacuum has been. The red boxes are the virtual blocks. The virtual walls are buggy. When I tried to add a second virtual wall the first one would jump to another location. I wound up deleting and starting again about 16 times trying to get these placed.

The mapping feature is really cool. As soon as it enters a room it maps all the walls it can see just from the doorway. Once it moves into the room it finishes getting the rest of the details.

The vacuum picks up a lot more dirt and stuff than I thought it would. I have only used it on the standard suction setting and it does great.

It is amazing how well it handles most obstacles. For example it works its way under chairs and over thick throw rugs.


I have the same problem.

I can assure you that all the problems the OP is worried about are REAL problems, and I’m SERIOUSLY considering returning this thing. It is HIGHLY unreliable, and needs to be babysat CONSTANTLY.

This is a BETA product AT BEST.

Thank you, I feel like certain people are being very condescending. I went through the forums and I curated a list of everything I saw. Minus the docking issues, eveything I listed were software issues. That being, unless the software is updated I should be expecting those same logic issues and mapping problems. I am raising legitimate issues, I don’t understand people who defend products with issues. You paid for it why would you not want a perfect product. We don’t need to worry about the price point. Wyze set the price so it’s not my role to lower my expectations. Wyze’s whole business model is quality products for less, not inferior products for less.


Perhaps you could get the vacuum before complaining. I just got mine today and it works perfectly. ZER0 issues


Well I’m glad you don’t have issues. Like I stated before these are all issues in the app itself. If people are reviewing a product on Amazon you wouldn’t buy it if they were all complaining. All of a sudden because it’s WYZE now it’s wait until you get yours and see if yours is broken too?

I just got my robot vacuum. I echo the sentiment of this post about not being beta tested. I spent about 3 hours just to set up the device and link it to my wifi. Didn’t have separate 2.4g ssid that added to the set up time. The first clean mapped the den and the living room but would not recognize that battery had run down. It started wandering far away from the charging station and the room mapping went all bonkers. It didn’t match the layout of my floor plan. After recharging, I did the foyer, but it stopped about 4" short along the entire length of one wall, a big no no. There does not seem to be an easy way to splice together the mappings of the 2 cleans.

Having spent about 6 hours, I will try to make this work for a few more days, else it’s going back. So far, disappointed in the product.

I had a chat this afternoon with Richard, one of the support wizards. The short of it is that the software is unusable for those of us with open networks. That’s a shame, because in manual mode the vacuum functions well as a cleaner.

Richard did suggest that I put an item on the wishlist regarding this and I did. I requested that the app be updated so that the user could choose whether to require a wpa network password or not.

I like the vacuum, but not the requirement for a password. As I told Richard, I have a Wyze Cam that never required a wpa password on the network in order to function. I have no problem with using a password in the app to access the vacuum, as I do with my Wyze Cam, just not a wpa password that locks down my entire network.

Note I just found out about the beta version of the app and I am going to give it a try. There is another post on the forum ’ Wyze Vacuum Map Editor’ that mentions this new beta version for the Android app 2.16.53. but I still do not see the Map Editor show on the settings menu.

Update: This morning, it kicked on per the room 7 schedule I had previously set up, zipped across the house, cleaned room 7, zipped back across the house and docked! I’m not aware of any SW updates, but it worked! Still not easy to partition rooms so that I could clean the kitchen, for example, since the kitchen was initially mapped as part of a larger area that includes my family room and breakfast nook. Hopefully, that capability will come soon. It’s good to see incremental improvements. The cleaning performance is good, not as good as my upright, of course, but I didn’t buy this to replace my upright, so that’s okay.