Robot Vacuum Issues on Day One!

Just received my Robot Vacuum pre-order today and set it up, charged it and ready to go.

It mapped the first part of the house, was stuck in the bathroom corner for more than 2 minutes and could not get out. I picked it up and moved it out in an area that was already mapped earlier and tried to send it back to the charger. It took off into an already run mapped area, map was now gone on my phone and it could not find the charger. It ran aimlessly around getting stuck further. I finally killed the power and carried it to the charger.

Upon re-opening the Wyze app on my iPhone, the house map is all gone and it now must restart all over again. Had I not been watching for the full 1.7 hrs., it would have died in a corner.

All in all, not an impressive product as these small glitches should not be occurring with this type of technology. I’ll give it another few tries before returning it as it is NOT ready for release to the public for sure. These minor items should be easily found during routine beta testing. Rushed product introduction for sure.

Any other similar experiences out of the box?

Thanks to all,
Thomas Marino


My similar experience was even worse. I got it to add to wifi and now it’s stuck in what I believe to be firmware upgrade mode. The lights just pulse white slowly. I called customer support two days in a row (because they never emailed me back) and they literally have no support info yet. How sad.

Interesting and utterly rude from a service standpoint especially on a new product. I’m giving it one or two more shots then it gets returned and welcome to iRobot Roomba which I know works awesome. I wanted to give a new product a chance and here’s where it got me with vert simple issues.

I see from reading a myriad of posts that response by anyone at Wyze to a support email is almost non-existent and looking at all the posts in this forum board, most with support queries, there are very few responses from the Wyze Support Team.

Not sure what the moderators do on this forum with most problem queries not even being acknowledged, let alone addressed. The initial ‘Welcome to Wyze Communities’ intro says ’ Powered by You’…basically a place for all Wyze users to vent their frustration as they search the forum for others with a similar un-answered problem.

One recent forum answer was to call Wyze support and NOT email, as the emails do NOT get answered, which in my case would be useless and would only result in more frustration along with a newly released Robot Vacuum that doesn’t work as advertised.

I’ll give a few more days and then I am sending the much touted, BETTER, Robot Vacuum back to Wyze for a refund and purchasing what I know works. Good Luck to those other Robot Vacuum pre-order supporters as you may be in for the same surprise and a not so Merry Christmas.

Well, here we are 5 days after posting this topic and also trying to get an email response to my problems and ‘couganhoobs’ notes above, absolutely NO response to either my email NOR my posted topic on this forum board. Am I surprised, not really after reading all the topics on SUPPORT but one would think that with new product release issues being noted, you would want to solve these issues for other users or to improve your product for a future release modification. Obviously this logical assumption is wrong and I think it was all about getting the product released as fast as possible, purely sales driven. My robot vacuum is getting packed back in its original packing and being returned on Monday. Now I have to pay for return shipping on an inferior product after being bold enough to help with the pre-order campaign in order to help collect $$ from pre-sales. Never again my friend. Off to buy another Roomba…that works as advertised!

Agreed. I have the same issue. The vacuum robot is fine. It’s the software that sucks

After many, many Wyze pre-order and subsequentpurchases, just filled out my first return request to return the Wyze Vacuum. Many of the same problems but for me, it’s not just the software which I wouldn’t mind waiting for updates on. It’s the higher physical tower profile so it doesn’t fit under many furniture pieces my robovacs fit under. So it just will never work under those. Then there’s all the little things like whenever I walk in the room where it charges not even that close to it, it says out loud beginning charging… I finally gave up on a cleaning cycle after it gets stuck 10 times and that’s not something I’m willing to deal with or have had to deal with on my robovacs ever, just fired them up and they worked out fine.

Did you ever get that sorted? I got mine yesterday and it’s stuck with pulsating white light nothing to do here. Any help would be appreciated.