Recording shorter (truncated) by 10 seconds or more than the Event Duration shows

Recording shorter (truncated) by 10 seconds or more than the Event Duration shows.
Issue started after installing on my (5) V3’s on Wednesday Dec 28, 2022. All 5 cameras have the issue, none of my 7 V2 cameras or my DoorBell has this issue.


Since the upgrade, every V3 recording is at least 10 seconds shorter than what the Event says it should be. Event shows 36 sec, when you play it back it will show and play only 26 (or less) seconds. If it shows 16 sec, opening the recording and playing shows and plays only 8 seconds. The recordings SHOULD be the duration shown in the Event, but the recording itself is ending prematurely while motion is still occurring.

Settings for all cameras was for Person, Pets, Vehicles but not on just Motion
I changed this back to All Motion + the P, P, V
Turned off the camera for 30 seconds, then back on
Unplugged the camera for 1 minute, then plugged back in
Removed the license, turned off & on the camera, then added license back again
I had the IR lights off, turned them on FAR so I can now see the IR lights on the camera
NOTHING has changed this camera back to where it was before Wednesday where the Event and the Playback are the same duration.
All my cameras are on the Unlimited Cam Plus pkg for 100 licenses.

The Wyze App version is v2.38.0 (153)
Issue started on Wed after upgrading my V3’s to, was fine prior.
My V2’s and Doorbell do not have this issue at all.
Running on Android Samsung 8, Android Version 9
Has anyone had or heard of this before? Please comment!!!

I am sorry this is happening. I will get this info sent up to the team.

Could you please submit a log and let me know the log number?

Hi Jason,

I submitted the log, but I am unable to make the keyboard go away or scroll the text up in order to see what the number is. I’ve pressed DONE and tried everything I know to make the keyboard retract. I did put in the Description: “Wyze Jason requested this log for recordings shorter than Event duration” along with my name “Richard Leavitt” and telephone “214 384 4180”. Hopefully someone can find this log or tell me how to make the keyboard retract.

I didn’t realize they sent me an email with the Log #: 876998
I have 4 other V3’s that are doing the same thing if you want logs from them as well.
Rick (dabassmann)

They are asking for new logs, can you submit a log from a few cameras that have the issue? Also can you be sure to not restart the camera before sending the log as this erases the log portions that will help us.

I’ll do that tomorrow morning-ish. I’ll create new recordings on 3 or 4 of them then send the logs from each one without restarting or rebooting. It’s occurring on all 5 of my V3’s but not on my 7 V2’s or my Doorbell.

1st Camera 10:03 Log #: 877983 Event: 28s Recording 16s

2nd Camera 10:14 Log #: 878003 Event 22s Recording 13s
3rd Camera 10:14 Log #: 878007 Event 28s Recording 20s
4th Camera 10:24 Log #: 878019 Event 16s Recording 13s
5th Camera 10:25 Log #: 878022 Event 16s Recording 9s

The 4th Camera “almost” worked properly but you can see the others did not

1 Like

I did another test on the 4th Camera… see the last 4 recordings where 1 out of 4 was almost correct, the other 3 had the issue.
Log #: 878062
10:51 Event 20s Rec 11s
10:52 Event 15s Rec 13s
10:54 Event 15s Rec 4s
10:55 Event 22s Rec 15s
it is truncating the recording while there is still motion occurring. The correct length of the recording is always what is shown on the Event duration, which would give the motion + 8-10 additional seconds of wrap-up.

1 Like

Thank you, I have sent these logs up to the team.

Actually, thank you! Hope they can find the root cause and a resolution. As you can see, I am able to reproduce it pretty consistently on multiple V3’s. I am disturbed that no one else seems to be reporting this issue. @Slabslayer tried to reproduce it on his with the same update, but his seemed to work properly.
Let me know if I can assist with additional testing or testing a fix.

1 Like

Hi Jason,
I know it’s only been a week, but would you check with the team to see if they have discovered anything? The majority of 12 second recordings are only 4 seconds long. I thought 12 seconds was extremely short, but wow, 4 second videos are becoming somewhat frustrating.

I apologize for the frustration. I have not heard anything yet but I just poked at them to see if I can get some info. I will let you know.

Thanks Bro

Well I can tell you it is being looked into, they have dug into the logs and are talking about possible causes so hopefully I can get more for you soon.

I am having the exact same issue. List shows long recordings, but the actual video is much shorter. Any resolution?

Yep, having the same problems on our camera, also.

Hi drben,
Welcome to the forum. There’s no root cause known yet. Since you’ve joined the conversation in this post, you will now rec’v an email as posts from others are made.
Hang tight, fixes like these are rarely quick.

Same here. Playback recording of motion event is nowadays only about half of the actual event. The indicated time shown on the thumbnail pic is correct duration, but the video is cut off early, often right in the middle of obvious motion.

I thought I was onto something, but it didn’t work for all cameras. I formatted the SD card in one of the V3 cameras with the truncating problem, and it seems to have fixed it so the Event duration and the actual recording duration were identical. HOWEVER, I formatted the SD card in a second camera and ran 6 or 7 tests but the problem still exists. Most of the recordings would be 8 to 12 seconds less than the Event duration and truncated while motion was still occurring. So one camera seems to no longer have the issue, but the other 4 still has it.
UPDATE: the 1 camera that worked after the Disk Format, worked properly 3 times, but is now back to having the issue again. I guess it was merely a fluke that it worked 3 times. FYI, the camera I have on my Front Porch is always truncating the recording since that update.

1 Like