Problems with Scale X (wrong units and not caching data)

Hi there, just got a Scale X and am having consistent problems.

First off, it keeps reverting back to kg. I have it set to lbs in the app, and the results read as lbs in the app, but when the scale is used on its own it sticks with kg.

Secondly, I was under the impression that the scale saved readings and then uploaded them when it connects to the app. However, it seems to only upload readings when the app is actively connected. Is that expected behavior?



I was discussing this same thing on my Scale X in this thread:

I started having this issue in December, but I haven’t seen it in a week and a half now. To be fair, I always have the app open. I will have to try without the app open and see if I get KG again.

No, it should upload readings the next time the app connects to it. If it is not syncing your measurements, consider contacting support:

If they give you any info about the KG issue, let me know.

1 Like

Thanks very much, sent over an email. Will respond here if I get any clarity. Pretty frustrating…

1 Like

Having the same issue here. Scale won’t stay on lb.

Mine switched back to KG again last week sometime, and stayed there several days. I tried toggling the setting to KG and back to LBS to get it to switch back, but it didn’t work. I tried again a couple of days ago and it finally worked that time and it has stayed on lbs for a couple of days now, but I am thinking it is likely to switch back to KG again like it has a few times now. We now have 4 users confirming this recently started happening. I’m going to bookmark this to remember to bring it up in the Fix-It-Friday event tomorrow since it keeps recurring and we’re now up to 4 people reporting this. I wonder why it suddenly started doing this in the last couple of months.

1 Like

Mine is doing the same thing. Android and it happened after I weighed my dog!

1 Like

@Alliemc @jetsk1 @TimS01
I have reported this issue in this month’s Fix-it-Friday thread. If this issue is affecting you, I would recommend voting for it so that Wyze can see it is not an isolated issue:

I have the same issues. I followed the steps Wyze recommended for the kgs problem, but it’s still not working properly. I also miss my weight readings not being held in memory like the original scale. The only reason I ‘upgraded’ was to get a white scale.

Well, I don’t know why but this morning everything worked. It’s been staying in lbs for awhile and, after a few days of not even showing me anything other than weight, it’s started saving data and syncing properly again.

Maybe they pushed a fix?

1 Like

If this is still happening to anyone, please try the following solution and let us know if it still has problems:

Scale seems to be working correctly by showing pounds on the scale display.

Scale is still not caching any weight (that was taken without the app) and later synching when connected via bluetooth with the app open like the original scale.


I had the same problem where the scale showed kg and not the lbs I prefer and set. Following the instructions of others, I cleared the cache on my Android app, I signed out of the app and back in, and I think I may have toggled the kg/lbs button and left it on lbs. It’s been holding lbs for about 4 days now. I hope this helps.

1 Like

Sadly my scale reverted back to kg this morning. Pressing the Unit button wouldn’t work – never showed lb. Took batteries out for about 20 minutes and when I put them back in lb displayed. Will see how long this sticks.

I had the same problem where the scale randomly switched to display weight in KG. I removed the batteries and when I put them back in it restored display in pounds.

2 days ago I took the batteries out and put them back in about 20 min later. Pounds showed in the scale that day and yesterday. Unfortunately the scale was showing kg this morning. Rather inconvient to take the time to remove the batteries in order to get a scale to display lb.

I have finally gotten sick of the sync issues and everything else. I’m sending mine back. Hopefully the Withings scale is worth the extra $$ and works a little better.

Looks like these are old but I’m curious if a fix was ever found. Have the same two issues with my Scale X: randomly reverting to kg and, even more annoyingly, will not sync weight data until a live reading is taken with the app open (interestingly it then does push all the old synced data I believe).

I did work multiple times with Wyze support and they gave up, ultimately offering me a full credit (it was too late for refund). I haven’t gotten a new one yet since I don’t believe it will be fixed just by replacing the scale.

Also curious if this is happening with Apple users, as I’m an Android phone?