Problems scheduling my switches

I have 3 switches that function very well. They turn on and off their respective devices manually and also follow the RULES I have set up for them.

My issue is that I am currently unable to get them to respond to Schedules that I create for them. They respond to RULES but not schedules. I am able to input schedules into the app but they Do Not respond. i.e. No lights turn ON or OFF.

I have tried everything I can think of to no avail. If anyone has knowledge of how I can get these 3 switches to turn ON and OFF my devices (lights) by schedule, I would appreciate hearing from you…Thanks…tlhutch4

I am currently testing mine, let you know after the test.

Was wondering how you have your switch setup? Mine is set as a dumb switch so when pressed or used in my schedules, the regular lights come on.

I do use the Double tap, etc, to control smart devices. But the single press is setup to control dumb bulbs not the smart bulbs.


@tlhutch4 , I just tested by setting a schedule for 2:15pm to 2:30pm to see if the lights would come on and off. The schedule functioned as expected.

Will wait to hear from you on your settings, but wanted to pass on that I am not seeing the same issue.

I just noticed you are using iOS, I will test with mine as well. Could be iOS related.

OK - Just finished resting with my iOS device and it functioned as well.


Are you using actual times? Or are you using sunrise and sun set? If you use one, have you tried the other for troubleshooting?

1 Like

I’m attaching a screenshot of one of the schedules I tried. I’ve tried several and none worked. I just used random times to see if I could get it to work.

Have tried sunrise and sunset also to no avail

This is maddening….

Just out of curiosity, what firmware are your switches on. I tested a few more times last night and my switches followed the schedule.

Firmware version is 1.2.24 days it’s up to date

I just don’t get it.
Virtually everything else about my switches is working perfectly. It’s only the scheduling that doesn’t cooperate.

I was able to get a schedule and a rule to turn the switch on and off. The rule seemed to fire seconds after the programed minute(##:##:02) but the schedule seems to fire almost to the next minute (##:##:55 I believe it was). My only findings of note.

I don’t know where to turn on this. Seems like some technical person from Wyze will have to get the answers for me

I’ve been having the same problem for some time. I’ve verified everything is setup correctly, I did all the power cycling, deleted and re-set schedules, even deleted the switch and reconnected.

Have you had any luck yet? Im getting ready to give up and try another product.

Sorry to hear about your frustration with this switch scheduling issue but glad to know I’m not alone with this.
I have spent 2 days and countless conversations via this forum trying to solve this to no avail. Several people have tried to help me figure out what is going on but I don’t feel like I’m any closer to the answer.
I to am purplexed but nowhere near ready to change products. I’m too vested in my Wyze products now and feel like there must be an answer, maybe we can get there….tlhutch4

This is my first smart device for my home so it’s not a good intro. If you find a solution then please share on this forum.

Curious, have you contacted live help?

If you have time read through my post yesterday titled- “Rules for overnight”. It will give you some background on some of my conversations about this issue even though it wandered a bit….tlhutch4

@tlhutch4 , I went through the thread. Interesting what you are doing with the schedule.
My switch worked fine until my 2.4GHz signal stopped broadcasting from my modem. I fixed that and ever since then my schedule broke.
I can manually turn on/off the switch with the IOS app but the schedule simply doesn’t do anything. I’ve even tried simplifying it to turn on then off 2 mins later but nothing happens.

One thing on the back of my mind is that sometimes I find the light on during the day. I’ve asked my family if they are turning it on but all deny it. Makes me wonder if the switch “clock” is off so it is following the schedule but based on its own time, if that makes sense.

I’ve had a hard time troubleshooting it because I have too many people in the house and I travel for work. Etc.

For the last 10 mins I’ve been testing using a rule instead of a schedule and they appear to work fine so far. So I’m going to go with that and hope it works for the next couple days.

1 Like

I just don’t know but I don’t think it’s anything either of us is causing. Like I said previously I think we need help from a Wyze tech to get this fixed. I have no idea how to make that happen. Maybe someone reading our conversation can help get us connected to the right resource.

Rules are working great for me but I want the schedule to work as a backup if online goes down.


Actually it does make sense to me that the switch clock is out of sync. I’m not sure but maybe you are on to something. There is a way to sync the switches and plugs. However I need to find the correct way to do it first. I will post the question on the forum “how to sync a switch or plug”

This is what makes me wonder if sync is the issue. Yesterday I had a plug go offline and it was backed up with a schedule. Interestingly enough it fired ON and OFF but was way off the actual scheduled time (off by many hours).