Schedules Don't Work

I’ve been trying to setup a simple schedule to turn on and off my lamp sockets. However nothing I seem to do seems to make them work.

First I tried a schedule to turn them on, and a separate schedule to turn them off (see below).

However that didn’t work. So then I got rid of the schedule to turn them off (disabled it) and added a end time to the rule above. The lights still didn’t come on tonight.

I also have the all my cameras added to the schedule above, they just aren’t in the screenshot, as my lamp sockets seem to like to “float” between to the cameras.

Am I missing something obvious?

Welcome to the Wyze User Community Forum @OhioYJ! :raising_hand_man:


Good to see a fellow Buckeye in the Forum!

When the rules are “supposed” to execute, does it produce an entry in the Rules History?

Have you verified that the cams are on and streaming when the Rule executes? The cam cannot get the command from the server to turn on or off the Lamp Socket if the Cam isn’t on or doesn’t have power.

Verify that the lamp sockets are still installed and operating manually on each V3. Make sure the V3 Firmware is fully updated.

Have you confirmed that your phone time and the timestamp time on the cam are in sync?

Either of your Rules should have worked if the cams were operating at the time of the rule execution. Separate schedule rules with no end times or one schedule Rule with an end time should have done it.

Occasionally, I will test a rule that isn’t working by reversing the Action to Turn Off and flip the start and end times so that both are within the same calendar day (Turn Off Start 9a, End 9P) just to see if it will change something. I turn them on manually before I go to bed and see if it will turn them off in the morning.

1 Like

Thank you very much for the reply. So I checked, and it does indeed, say it’s turning on the lights (see below). However it is not. The schedule for “No Notifications from Mom” is so I don’t receive notifications for my mom’s cameras (located at her house), and this schedule has always worked fine.

  • The time on my cameras is correct, so is my phone.
  • The firmware on the cameras, is up to date, currently:
  • The firmware on the lamp sockets is

My network is a bit overkill, and in theory I should receive offline notices from my other IOT devices if something were to actually go down (So I don’t think it’s going offline). I am connecting to the cameras in some instances, like tonight to see if the lights came on.

Last night I ran a schedule on my Lamp Sockets similar to yours and it executed without issue.

However… I was running the previous Production Firmware. I just updated it to the new firmware and ran the same schedule Rule twice. Both times it executed. I couldn’t replicate it. But, I have only one V3 primary with the Lamp Sockets linked.

What I find interesting is that your rule shows executed and successful which means that the server pushed the commands. But, not one of the four cams actually turned its respective lamp socket on. Either the V3 cams aren’t getting the command or they ignored it. But, it is very hard for me to believe that all four cams didn’t get the command to turn on.

If I were troubleshooting on a setup such as this, the first thing I would do is to reboot all the cams and toggle the on\off button in the Live Streams to make sure the Sockets work. Then reschedule the rule to execute in the next couple minutes. If it didn’t run, next I would replicate the same actions in a shortcut rule and a trigger rule and see if that turns them on. Next would be removing 3 of the cams and testing on a single cam to see if either the schedule or shortcut rule would work.

1 Like

Out of curiosity, what bulbs do you use in the sockets?


That is why I’m almost starting to think it is a bug at this point. Only two of the cams at any one point control all 6 lamp sockets, however with this wyze stuff, the lamp sockets can freely “float” between cams. So in the front, I have 4 lamp sockets, but if there is a power failure, or a firmware update, I have no idea which camera will grab the 4 lamp sockets (same for the back). So that’s why I have all the cameras added to the rule.

I’ll try this this evening.

They are A15 LED bulbs, 60 watt equivalents IIRC. I had to use the smaller A15 bulbs as they fit the fixtures better with extra space the lamp sockets took up.

I should probably add, just setting them to auto, and sunset to sunrise does work. I was just trying to stop using this mode as it turns the lights on too early.

Therein lies the possible issue and I don’t know if there is a way to make that stop.

When the Lamp Sockets power on, the first 30s of operation is spent searching for another lamp socket to pair with. One would think that if the Lamp Socket has its controlling V3 plugged into it that it would forego this step, but apparently not. Unfortunately, I cannot test this as I have but one controlling cam.

At the point you are now, I would reset your setup. Turn off the power to all the Sockets and start one cam at a time. Power on the root socket for that one cam and then within 30s power on only those lamp sockets that you want paired with that cam and root socket. Once you have verified in the Cam settings that the appropriate sockets are controlled by that cam, move to Cam #2 and so on.

Once all sockets have been verified in each of the cam settings to be controlled by the appropriate cam, you can then retry the rule and see if it works.