Wyze lamp socket not following schedule times anymore

I have a set schedule to turn on and off the light at certain times but it recently stopped working. It worked fine for months but recently stopped following the schedule I put in place. Any idea why it stopped following the schedule?

Is the schedule a Wyze rule, a schedule in the lamp socket settings, or an Alexa routine?

Have you tried deleting the schedule and setting it back up?

It’s a scheduled rule in the lamp socket settings. I tried deleting and changing times with no luck.

Is bulb responsive when you try to control it manually in the app?


I would delete the camera from the app and try to set it back up. Strange issue your having

I have a similar problem. It started with after updating to the latest firmware update. Lamp turns on with motion but won’t turn off no matter how long the timer is set.
Any ideas?

Mine started happening after the update too.

So it looks like the last update for the lamp socket is what broke the schedule. Is there anyone way to notify the wyze team on this issue?

@WyzeDesmond could take a look.

1 Like

Thanks. I will take a look into this.

1 Like

@Whatyousay @rivnie What you try to accomplish here is to let V3 camera detects anything (like person or vehicle) and then turn on the light? And when the light turn on for certain minutes or seconds it will turn itself off?

1 Like

Yes exactly, which used to turn off within 3 minutes (or whatever the timer is set for). Now I find it stays on indefinitely. I have to manually turn it off.

I see. We are working on new rule functions like “turn on lampsocket for X sec”. Perviously some customers complain that sometimes the lampsocket follow the timer but sometimes it doesn’t. We are still working on the implementation on this. Thank for the waiting.

As for the temp fix for now, do you happen to have any wyze plug or wyze bulb on hand?


I use my lamp socket to turn on and off at certain times. I don’t use it for turning on during motion events. I like my outdoor lights to turn on and off at certain times throughout the night. It seems the new update made the wyze socket stop following the schedule.

Understood. Could you please go to app → Account → Rules → History and check if that rules are executed correctly?

1 Like

It says it succeeded but looking at my video playback it didn’t turn on my lights at the scheduled time.

Got it. Could you please submit a log for this lampsocket and V3 together. And also a snapshot of where it says “succeeded” so we can look at that certain time. And if you could please attach the video clip of that time showing the light didn’t turn off that will be great. If not no worried. Thanks!

1 Like

After more further testing, it looks like the schedules do take effect but then get quickly reverted back. It seems to always follow whatever the lamp socket control setting is set to instead of following the rules I put in place.


Just an update on my situation. Over the last few days it appears the timer started working again. Motion activates the light socket and the timer is correctly timing out after the set period. Could be something Wyze fixed on there side.