Problem with SD card (Fixed)

One of my V2’s wouldn’t connect today, checked for power reset camera, so then I took out the sd card (wyze sd card) and camera started working after a couple cycles, I tried putting the sd card back in and I hear the chime but camera disconnects. Also it says no sd card installed. Any thoughts.

Can you try the card in another device?
Have you recently done an upgrade?
If you can put the card in another device try to format it in FAT 32.

I was doing firmware upgrades/down grades yesterday and at least twice ran across card not recognized, but after successful change of firmware it all worked.


I will try to format the card in another device, I upgraded firmware over a week ago and everything was working fine since then.

Update, I just tried the sd card in a different camera and it’s not found in this camera either. Also it disconnected this camera.

Can you format it in a PC?


Gonna try that now.

So formatting the card on the pc did the trick, strange that this happened out of the blue, I haven’t touched the camera or did any updates in at least 2 weeks. Thankyou for the help.

1 Like

Glad you got it working!
And glad you wrote back. Too many people don’t reply once they get it working.

1 Like

The OP should also denote the post which solved the problem he had. That shows that the thread has a solution, which further helps fellow users to quickly find the answer to their issue #payitforward


I just had this happen to a card earlier today as well. ( completely unrelated to any updates or anything if anyone is wondering) this is caused by a card error. usually when this happens and you put it into a computer it will say it has a drive error and ask if you want to fix it ( do it).

then just format it and you are good.

1 Like

Exactly what I had to do, I’m still wondering what caused it just out of the blue.

1 Like

well typically an error can be caused by a few things.

  1. a simple read/ write mistake. could be caused by a glitch in writing software when a series of variables line up when they aren’t written like they are expected.
  2. a card being removed while it is still writing ( think of pulling a card out of your comp without doing the safely remove/ eject option first. ( something like an unexpected shutdown ( power outage ) could also cause this.
  3. an actual error on the card. happens when the card reached it life expectancy ( another reason we should be using endurance cards in these cameras) and even though there might be this type of error, it does not mean the cards can’t still be used. the odds of getting another error like this are just there for the foreseeable future.

these are just some reasons that might cause an error as you and I have experienced. nothing to worry about. but at least now you know a solution if it were to happen again :slight_smile:

What about “network” glitch?
I’ve been trying to download time-lapse sequences predicted to be almost 2GB.
They are bombing out at around 1.4GB, they create the *.h264 file on the device (viewable with VLC) but fail to create the time-lapse file viewable by the app.
Invariably if the SD card from the camera is put in my PC Windows flags it as having faults and seeks to repair it.

hmmm that’s an interesting one.

all the issues I’ve seen lately with time-lapse seem to have a common cause of the latest FW…so I did the reversion back to .33 and haven’t had any issues whatsoever. oddly enough though…even though I reverted back to an old firmware…I still see options for beta settings that I don’t think should be available…but whatever. I got my time lapses back in the mean time while they solve the lapse’ bug in the latest. I would recommend doing that currently if time-lapse is a needed option.

That’s what I did

Both versions bomb out at about 1.5GB.

This is running on an Amazon Fire 10, 32GB with 15GB free.

ill set up a lapse tomorrow ( a large one and see if I have the same issue.) if its happening with both of us I would say its the firmware.

what sd card are you running? I wanna say you’ve told me and I don’t recall.

Wyze 32GB.

I still havn’t seen any technical specs on the Wyze cards. I would love to know more about them but until I do im going to stick with cards I know the specs of. and when I say specs im talking simple things like MCL, SCL OR TCL. as obviously they all have their differences ( especially in durability, endurance and cross talk etc… )

Where are the specs in that link?

Heck, I don’t yet know what MCL, SCL or TCL stand for with respect to SD cards. :grin:

Most flash products on the market utilize NAND flash memory which can be sub-divided into two categories, SLC and MLC. MLC is by far is the most popular because it has a lower cost.

  • SLC (Single Level Cell) products store only one data bit per NAND flash cell which leads to faster transfer speeds, higher cell endurance and a lower power consumption. The only downside to SLC chips is the manufacturing cost per Megabyte. SLCs are intended for the high-end consumer and server market and they have approximately 10 times more endurance compared to MLCs.
  • MLC (Multi Level Cell) store two or more bits per NAND flash cell. Storing more bits per cell achieves a higher capacity and lower manufacturing cost per Megabyte. MLC products are designed for the mainstream consumer market.
1 Like