V2 time lapse problem worked around - up to 1.5GB - reversion therapy

/edit -
WHOOPS that should have been may 10 2019
Originally written May 10 - 2018

With the new-to-me reversion capability I was able to try a number of older firmwares. The latest Beta FW I found to work is, the latest released is Not ideal because I’ve got to give up RTSP possibility but time lapse is one of my critical needs.

For those unaware of the problem
I’d start a timelapse, it would end. I’d go to “view” it and would get a “file does not exist” error.
I went through numerous emails with support, formatting SD cards, reloading the app, etc.
Now if they could just get time lapse and RTSP/NAS I’d be a happier camper.

/edit 2 May 12th
Ran several “small” time lapse files on the order of a final file size of about 400GB. These worked fine.

So I tried running a longer Time Lapse
When I tried to download the image in the menu for downloading it reported a final file size would be 1.8GB.

The processing ran fine up to reporting 1023MB and 55%.
Then it switched over to reporting GB, not MB, 1.0GB 55% still predicting 1.8GB total.
It was processing it at a rate of about 8 seconds per %.
When it got to 84% and 1.5GB it stopped and gave the “same Wifi network” error.

In order to “process” it again I had to reboot the device, got the same results.
Looking at the directory → HL/API/timelapse/2caabe…/1557553…/video there is a file record.h264 1.53GB in size

/edit 3
This is running on an Amazon Fire 10, 32GB with 15GB free.