Ongoing Trouble with Wyze White Bulbs

I have been having ongoing trouble with Wyze Bulbs and am not sure at this point how to resolve them. I have had multiple interactions with support that have gone nowhere. I feel like Wyze is not quite listening to me nor have a full understanding of the problems. I need to provide some backstory, so please bear with me.

I used to have a single Wyze White v1 bulb in my bedroom. Eventually I added two more White bulbs, both v2. All the bulbs are linked to Google Home, and everything was working fine. At some point, I would start to experience failures; all of a sudden, I wasn’t able to communicate with one or more bulbs. Standard troubleshooting steps did not help. I would end up letting things “sit” (for example, if it happened at night, I would just turn off the lights physically and go to sleep; the issue would resolve the next day). But over time, I noticed more issues. At one point, I had Sun Match enabled on all three bulbs, and it worked for a time. Eventually, however, the v1 and one of the v2 bulbs had trouble with Sun Match. The v1 would “forget” its Sun Match setting (and even its custom icon) and I would need to go into the Wyze app to turn Sun Match back on and set its icon again. With the v2, I kept getting a message about needing to update the firmware on the bulb to enable Sun Match, despite the fact that the firmware was already up to date. I thought I had faulty bulbs, and that maybe the v1 needed to be upgraded. So, I recently purchased a brand-new 2-pack of Wyze White bulbs. When I set them up, at first Sun Match wouldn’t work for either of them, both giving me the firmware error message, right after I upgraded the firmware. After a few weeks, I noticed these brand-new bulbs exhibit the exact same behavior as the old bulbs; Sun Match worked in one but would “forget” its settings every so often, and the other would not allow me to enable Sun Match at all. This is how things stand today. I am at a loss as to how to resolve all this. I have tried all troubleshooting steps, talked to Wyze support multiple times, and still nothing. Last I heard from them was that they were aware of these issues but could not give me any updates nor a timeframe for when these will be resolved. I used to think Wyze had decent and fairly priced products, but now I am more skeptical, and I am not sure I would buy them again in the future.

If anyone has any insight as to what is going on here, I’d appreciate it. Otherwise, I continue to be frustrated and disappointed in a failing product that I once thought was pretty good

1 Like

Are they in a group?
I have noticed that sometimes some of the bulbs don’t do sunmatch well when they are grouped, especially with different version bulbs. This may be something we need to report in fix it friday.
I am curious if you notice a difference when they are not grouped together and if they work better this way.

Also, what rules are tied to all or any of these lights? Any automations?


No groups, no automation. Not using the v1 anymore, all v2. I do everything through Google Home. When I set up the new bulbs, I used the same names as the old bulbs, and they oddly exhibit the same behavior as the old bulbs. The new bulbs are malfunctioning in the same way the old ones did, despite being brand new and fully updated. Seems like there’s something going on on the backend, as if the old bulbs are not truly deleted and the new ones “remember” them

1 Like

When you say you do everything through Google, what kind of things? Do you do something besides turn the bulb on and off? If you ever change the bulb temperature (or the color on the color bulbs, which isn’t the case for you), it can disable sun match automatically. But if you set up sun match on the Wyze app and then just use google for only turning the light on or off, it should work okay to keep sun match. If you are having google set sun match, then that might be why it doesn’t work consistently (if the option isn’t enabled in the app.

(just trying to clarify to help narrow it down)

Have you contacted support about this yet?

I do use Google to have the one “forgetful” bulb gradually increase intensity (but not color I don’t think) before my alarm goes off (Gentle wake up). Maybe this is doing something that disables sun match. It didn’t occur to me that this might be the cause. It is unfortunate that this is the case, as I do like being able to use gentle wake up and sun match, and having to choose between the two is not great. I am not sure if this can be fixed, and if would need to be on Google’s end, or Wyze’s, or both.

This does not explain my other bulb, on which I can’t turn on sun match at all, despite the fact that the bulb is brand new and the firmware is already up to date.

I have contacted support multiple times about both bulbs, and didn’t get very far. Most of the time they ultimately suggest replacing the bulbs, which I have already done on my own, and it didn’t resolve anything

Just to clarify, you let support know it wasn’t working on the brand new bulb, and they didn’t get it fixed with troubleshooting and also didn’t replace it?

If that is the case, can you post a copy of your support ticket number for me and call out my tag @carverofchoice so I definitely don’t miss your response? I’d like to see if I can have someone look into that on your behalf so we can see if someone can get it resolved somehow or at least get someone figuring out what’s going on.

1 Like

@carverofchoice Yes, that’s correct. But to be fair, replacing the bulbs was something I already tried myself, and it didn’t help, so having support offer to do so would not have made a difference.

The most recent support exchange I had was ticket 2530373. I will note that at first, both of my brand new bulbs would not allow me to enable sun match, and then at some point after my exchange with support, without me doing anything in particular, one of them (the one I use with gentle wake up) suddenly allowed me to enable sun match (although it “forgets” this setting, which seems to be Google’s fault as we’ve discussed). The second bulb is still not allowing me to enable sun match


This is looking like a cloud/rule engine issue. The developers looked into the logs you submitted and had a few follow up questions.

  1. Have you set up the address in the Wyze app?
  2. Check under Rules - History and see if there are any executions of rules for those bulbs.

Thank you

1 Like


I have not set the address, should I?

There are no entries under Rules - History

@WyzeJasonJ @carverofchoice I am not sure if something was fixed on the backend, but my one bulb that did not have Sun Match working is now working again. I did not set my home address or do anything on my end; I just check periodically, and I noticed it’s now working. Thanks everyone for your help and suggestions. It’s too bad Google Home conflicts with the Sun Match feature. Maybe this can be fixed in the future.


I love to hear success follow-ups like this. I’m glad it’s working. Thanks for the update :+1:

Thank you for letting me know it is now working! Sometimes they are fixed by cloud changes. It is possible that was the issue here. As far as your other question about setting the address, this makes it so it can accurately do the sun match based on where you are located.