Notification delays today

Was checking to see if others were experiencing some delays in notifications today? This morning I noticed that I was not notified on my 2 outdoor camera’s when individuals walked in front of them. But the Garage Camera’s were. Then later it switched. I was also getting delayed notifications. I ended up unplugging the outdoor camera’s and plugging them back in, which seemed to help, but not 100%. In the afternoon, notifications started to come in again as expected.

Was there an issue with the AI processing as I have CamPlus or servers?

My setup is as follows:

Platform: Android 11 phone
App: 2.18.15
V3 FW:
V2 FW:

Testing the Beta FW and Release Candidate App.


1 Like

I just noticed that I’m not receiving any notification from my cameras:

IOS 2.18.16
V3 FW:
V2 FW:
Pan FW:

I’ve been having notification issues with Android 11 in general (I have a Pixel 5). This is despite disabling all battery optimization options, etc.

It does seem that if I go into the Wyze App, select settings, then App settings, then “Running in the background” that this helps a lot to make sure notifications come in okay for Wyze (though it annoys the crap out of me that I can’t minimize the perpetual full size notification that it is running in the background and keeps making me wonder why the top of my screen indicates I have a new notification when nothing is there but this notice that I can’t dismiss or minimize).

There are some apps that completely stopped giving notifications as soon as I got Android 11, and no matter what I do, Android 11 will never display them (such as from this Chess app I use). Most just suffer delay issues on and off, though it seems there are some that are possibly not affected at all.

Honestly I blame Android 11 more than I do Wyze or any other company because I see TONS of issues with lots of apps giving push notifications despite putting all possible settings to give me everything as immediately and high functioning as possible. It still doesn’t work right on lots of stuff. I keep hoping Google will resolve it, but I keep seeing tons of push notification inconsistencies.

I still run things on my deactivated Note 8 with Android 9, and it gets notifications right away from basically all apps without delays or issues.

Hence why I blame Google for messing with the notification changes. They just haven’t worked it out yet.

1 Like

I have also. However, I did run the ADB command so that my notifications are on par with iOS. I have been receiving notifications via the app in about 7 seconds (on V2) to up to 15 seconds (on V3 - but normally get it < 10 seconds on the V3). An occasional missed one. This morning is when my notifications were all out of whack. To the point of no new notifications at all - similar to @WildBill. I ended up removing the power from my outdoor camera’s and plugging it back in. Seemed to help some. But after 12ish, things started to pick up.

I will try the Wyze Background option, tried it before and did not notice any real difference. But maybe it will now that this is a new app.

I also have a Pixel 5 and blame Android 11. What is interesting to me is te fact that some of the Google apps also suffer from this delay. If those are suffering, wonder why they have not put something in place.

1 Like

Ditto, to all…

ADB, power cycle, cache clear, reboots galore.
Push notifications have been limited. Doorbell has been good, WCO, V2s, Pan Cam, V3, with or without Cam Plus…no Bueno. All Android 11 Note10+

My iPad has been wonkey so I can’t validate against iOS vs. Android.

My Alexa person detection has worked though.


My iPhone is up and running with the same issues as I am experiencing on my Android. I think it is something with the Wyze AI Servers. Or maybe the Release Candidate App.

Still not getting any alerts this morning…none. Any word from Wyze regarding an issue with the servers?

Mine became sporadic again. I decided to reset everything and then turned on all motion in addition to the AI.

I have found, and I believe @R.Good has as well, that setting a detection zone may cause issues on notifications.

I set a detection zone and it got worse, removed it and things started flowing.

I’ve also been getting delayed notifications or none at all on iPhone 12 ProMax. Currently on Wyze Outdoor Cam as well as V2 and V3.

Any chance someone from Wyze can check into this? @WyzeGwendolyn ? I checked my cameras and I don’t see anything wrong. They actually record video but not getting any notifications.

Same here. But the confusing part is that the event shows up in the event tab and Alexa announces it correctly as well. But no Notifications on the phones. I have sent in 2 log files for this: 143657 and 143658.

Hopefully this will help

Just for more information, my iPhone runs version 2.17.42 and it is not receiving alerts either. Also, my contact sensor alerts seem to work…maybe something with CamPlus/Person Detection?

I turned on all motion and am getting bombarded with a lot of Alerts now. I turned off All motion and left person on. Waiting to see again.

But I am experiencing the same thing you are. Hopefully Wyze has a reason or is working on something.

I would be willing to test a potential fix as an Alpha release if needed.

Motion detection seems to be a problem, generally. I was sitting watching out my front window as a person walked by with a dog. Three cameras failed to detect any motion.

I was actually thinking of changing my Wireless Mesh Setup - but it isn’t that. Everything else works and the Wyze Sense is working without issue.

My only issue is that the notifications do not get announced on my phone continuously. They do at times.

Signal Strength on all Camera’s are full signal.

@WyzeAndy , @WyzeGwendolyn if there is anything you or the developers would like me to try or run a Alpha FW to see if it corrects anything, feel free to ask. I am willing to test on either my Android or iPhone if you would like

@spamoni4 and I have provided a plethora of feedback in the Beta forums and logs, as this issue has been persistent across a couple of release. My guess is it’s in a backlog waiting for the right sprint to get worked on :slight_smile:

1 Like

I’ve been having issues the past week or so. Was thinking it was related to a firmware update, but it’s a new camera in a new location and so I can’t remember for sure how things were working before. But it’s been frustrating that I can check the events and see vehicle or person detection occurred and it uploaded to the cloud/saved to sd card, but yet it never notified me. I have notifications on only for AI events and they should have alerted me. I just had a UPS guy walk all the way to my front door (by my camera) and ring the door bell. Never got alerted. However my wife just peeked out to grab the package he left and it triggered. Like what?

It’s been so inconsistent. I’ve been working with support and they told me to factory reset and that seemed to fix it for like 10 minutes before it not working again this morning.

Been through all of that. Provided the logs. I think it is on the back end not sending the notifications announcement correctly or timely. I do get some, so maybe it is a performance issue on the server.

That’s what is so crazy to me, is that it’ll work one minute, and then not the next. My v2 camera if flawless with alerts. I don’t have cam plus on it, so it’s not using the AI detection and such, but motion alerts pop up on my phone almost right away. Which is telling me, at least in my situation, it’s not a problem with the phone or push notifications, but something from the cam/back end. I just bought 2 more v3 cameras and seem to be having the same issues, granted I only unboxed them last night.

A bit annoying depending on the level of traffic around your cameras, but…

I have had some success with Turning ON All Motion notifications, and turning off the detection zone. It will provide the AI tags… but you get notification of everything

1 Like