New Wyze Thermostat Configuration/Wiring Issues

Have spent many hours over the last two days trying to get my new thermostat working. Seems to all come back to the ‘Y’ wire not being connected on the Furnace side. I have tried several wiring configurations and I’m still having no luck.

Background -
Older gas * furnace/AC system. Wiring is unusual to say the least but I have gone through everything and validated it. (house 70+ years old, furnace 20+ years old, compressor was relocated a few years ago, a few splices)

  • I’m no HVAC guy but I’m technical and have decent electronics and electrical experience. I’ve reviewed all kinds of wiring diagrams and everything says the Y wire should be connected at the furnace but it isn’t, yet everything works fine with the old programmable thermostat.
  • furnace control board is Honeywell ST9120C 4057.

The main difference I see from ‘standard’ wiring is that The Y from the thermostat goes to the AC compressor and the return wire from the AC compressor goes to the C terminal on the Furnace controller. I have nothing connected to the Y terminal on the furnace side. I originally did not have a C wire on the thermostat so I tired the the C wire adapter and that did not work so I have installed a C wire one with an unused conductor in the cable. Validated all the wiring with the old programmable thermostat.

When running through the config on the app, it connects to the thermostat and says there is a wiring issue, however the wires are connected to the proper terminals. I can’t get any farther in the install process in the app due to the issue.

Current wiring in use is G, W, R, C, Y (Thermostat side only)

Tried moving the return wire from the compressor to the Y terminal in the furnace and using the new C wire and AC does not work then (even with the old thermostat). If I leave the Y wire that returns from the compressor connected to the C terminal in the furnace the AC compressor works. Heat works regardless

Any help would be appreciated.


Just realized I can add pics.

This pic shows how it is currently wired with the Wyze thermostat and I get the error. I suspect it has something to do with the Y wire. I have tried it connected to Y or C on the furnace side and get the same results.

Sorry to hear you’re having trouble. Your diagram doesn’t look correct. See the image below, please verify your wiring matches now that you ran a C wire from the furnace to the thermostat.

1 Like

Looking at your diagram the “Y” wire from the thermostat goes to the outside unit directly. There are usually two wires running to the outside unit. Most times it may be a red and white in a separate cable with one of the wires connected to the “Y” terminal at the furnace, and the other to the “C” terminal. The thermostat’s “Y” wire would run back to the furnace where it would be connected to the “Y” terminal. The thermostat requiring cooling would send 24 volts to the “Y” terminal where the second wire going outside would carry the 24 volts to the compressor contactor turning on the outside unit. The second wire returning from the outside unit would be the “common” wire completing the electrical circuit. Are the circled X’s connection points for the wiring? The second diagram posted by Brian is correct wiring for most normal installations.

Hey jimmy

Do you have more than one transformer for 24c?

Using a multimeter

The RC and Y should give you 24 v
Also RC and W should give you24v
And you guessed it RC and C should give you 24v as it’s the line common side of RC.

RC is the main power side of the transformer and should be providing the power side for both Ac and Heat. Y is for AC turn on, and W is for Heat turn on. C is common to provide stand alone power to the Thermostat.

Do you have pictures of your original thermostat set up and the furnace?


I’m not the one having problems. I was trying to help Keeder with his post.

The circled x’s are splice points in the wiring where the wires from the furnace meet the wires from the compressor and the thermostat. It is about 10 feet from the furnace itself.

So I’ll try extending the compressor wires back to the furnace and splicing the thermostat wires straight through to the furnace for simplicity. I’ve ordered new wire to replace everything because this is a mess :slight_smile:

I guess my root concern was whether there was something on the furnace side that was the reason the Y wire was not connected there. (see original wiring pic in post below).

Here is a picture of the original furnace wiring before the WYZE install.


As you can see, nothing connected to Y terminal.

Here is how it was originally wired…
Thermostat ----------------------------------- Furnace
RH+RC ---------------------------------------- R
G---------------------------------------------- G
W---------------------------------------------- W
Y--------- to compressor/from compressor------- C

I have since run a dedicated C wire (borrowed a spare conductor) but it is not needed for the current thermostat. With this current/original configuration and the old thermostat, the compressor will only run when connected to ‘C’ at the furnace. I wasn’t sure if there was a reason they did not wire it in a standard manner (essentially having the compressor in series) so I was hesitant to change it.

I’m going to try to wire everything as you suggest and see if that gets it working.

Thanks for the feedback and I’ll let you know how it goes!

The y terminal on the board is a dummy terminal you just hook your compressor hot to that one and your stat yellow to it which is the same thing your wires are doing outside the furnace. if you were to pull the board and look at the backside you would find there are probably no traces to that terminal.

1 Like

The wire to the compressor is carrying the voltage from the thermostat to turn on the condenser unit. The wire coming back to the “C” terminal is the common for completing the circuit. That is why the compressor would only run when the wire was connected to the “C” terminal. An electrical component needs three things to work. A source, a path and a load. The transformer is the source sending power to the thermostat (which is basically a temperature activated switch to route the power to the desired component-heat or air) the wires of course are the path taking the voltage to the “load”, the load in this case is a contacter (for A/C) which has a basically an electromagnetic coil which is pulled closed by the 24 volts fed from the thermostat. The “common” wire returns the unused voltage not utilized by the contacter back to the source. (the return path)

Okay, I finally got the time to tackle this again. I ran all new thermostat wiring from the furnace to the thermostat and removed the spliced mess in the middle of the wiring so it is a clean run. Works fine with old thermostat on new wiring.

Still have the same issues when trying to install the Wyze thermostat.

Took the Wyze thermostat and connected it directly at the furnace, same issues. (pictures below) I get the message when trying to install to check the wiring. As mentioned before, the thermostat powers up and when I run through the setup process it gets to the wiring check and fails every time. At this point I dont see how it can be anything other than a defective thermostat.

I wondered if the setup process on my phone is somehow in a stuck state no matter what I do, but I am unable to delete the partially installed thermostat from the Wyze app to try a ‘fresh’ install.

Again, appreciate any feedback or suggestions.


Why cant you delete it from the app? Just cancel the install if it hasn’t finished.
And have you tried holding down the button on the wyze until it resets?

I noticed this when setting up with the wyze app. When it ask you what wires you have for original thermostat make sure you choose exactly or else after wiring new thermostat it will not sync. So example if you have wires connected to R,Y,C,W, & G thats what you select in app no matter what color the actual wire is. I would just try again from beginning. Good luck

I canceled the install but if you try to edit from the Wyze home screen to delete the partially installed thermostat it says you have do delete the thermostat from the settings screen, which I can’t because the setup has not completed.

Try adding a new thermostat and ignoring the messed up one? I don’t know, I’m more of a hardware guy :slight_smile:

I have run the install several times from the top and i am selecting the correct wires. I originally did not have a C wire but instead of installing the adapter I just installed a C wire. I have now completely re-run the cabling, and the install process, with the same results. I have tried to connect the thermostat directly at the furnace with 1 foot of wiring and rerun the install, with the same results.

Interestingly I just ran the install without the thermostat even connected (it is in the box) and the results are the same - I get the wiring error screen. Not sure at this point if it has ever talked to the thermostat since i get the same results no matter if the thermostat is wired and powered or if it is in the box :thinking:

The “C” common is to supply power to the thermostat. Check the voltage of that wire to be constant 24v.

Just going to ask also, is bluetooth and location turned on your phone for the final setup on app?

I have 24VAC on R to C or R to ground. I do not have any voltage on any other contacts to ground.

Note that the thermostat powers up when connected but fails the wiring check process.

Bluetooth and location services were enabled when installing the thermostat.

Based on the error I’m getting (that wires are not correct) even though they are, and even when the thermostat is not installed, I feel like the installation process in the app is ‘stuck’ for some reason, giving me the same results no matter what is done. I can’t seem to find a way to remove the thermostat from the App to start from scratch, so every attempt is resuming the install process in the app. Is there a way to remove the partially installed thermostat from the app?

Not yet, but you should still be able to add a new thermostat? Just drag the messed up one to the bottom of the list and ignore it until they allow you to delete it.

Great suggestion. I will have to try that.