New User here, Cam v3 will not connect to Optimum WiFi

I received my Cam v3 from Amazon several months ago, and just now got around to setting it up. Well, it won’t connect to my Optimum WiFi. I keep getting “Cannot connect to local network” message. Optimum uses “Smart WiFi” in that you cannot choose 2.4Ghz or 5Ghz, it is auto selected based on quality/strength. Is that why the camera won’t connect? That would mean that I am screwed then?

Most smart IoT devices don’t play well with 5 and 2.4 on one ssid. If you can seperate them it will work.


You might have to do a little research to find it, but I remember there was an app that restricted the 5 GHz band on the phone. That way, its only trying to connect your IoT to your wifi. You might try that.


Obviously adding 5 Ghz to existing cameras is out of the question though. So the OP raises a valid question - what IS the best practice for adding Wyzecams to these twin-named networks? Is temporarily disabling 5 Ghz sufficient?

The OP has (had) same-named networks. SlabSlayer provided some helpful tips over here:


Well, when I called Amazon, they brought Wyze onto the line to support me and then dropped off. So Wyze DOES have phone support, they just don’t publish the phone number!

The rep told me I need to contact my ISP and have them split my Smart WiFi back into 2 separate bands. First of all, that’s unacceptable… Smart WiFi allows me to move around and always have the best signal and transfer rate. That’s a great feature, and you would need to purchase an expensive mesh system to replicate that functionality. Secondly, they are just flat wrong, that is NOT the only solution.

Solution I chose: Purchased an inexpensive TP-Link AP device that broadcasts on both bands. Connected the phone to that on 2.4Ghz temporarily, and voila I was able to add the cam to my network. Now I can see it on the network from my phone that is still using the Smart-WiFi router. Wyze support is pretty useless!

This is 2022 and people have been asking for 5G since 2018… COME ON WYZE!! They are woefully behind the times by not having dual-band cameras… there are other inexpensive cameras out there that do have this functionality, so it’s not cost or size prohibiting this. The v3 only recently came out, and they STILL stuck with 2.4Ghz only. Get with the times Wyze!!

What I really want to point out is how inept support from Wyze is… their recommendation is to call the ISP and disable functionality that I use regularly.

Contact info is available on website pages in the standard footer location by following the link, “Contact”.

You can also find this information on the Wyze Support Help Center page on a very large banner across the bottom of the page:


I understand you can also just dial 844-WYZECAM .


:exploding_head: Life Changing Event :exploding_head:

I knew they had a toll free number.
I knew it was listed on the bottom of the Contact Us Webpage.

Never knew it spelled out WYZECAM!

Thanks @Customer!


Wow… instead of acknowledging any of my valid points you only choose to point out that I missed seeing their support phone number… :expressionless:

It is a valid point, and that’s what the wishlist is for. Please add your vote so Wyze knows people want that feature.

1 Like

No. As far as I can see everyone here acknowledged your points, empathized with them, and tried to help you. Before he pointed out the phone number availability, @Seapup pointed you twice to appropriate previous suggestions on and solutions to exactly your dilemma.

Apparently one current best practice would be to temporarily turn off “Smart WiFi” long enough for a Wyzecam to find the 2.4 Ghz network. Your reaction is surprising.


This is a very good question that I have not yet tested because I have not had the need. Wondering if there are users who have done this. I might try it on my next cam expansion.

Theoretically, yes, it should work. We already know that the cams will log back into a new replacement router so long as the SSID and PW on the new router are exactly the same as the old one. So, turning off the Smart WiFi feature and the 5GHz and setting the 2.4GHz network to the SSID and PW that will be used for the dual band network should allow them to connect.

Then, reenabling the Smart WiFi dual band network with the same SSID and PW used on the 2.4GHz should allow the cams to automatically connect.

Also, I seem to recall a topic\post from some time ago that indicated there is was character length limitation for the SSID or PW in the Wyze login architecture. Anybody recall that? Wondering if that may be contributing here? Just brainstorming. (Light Drizzle)


Another feature that many of the smarter routers have is the option to turn on an iot Network. I have one of the Gryphon routers with this feature. It allows me to leave the smart band steering on for my primary Network but then set up any device that is more particular about the frequency up on either the 2.4 GHz or the 5 GHz iot networks being broadcast as well. I’m not familiar with the OP’s router enough to say if that’s an option there but something worth looking at.


I use Google WiFi hub V1. It has the ‘smart’ bands thing. Works OK with Wyze for connection. Playback pretty poor. If using google nest devices, drops out quickly. However Googles OWN Nest camera wouldn’t connect at all. Kept trying to login into main router not nearest hub. Had to get refund. Google have given up the ghost. NO SUPPORT & no support for group playback of Spotify. Google too busy trying to be WOKE rather than IT.

Best playback is connect to hub and then use Wyze app on Samsung Tab A (have bought 3 now) work perfect.

Try setting up your camera somewhere far away (out of 5gh range) then move it to where you want to use it.

1 Like

Tried that but when moved it was looking for the router hub I set it up on for some reason. Wouldn’t connect with nearby hub.