New v3 cams won't connect to wifi

New cameras give the message “cannot connect to specified network”. My router names both 2.4 and 5 ghz networks the same ssid, which might be an issue according to a forum post from a few years ago. But even when I turn off the 5ghz network altogether they still won’t connect. I tried re-installing the app, restarting the router, restarting the phone…

Is there a known solution to this? Or am I missing something with the setup process?

Make sure your SSID (network name) doesn’t have any “special characters” in it and that there isn’t a space at the beginning or end or something. Common issue in the past that I saw was someone using an apostrophe in the network name.

Also make sure you are using WPA/WPA2…WEP is no longer supported.

I’m not sure if the cams have a channel limit or not, but you could consider changing the 2.4gHz channel to something lower or more common like channel 11 and see if that helps.

I’m assuming it’s not a WiFi network with a landing page (it won’t work with those…ie: like how hotels make you click an agreement in a browser)

Make sure the SSID has a password (if it’s an open network, that’s likely the issue).

I’m sure you know the password is case-sensitive, but just in case, it has to be entered exactly.

If you’re still having problems, contact support, they can walk you through it. They can also have you use the RouteThis Helps app to see if there is anything weird going on with your network.


Thanks for those details.

There is a space at the end of the ssid, but there’s also one in the middle and I’ve entered them both when I try to sign in, can Wyze handle a space if the ssid is entered correctly?

My mesh router does not allow manual channel selection, much to the chagrin of users in that forum… Although the manufacturer does seem to have some reasons for that.

1 Like

My SSIDs have spaces in them and the Wyze products connect without issue. I think the Wyze products should be able to handle a space at the end of the SSID as long as it gets put into the settings, but why fight it? The bigger problem is probably having the 2.4ghz and 5ghz SSIDs as the same name and password. Can you temporarily shutdown the 5ghz SSID? I know many of the mesh systems allow that so that IOT devices can connect.

Thanks. I did try to connect Wyze after turning off the 5ghz and it still didn’t work so it makes me think there must be something else…

The router doesn’t allow different SSIDs for different bands.

Getting rid of the spaces in SSID would involve having to reconnect every device I have, which I guess wouldn’t be the end of the world if I knew it would solve this problem.

One work-around might be to set up the available guest network at 2.4ghz and try to have Wyze use that. but if I did that, would my phone always have to be on the guest network to interface with Wyze, or only during setup?

Only on setup. After that the phone can connect from anywhere internet is available.

Good to know. I guess possible downsides of that would be then having to leave the guest network on all the time, which could create more signal interference and in general another point of vulnerability on the network.

You can assign a password to the guest network so there is no vulnerability and I doubt it will cause any signal interference as long as it is 2.4 Ghz.

1 Like

No. Using a guest network does not [typically] change signal interference at all if you already have a main SSID in use from that router and leave the guest network using the same channel (in fact almost all routers force guest networks to use the same channel). Think of it more like having a second account login for the same service, The router isn’t sending out another signal exactly, it’s just accepting different credentials. Plus, guest networks usually enforce device isolation, which means any device connected on the guest network won’t be allowed to interact locally with any other device on the network. Thus it’s actually more secure. On the downside, if it uses device isolation then it will probably use internet to stream the video feed to your phone instead of everything streaming locally through the router (this actually using your upload and download limits from your ISP instead of staying on the router). Not a big deal for most people, but a minor downside worth mentioning.

I don’t believe so. the following support article indicates that a space at the end of the name is unsupported:

I believe that is exactly the problem here. You can test it out first though. Like you said, try the guest network and make everything the same except for the space at the end. Then try to setup the Wyze cam. If it works, you have your answer. Then you can decide what to do from there…

  1. You can keep using the guest network (including change it to a different SSID name so it doesn’t get mistaken as the primary SSID, then set up the cam again)
  2. You can change the primary SSID to not have a space at the end. I strongly recommend this option. In fact, best practices recommend not ever using spaces or special characters in the SSID name because a lot of devices are incompatible with them. I would honestly recommend only using letters, numbers and either hyphens or underscores (in place of spaces) in the SSID or it’s possible you will have more devices from other companies with problems on your network in the future. The longer you leave with with a space at the end, the worse it will get in the long term as you add more and more devices and eventually have something else not working as well (or at all).
  3. Any other choice.

May I ask, why would you put a space at the end of an SSID anyway? I’m assuming it was intentional for some reason. I am just curious why. I know my brother-in-law always puts a space at the end of everything, basically no matter what, even if something is the last word or sentence or anything. I think he uses a space as “end / done” in his mind, like a period or something, but I am not sure.

A space at the beginning or end of something is often intentionally programmed to be ignored in computers, so using a space at the end of something is taking a risk of incompatibility.


According to your post from Wyze support, spaces anywhere other than the beginning or end of the SSID should work. (Note the space in “Wyze Network123” in both examples.)

Screenshot 2022-10-12 at 15-04-37 New v3 cams won't connect to wifi - Cameras - Wyze Forum

1 Like

Thanks for all that info, really helpful. I’ll have to try to implement these things later this evening.

To your question about spaces, I think it was inadvertent. I normally avoid them for this kind of thing without fully understanding why it’s a good practice even if some tech allows for it. But in this case I think I set it up late at night and probably wasn’t at full mental capacity and since it worked at the time I didn’t really think about it until yesterday when this problem with the cams came up.


You are correct, a space in the middle will indeed work with Wyze devices. My suggestion to avoid it in general was not for the sake of Wyze devices, but to ensure compatibility with other things. For example, I have read of people trying to use Tasker to automate some things, and people were having problems with Tasker only grabbing the first word in the SSID and thus failing to do the things they want.

A lot of other IoT devices don’t support spaces anywhere. It is not uncommon for devices using some forms of ESP-32 chips to not be able to connect to a WiFi that uses spaces anywhere in the SSID. Some Github code (opensource code that any business might copy/adopt) has had problems with SSID’s with spaces in them.

Basically, you can use a space in the middle with Wyze, but don’t be surprised if a lot of things you want to do or add to your network end up failing or having problems because a lot of chips and code does not support spaces, even though they should. It’s just better to avoid it from the start instead of continuing to get farther behind and someday later when it’s even harder to fix getting forced to change your SSID just so you can do or add something you really want to. The sooner you make the change and enact the prevention, the better and less stressful it will be.

Though for people who really only connect a computer or phone to WiFi and are unlikely to add various other IoT devices, or never have very many, then it won’t be too painful down the road if it becomes necessary…but for someone like me with over a couple hundred devices, it would be a nightmare to have a space in my SSID and have to reprogram every single device to accommodate one new device or app or something that won’t support a space or special character.

Just a word of caution, not an absolute must.

1 Like

Makes sense. Thanks for humoring my curiosity. :+1:

I hope that resolves your issue. If it doesn’t, please let us know, or let us know what you do figure out. I am pretty certain that’s the best long-term solution though. :slight_smile:


I got the cams working after I removed the space at the end as well as a space in the middle while I was there, even though as noted above, the middle space may be ok with Wyze.

Thanks to you and the others for the help getting it off the ground!


I think that was for the best. Since you were already making a change, might as well make it as compatible as possible for the long term.

That’s great to hear everything is working well at making that change. I’m glad it got figured out. :+1:


Yeah it made sense to do it all at once, thanks for pushing me in the right direction!