None of my wyze devices will connect to my new wifi

I have contacted Wyze, but they seem to be just as confused as me. I’ve even tried to delete a Wyze device and reinstall it, but my wifi network will not detect ANY of my Wyze devices. I’m out of ideas. This is extremely frustrating. My entire home is full of Wyze devices and NONE of them work. I can’t even turn my lights on! This is crazy. I appreciate any help anyone can give me, because this issue is stressful. Thank you.

1 Like

Just set your new router’s 2.4 Ghz SSID and password to be exactly the same as that of your old one. (Every router supports this.)

Then everything will just work.


Did you rename the new ssid and pw the same as the previous ssid and password? It will also help to mention what brand and model your new router is, I bet there are some folks that have experience with whatever router you got that could provide some focused pointers.


100% agree with @Customer and @Omgitstony about making sure you name your SSID and Password the same. Note that the SSID can be case sensitive, so it is important to get the case correct as well. Not all devices are Case Sensitive, but I ran into an issue where I had issues with other devices because of this.

One other note, which I have done on mine and I seem to not have any issues: Turn off WPA3 and IPV6.

Also, as requested, provide the Router Information so you can get additional support.

1 Like

I appreciate the reply. I already did those things, and my Wyze devices still will not connect. It makes absolutely no sense. I’m on the 2.4G network (I disabled 5G). My SSID and password are exactly the same. Like I mentioned, I can’t even delete and reinstall the Wyze devices onto my wifi network because it won’t even recognize any of the devices. I’m stumped.

Yes. The SSID and password are exactly the same on the new router. Sorry, I probably should’ve mentioned what router I have. It’s a TP-link Archer AX90 AX6600 tri-band 8-stream WiFi 6 router. I’m not entirely sure it matters, but I have my ethernet cable connected to the 2.5 Gbps port on the back of my router, not the 1 Gbps port. As far as I know, that shouldn’t be an issue. I appreciate any help anyone can give. I’m pulling my hair out here.

The SSID and password are exactly the same on the new router. It’s a TP-link Archer AX90 AX6600 tri-band 8-stream WiFi 6 router. I’m not entirely sure it matters, but I have my ethernet cable connected to the 2.5 Gbps port on the back of my router, not the 1 Gbps port. As far as I know, that shouldn’t be an issue. So, turn off WPA3 and IPV6 while the devices are trying to connect, then turn WPA3 and IPV6 back on after the Wyze devices connect, right? Thank you for the tip. I’ll try that and let you know. Thank you.

Yea, I leave mine off as I don’t need those settings yet. I know Wyze is working on the WPA3 and have released it for some camera’s and devices already. However, some are experiencing issues with this.

1 Like

On my Ubiquity gear I had to enable “legacy wifi” something then on my mom’s router just a few days ago I had to enable a “801 b” something to help Wyze stuff connect to these Wi-Fi networks. If you can find a same or similar setting on your router I would enable that and leave it on. I forget their exact names but it’s something close to what I stated above.


Hopefully you don’t mean 802.11b, because that is really ancient and barely 10 Mbps.

For @caseymyhro the only other normal setting to match up might be the encryption type - WPA AES vs. TKIP etc.

1 Like

This was the setting I enabled in my Ubiquity access point so that I could connect my base station up wirelessly. Thought it may help here.


Well I even downloaded the manual but it is still not clear if they really mean just 802.11b (“i.e.” meaning correctly “that is”) or whether their concept of "legacy* also includes 802.11g (since some people mistakenly use i.e. to mean et al. or etc.).

It makes a big difference since overall network performance degrades if the AP will only talk to the Wyzecams at slow 802.11b speeds. (That’s why it’s off by default.)

And it also doesn’t make a whole lot of sense that this would be required anyway. :frowning:

1 Like

Put your old unit back in service untill you can have an IT person help you out

1 Like

Thank you for all of the replies. I ended up just temporarily disabling the 5G bands and was able to manually add most of my devices back onto my network. It took most of the day :expressionless: I gave up on trying to get them all to reconnect automatically. I’m still having issues trying to add the Wyze switches and plugs, though. I have 10 Wyze switches installed and was only able to add 4 of them. 6 of the switches still need to be set up, but it keeps saying no switches are found. As for the plugs, I have the older version. When I try to install the plugs, the temporary wifi network never shows up. I’m sure I’ll eventually figure it out. This has been one big headache. I guess that’s what I get for updating to the most up-to-date wifi hardware. :roll_eyes:

This appears to be an issue with a lot of smart home devices, not just with Wyze devices. I’m sure eventually, all the bugs will be worked out.

1 Like

Unless it’s a defined security issue, I usually run 1 version back (known stable) on router/switch firmware. YMMV.

It looks like WPA3 isn’t the default security setting for my Wi-Fi router. It was set to WPA/WPA2-personal. I still turned off the security, but that did nothing. I still can’t connect any Wyze switches or plugs. I’m starting to wonder if WYZE is having issues I’m not aware of. So far, customer service has been unable to help. I’m determined to figure this out.

I figured out how to reconnect my Wyze Switches! First of all, I’m disappointed in Wyze customer service. I love their products, but their customer service is lacking. I have been emailing customer service back and forth for DAYS, and not once did they mention holding down the Wyze switch for 20 seconds to reset it. As for the smart plugs, I’m still trying to figure it out. Thanks again for all of the responses.

I just figured out how to reconnect my Wyze plugs as well. You hold down the button for 5 seconds, and it resets it. Everyone I contacted from Wyze failed to tell me these things. I don’t get it. Wyze needs to educate their employees better. I have been in contact with them for over a week, and none of them even brought up how to reset the Wyze switches and plugs. Overall, I’m happy with my Wyze products, but Wyze customer service failed me.

1 Like

What about mac filtering being turned ON by default on the new router? Did any non-Wyze products have a hard time connecting to the new router…

It seems unlikely that holding the switch down on one IoT device solved ALL your IoT device problems. Maybe you got mired into a lot of device deletions and resets and had to resolve that, but if you had done the first suggestions from the start you probably wouldn’t have had any issues at all.