My new Cam-v3 cannot connect to network

My new Cam-v3 cannot connect to network.

Welcome to the community @wz8542

Can you provide a bit more information?

  • What are you experiencing, error messages or what?
  • What version of the Wyze App are you using?

Any additional information would be helpful.


Does you WiFi have special characters in the SSID?

I’m with wz8542.


The APP found the network name on its own. The camera scanned the QR code. Then the blue screen of death. Not really. The above message. Failed.

I tried the startup several times with the same result. I also moved to the room where the router lives, no luck.

WYZE ver V2.28.0 (102) on Droid

Spectrum network name: ViperPit



It worked now. I entered a wrong password that caused the issue.

1 Like

Maybe mark as solved…?

1 Like

My issue resolved as well. The automatic WIFI name detection wasn’t so accurate. I hit the dropdown box that had the wrong name and selected the correct one. Case closed.

Thank you for yore suggestions.


For people reading this thread, FYI, a corrupted SD Card can lead to a camera not booting and therefore not connecting to WiFi.

Remove the SD Card and power cycle it (unplug the power and plug it back in). Hopefully, this will cause the device to boot properly and connect to WiFi. Next take your SD card and format it in a another computer, you might see windows wants to format it when you insert it into a computer, since it is corrupted.

After formatting, put it back into your camera, it should now work properly. I am not sure what lead the SD Card to be corrupted.

Wyzecam admins, if you are reading this, maybe your troubleshooting instructions should have this step:

  1. Eject SD card and power cycle. Wait to see if it fully boots. Check the SD Card for corruption.
  2. If #1 doesn’t work, then proceed to the reset to factory defaults instructions.

Also FYI, if you didn’t eject your corrupted SD Card prior to the reset instructions (you skipped step 1 in the howto factory reset guide), your camera won’t reset if you hold the setup button for 10 secs.