My Experience with RTSP Firmware

I’ll be using this topic to document my experience with the Wyze Cam v2 RTSP firmware update.

Initial Configuration

  • Four IP cameras on the network
    • 1 x Linksys WVC80N
      • Over 10 years old, cost $120CAD
      • Runs at 640x480 and 30fps, narrow FOV
      • Full web server interface for configuration, no app required
      • Located in the garage
      • Connected to Netcam Studio
    • 3 x Wyze Cam v2
      • Latest version of hardware, cost $38CAD each
      • Runs at 1920 X 1080 and 10-15fps, 110° FOV
      • Uses an app by default
      • Located in: garage, kitchen facing out, front room facing out
      • Previously configured and managed via app on Android phone

Firmware Upgrade

  1. Accessed the Wyze Cam RTSP article
  2. Downloaded the Wyze Cam v2 RTSP file v4.19.4.48
  3. Exported contents, renamed to “demo.bin”, copied to MicroSD card formatted to FAT32
  4. Unplugged first camera, inserted MicroSD card, held down Setup button, and connected power
  5. Waited for blue light then left the camera alone for a while

Note: These were the steps used for all 3 of my Wyze Cam v2 cameras.


  1. Kitchen: Success
  2. Garage: Success
  3. Front: Error code -90
    a. Will attempt firmware upgrade again tonight

Camera Configuration

  1. Opened Wyze App and selected group
  2. Confirmed camera was present and video feed connected
  3. Selected settings gear > Advanced Settings > RTSP
  4. Entered a username and password and generated the URL
  5. Copied URL


  1. Kitchen: Success
  2. Garage: Success
  3. Front: Unable to test

Netcam Studio Configuration

  1. Remote into home server running Windows Server 2016 Essentials
  2. Open Netcam Studio Client
  3. From Home menu, selected “Add Source”
  4. Selected “Custom URL” and used the following:
    a. Stream Type of “RTSP_TCP”
    b. Pasted URL into Address
    c. Named source appropriately
    d. Set orientation to “Default” as this was managed by the Wyze app
  5. Added source
  6. Right click on source and select “Configure Features”
  7. For motion detection:
    a .Turn On
    b. Confirm Motion Algorithm to FrameDifference
    c. Confirm Motion Display to Area
    d. Edit Detection Zone and use mouse to paint area to monitor
  8. For Timelapse:
    a. Turn On
    b. Confirm intervals, duration, and encoding method
  9. Confirm updates using the check mark
  10. Right click on the source and select “Scheduler”
  11. Select “Motion” and click on each day name in turn to enable always-on motion detection
  12. Select “Timelapse” and click on each day name to enable always-on timelapse
  13. Confirm updates using the check mark

Note: For details of how to install and configure Netcam Studio, please refer to Guide: Installing Netcam Studio on Windows Server 2012 Essentials on the NCS forums.


  1. Motion Capture: Library reports success
  2. Timelapse: Library reports success

Initial Thoughts

  • For the cameras that worked, the upgrade process was easy and fast
  • The URL generation and copy to clipboard is a nice touch
  • I did not expect to be able to continue to use the application
  • This is amazing - well done Wyze! You have massively exceeded my expectations here!
  • I am very pleased with the RTSP support
  • I will be purchasing many more Wyze cameras and recommending them to friends

Thank you to the entire team for making this seamless! I will report back on my third camera over time.


Here is a side-by-side comparison within Netcam Studio of the Linksys WVC80N (left) and the Wyze Cam v2 (right):

You can clearly see the smaller FOV with the older camera - which is also giving 1 Frames Per Second (FPS) vs the 7 FPS with the Wyze cam. Note that this is via the client interface on my home server.


Here’s the same multi-view on the web interface from a remote connection:

This time the Wyze cam is displaying at 10 FPS - I can customise this via the Netcame Studio interface.


Firmware Upgrade Update

  1. Reapplied firmware update to Front


  1. Front: Success

Everything looks good. Once I have a number of recordings in my library I will review the results and summarise them here.

1 Like

Fourth camera arrived today. Heh. This is fun.

1 Like

Using the access token generated in Netcam Studio, I was able to add the feed from each camera to my Action Tiles set up for my home, which integrates all my smart home items together.

Action Tiles main panel:

Action Tiles Security Panel showing camera feed (landscape)

Action Tiles Security Panel showing camera feed (portrait)

I later set the tile height and width to 1h x 2w and it looked a lot better in both portrait and landscape.


Thanks for this thread, I have a question if you are other readers might know the answer to, if you put the RTSP firmware on a Wyze camera, will the Wyze camera still continue to work with the Alexa voice commands ?

I have an Echo Show, also a Fire TV stick, and I can say “Alexa, show me the (name) camera” and it will appear on my TV or Echo Show and I want RSTP but without losing the Alexa connectivity.

I do not know, as I am not using Alexa or Google Assistant.

Thanks for replying anyhow, maybe someone else who reads this thread later and uses Alexa might know.

Camera disappears in Google Home/Assistant, still shows up on the Alexa app, but I couldn’t get it to show on the Fire TV stick 4k (alexa just says the camera isn’t responding) .Reverted to non-RTSP firmware and the camera shows up again in Google Home. Still can’t get Alexa to work even after reverting.

Yes, a WyzeCam enabled for RTSP is still accessible via Alexa. Probably for the same reason its still accessible via the WyzeApp cloud access.

Thanks for the alert, that makes me leery about trying RTSP as I do not want to lose access via Alexa. A later reply by MMediaman says it is accessable, I’ll ask him for further details, maybe he has a way to get it to work,

In an earlier reply by Drift he says he couldn’t access with Alexa, do you access your RTSP Wyze cam via Alexa with a Fire TV stick or an Echo Show ? Maybe you did something to get it to work that he didn’t know needed done ?

I am using a Fire7 Tablet to run Alexa. I did find that I had to disable and re-enable the Wyze skill, which included re-submitting my account credentials. But I don’t think it was related to RTSP since I couldn’t access my non-RTSP Wyze cameras when I first tried.

Anyway after re-enabling the skill I can Alexa access all my Wyze cameras, including the ones with RTSP.

Okay, thanks, I appreciate the info, I wonder how much longer the RTSP will be in Beta, if not real long I might opt to wait.

Further Updates

  • Need to assign 4 Wyze v2 cameras to a set of static IP addresses
  • Assigning a range of to manage cameras on network

Static IP Assignment

  1. Access Netgear Nighthawk R7000 router
  2. Select Advanced | Administration | Attached Devices
  3. Locate each camera and compare IP address and MAC address against camera details in Wyze app
  4. Edit each camera to have an appropriate name and type (example shown)
  5. Select Advanced | Setup | LAN Setup
  6. Scroll down to Address Reservation
  7. Click Add and select camera - taking care to match IP address and MAC address
  8. Set the new IP address range (starting from 51) , and do this for all cameras
  9. Review results on Address Reservation screen (example shown)
  10. Reboot router and restart each camera
  11. Check results and adjust connections in Netcam Studio to reflect new IP addresses


  1. The IP address for each camera was changed: Success

Continued good results here, I’m very pleased.


When adding a camera to Netcam Studio I am using the “Custom URL” option as shown below:

Both RTSP_TCP and RTSP_UDP work. Is there a preference for which stream type I should use? Are there any other settings for a V2 that I should consider? This is useful information, because I can pass this to the developers of Netcam Studio so they can create an entry in the Network Camera section for Wyze devices.


UDP is usually better for streaming since any lost packets are just skipped over, typically resulting in a lost frame. TCP confirms each packet was received and re-transmits any lost packets, which usually isn’t desired since the frames are time-sensitive. RTSP negotiates via TCP but typically sends the video stream via UDP, so I’m honestly not sure what each of those settings do in this context.


Has anyone had problems installing the firmware?
I format the sd card to FAT32 then rename the file to demo.bin then put it in the camera.
Then i hold the setup button and power it up. It flashes yellow and says ready to connect. It never does the flashing blue light.

Any ideas?

I got stuck on this step as well - try renaming the file as ‘demo’ (no quotes, minus the .bin part). If you’re on Windows 10 like I am, it may be hiding the .bin file extension in explorer view - renaming the file to ‘demo.bin’ results in ‘demo.bin.bin’ which the camera isn’t looking for,