Problems with Wyze Cam v2 and v3 with RTSP

So I have decided recently I wanted to try to do some experimenting with implementing RTSP on my Wyze cameras. I have both a v2 and v3 version.

For the Wyze Cam v3, I flashed the camera today with the RTSP firmware from Wyze, and currently my camera is reporting a firmware version of, and then of course I went in and enabled RTSP, put in the username and password, and generated the URL.

For the Wyze Cam v2, I did the exact same thing, except the firmware for that is version

I can see the cameras show up on my firewall and the pull an IP address, and that IP address I see in my firewall matches what I see in the device info on each camera, so I know they are participating on the network, and I’m also able to view each camera from the Wyze app. The first thing of concern to me is that I am unable to ping the cameras, and so I’m not sure if I should be able to ping them or not, as I don’t know if they support ICMP, but being unable to ping them was of concern. I know my PC is on the same network subnet as the cameras, so there should not be anything in between my PC and the cameras to block access, so this is a red flag to me, but it could be perfectly normal as well, so that is just an observation I have made.

The issue I am having is that when I take the URL that is generated when setting up RTSP on each camera and then go into VLC Player, click on Media in the menu and then click on Open Network Stream and enter the URL that the Wyze app generated for me, I am unable to see the video stream from either camera.

Ultimately I want to get these working in Blue Iris, but for now I will settle with just being able to diagnostically being able to see them in something just as simple as VLC, and right now I cannot get it to show in there or in Blue Iris.

From what I have described above, does anyone have any idea if I am doing something wrong trying to get these cameras to display an rtsp video stream via VLC?


Just a quick update. Is there another way I can test the RTSP on either of those cameras to see if things are working as they should? If the firmware didn’t take on either camera, I would expect that I would not have an option for RTSP, but I do, so I believe the firmware is installed correctly, and I know they are working on the network, as I can see the DHCP lease from my firewall, and the cameras still work in the Wyze app, so I’m just at a loss as to how to to troubleshoot this and if maybe I have configured something incorrectly?

I have nearly all my cameras setup with RTSP. VLC is the easiest test to see if it is working. If you have the RTSP options in the Advanced settings then the firmware is correct. Not sure if you may have something on you network blocking RTSP, but it is a possibility. If you can reach the cameras with the Wyze app, they are on the network and the IP reported in the settings should match what you have on your router. Just tried to ping one of my cameras and it did respond.

Do you have your network segmented in some way? Different subnets? Firewall blocking? etc…

URL for VLC should be something like:


So as it turns out, I have an older Dlink wireless router that I’m not using as a router, I am just using it like an access point, but it is old enough that it does not have an “access point” mode on it, so I just don’t use the “internet/wan” port on it, which is a poor man’s access point. Since I never use that as a “firewall”, I never really messed with the firewall settings on it, and it has always worked for us for years as is.

So after thinking about this, I got into the firewall settings and disabled everything in there I could find, and then rebooted it, and now I am able to ping the v3 camera, just no the v2 camera. LOL It would seem there was something in the wireless device that was in fact interfering with the RTSP connection, despite the fact I am not even using any of that side of it, but it is still impacting things just the same, So at the moment, I do at least have the v3 camera working, and really, that is what I was wanting to work anyway, so even if I don’t get the v2 camera working, it was just sitting on the shelf anyway, so I guess it can just go back to sitting on the shelf again. :stuck_out_tongue:

This tells me that I really just need to break down and upgrade my wireless here at the house, as we really need to do that anyway, as it has been quite some time since I have done much with that side of things, so upgrading should help things, even if it does not help my v2 camera. I am now a little perplexed as to why the v2 camera is not work. despite the fact it is setup virtually the same as my v3 camera is, and they are both connected to the same wireless device, so if one is working, the other should as well, but at the end of the day, I’m not super concerned with it now that I at least have a v3 camera working.

Thanks for the nudge there to get me to really delve into the wireless router, and at the very least I have one camera working, which is the one I actually use anyway, so that is good enough for me at the moment. :slight_smile:

Does anyone know if the forthcoming software/firmware update is going to affect cameras flashed with the alternate RTSP firmware? Will they too be automatically updated and suddenly stop working? Or is RTSP support finally going to be included in the standard firmware?

I use dd-wrt on some of my old routers to use them as APs. Don’t know if it would run on yours but it would give you greater flexibility with the configuration.

I haven’t heard anything specifically on RTSP, though I asked. Wyze has always said that RTSP would remain an offshoot from the production firmware and, so far, has never pushed a firmware update that overwrites it.

I have all my cams on normal FW except one that has RTSP the other day the camera that is on RTSP FW stopped working with my voice assistants
I have tried normal troubleshooting , reboot router, reboot camera, reboot echo show, the camera is not responding still , all my other cams are working in both Alexa and Google but not the one with RTSP
I think I am on an older version of the RTSP FW
it says
do you happen to know how many versions of the RTSP there are for the V2 and which one is the latest one ?
could you post a link to the latest V2 RTSP FW
sorry I tried searching myself but this forum just sucks , the layout is visual cancer and it is impossible to navigate , I don’t know what you call this style of forum layout but it sucks and I can’t find anything on here I don’t know why they went with this garbage instead other forum layouts cause it sucks, do they even have an RTSP thread with all the RTSP FW’s organized by camera versions because I can’ find it
the layout sucks, the search sucks ,and this whole forums just sucks
smartthings uses the same one or a similar one but wyze forum is much worse
I hate them both but I hate this on the most , it’s just garbage

Current version is for the V2. Here is a link to everything for RTSP:

1 Like

Do you happen to be running the older versions and using a voice assistant?
I am seeing other people having an issue with voice assistant for only only camera
I think it is for V2 pan though
I am wondering if flashing the newer RTSP FW will solve the issue
how is latest RTSP working , and is it a beta?
I am wondering if I will get other improvements besides it making it work in Alexa/Google again , maybe better motion and person detections and a more stable RTSP stream hopefully,
have you noticed any downsides from updating to the newer RTSP FW if you were on the older one before this I mean?

No RTSP for Pan V2 …only Cam V2, V3 and Pan Cam original. All RTSP is considered beta.

6 posts were split to a new topic: V2 RTSP functions not showing

My four V2’s with RTSP have been a bit recalcitrant about maintaining connections to the Blue Iris software I’ve been using. I updated to the latest version (5.2.something I think) but there have been two issues that I’ve resolved that seems to make BI work properly for me:

#1. The Wyze cams periodically change IP addresses. Maybe there’s been a power outage and, when they power back up, they now have different IPs and, of course, BI doesn’t know how to deal with that. The resolution was to reserve specific IPs for each one in my router’s DHCP section. I use AT&T and the gateway they had provided will not save any settings on “page 2” of that function; this is a known issue - when I chatted with the customer service guy and told him about it, he verified it with his techies. He then provided a new gateway of a different model and all the V2s now maintain their IP addresses. Obviously, there’s no method to manually assign an IP within the Wyze app so this is the accepted workaround.

#2. Periodically, the V2s still disappear from the network (as far as BI is concerned). The Wyze app still can see them but BI will not. I had tried using the restart command in the app but this did not always fix the issue. Pulling the power plug and re-plugging the affected cams did always fix the problem but I’m not always home to do this. My workaround is to plug the cams into 24-hour timers. Once a day, the timer turns off the power and, 30 minutes later, turns power back on.

Elegant? No. But these workarounds do the job.

I have RTSP enabled on all 9 of my v3 cameras. I have it running through a free multiview software by Luxriot. GREAT software program with lots of functionality (both LIVE and Recording). Just a few steps to get everything setup, but nothing too hard! Check it out… Luxriot

Intersting. My v3’s drop off both the Wyze app and my Agent DVR system about every 12 days. Power cycling restores them. I hope Wyze fixes them.

Is anyone not able to access the RTSP firmware page -

I’m getting an error as below. @WyzeGwendolyn

1 Like

I will get this reported, thank you for letting us know

1 Like

Looks like its working now. Comes up for me today. It didn’t the other day.

So you can access the article but not the files:

RTSP was considered a beta feature and we are currently assessing the path forward as the firmware versions have aged quite a bit. We have removed the firmware files for these versions for now and we’ll update the pages when plans are finalized. Please note that firmware files take a while to work on and test so you may not see an update in the near future. We apologize for the inconvenience.

1 Like

Might have to do with security flaws? It would have to be quite important for them to remove the files.