Mode switch failed. Please try again

I have an issue arming my home monitoring via the app. I am getting Mode switch failed. Please try again

I have attached a screenshot.
It is really getting frustrating with wyze.


Seems to be working now with the latest update.


@tedd. Glad it is working now…

I get this error occasionally as well. It has to do with a loss in communication between the app and the hub.

When I am on WiFi connected at home but then leave the house, I will get that error if the app is still open but the WiFi is out of range. I have to turn off the WiFi and then reopen the app to force the LTE connection. Then it works.

1 Like

It seems like I spoke too soon.
I am still have the same problem.
My wife is having the same issue.

It does not show as armed in the events

Not sure why it’s not populating the events section or failing to arm… Especially if it is occuring on 2 app devices. I am on an older stable Android app version, so I’m not sure if it is the new app version, the cloud, the hub, or the multiple WiFi \ internet connectivity possibilities between the three that would be causing this.

My troubleshooting steps would be to run it thru it’s paces in test mode and try to narrow down the conditions when this happens. Given the issues the hub has endured in recent Firmware updates, I would seriously consider NOT updating or resetting it unless it is fully nonfunctional.

  • When it does this and shows armed, will it trip the alarm?
  • Does the armed state change if you log out and back into the app when this happens (does it refresh from the cloud with new accurate data)?
  • Does the app refresh with new data if the app device connection type is changed from WiFi to cellular or vice versa before reopening the app?
  • Is there any audible feedback from the hub when this happens?
  • Does it do this on both WiFi and Cellular device connection?
  • Does it do this when armed and disarmed only from app devices or does the keypad arming also do this?
  • Does it do this when Hub is on WiFi and Ethernet? (Ethernet is preferred because there is no Network WiFi congestion or connectivity loss to deal with. Also, setting the hub as a priority device in the router is a good idea)
  • Does the “More” event history reflect the same?
  • Are notifications being sent when armed from the keypad when this happens?

Then, with this information, I would submit logs for the Hub and the App to Wyze (could be either) and contact Customer Support with your App versions, your hub Firmware versions, and your log numbers to open a ticket. Make sure you get a ticket #. Share with them your test findings and if they can’t pinpoint the issue, ask them to escelate the ticket.

Good luck! Post back with what you find.

Thanks slabslayer.
I have tried all that you have suggested but I am still having the same problem.
I downgraded my app to the may release.
It is so bad that I cant disarm from the app.
When the alarm goes off, I dont get a text/call from moonlight.

I just uploaded a video of the issue
It happens when disarming too.
I have three phones having the same problem.
Wyze’s quality control has gone down the drain!

It sounds like the app is communicating thru the cloud to the hub as I do hear that the hub is responding to the Armed Away command. It responded immediately so I assume you have the exit delay set to zero. Couple that with the fact that the hub is alarming with a siren locally when tripped which means the hardware is infact arming properly.

If you arm and disarm with the keypad, I suspect it will shut off the alarm.

All this would make me suspect that there is some issue with the verification of your subscription with Noonlight. If you are in test mode, it won’t contact Noonlight but you should still receive a push notification.

The fact that you can’t shut off an alarm in the app also makes me suspect your subscription is the root of this. The disabling of the tripped alarm requires entry of your code within a Noonlight pop-up keypad on the screen. Without verification of your subscription on the account, I doubt this disable feature would work.

Verify that your Account>Services tab shows your Home Monitoring subscription properly. You can also contact Noonlight to see if your subscription is active and when the last activity was. This will give you an indication of when the problem started.

But, it looks like a long conversation with CS is in order.

As you can see from the video, after arming/disarming the loading circle continues to spin endlessly.
When I arm or disarm on the keypad, it does not reflect on the app. I think too that there is a communication problem with their server.
My monitoring service expires next year April, so it is not that. I spoke to customer service and went through the troubleshoot step and it was determined that something is wrong on their end. I am waiting to see if it gets fixed. It seems to not be a wide spread issue and dont trust it gets prioritized.
Nevertheless, I cant be paying for a service that does not work!

1 Like

Agreed that this looks to be isolated on their end with your subscription. Also agree you shouldn’t be paying for security you don’t have.

See what CS replies with and if they can isolate and fix the problem. Be sure to get a ticket # from them so that you can escelate it if necessary. There are ways to get Wyze’s help here in the forum, but it is best to let CS exhaust their resources first.

So, it has been resloved.
I hope it is permanent this time.
I was on the phone with support and the had to reset my service on their end and have me reset my home monitoring hub.

1 Like

That is great news! :partying_face::tada::raised_hands::+1:

Make sure you give your last post the SOLUTION checkmark :white_check_mark:!

Yes, let’s hope it is permanent!

Just an FYI, they just announced a Firmware Beta is in testing for the hub that will contain some much needed fixes. Keep an eye on that thread to see how it proves out in testing.

I will.
Thanks for you help!

1 Like