Mesh router Pro - unable to obtain IP

I had an issue with all 3 mesh routers pro that last week, they suddenly stopped broadcasting internet, rebooting did nothing and i confirmed my spectrum internet was working fine, eventually i had to factory reset the devices - but attempting to re pair in the app, they would always show the error message “unable to obtain an IP address”.

after speaking with a wyze support, it seems like they could not fix this issue (and it appears to be a known issue according the to the below doc) so are issuing a credit… However as this issue only affects certain chipset models, im reluctant to buy replacement wap’s till i know the issue has been resolved either by firmware of a new chipset? appreciate any thoughts from anyone who knows about this issue, thanks!

From the post by Support:

**Note: This issue only happens on modems with Intel Puma 6 or Puma 7 chipsets. **

That’s referring to your ISP modem. Per the same post, Wyze is working on a firmware fix for this. Nothing gives any clue to how soon this will be fixed. You might want to post your issue to “FixIt Friday” and hope it gets enough votes to be considered.


noted, its just weird how i was able to set up the routers originally and use them for 6 weeks without any issues… but when they worked i was very happy with them.


There is a Beta Release which indicates the following:

Wyze app Release Candidate, Cam Pan v3, Mesh Router & Mesh Router Pro Firmware Beta Test 4/6/2023 - Beta - Wyze Forum

You can try going to your Wyze App, Select Account, then About, then Beta Program.
Choose Edit in the top right and select Wyze Mesh Router Pro and click save.

Once you do this, you shoul dbe able to get the Beta FW for the router and see if it corrects your issue.

Realizing you may not be able to get out on the WAN to get the FW, you could plug in your old Router, connect the devices through that and then do the update. Basically setup another Network to get the update. Just a thought.

Welcome to the Wyze User Community Forum @awb73! :raising_hand_man:

When I first set up my Pro router onto my ISP supplied Fiber ONT, I got the same setup message… over and over again… Unable to Obtain an IP address from the ISP. I probably tried dozens of times and power cycled the ONT and router about as many.

I had plugged my Pro into the same Ethernet port on the ONT as the old router. For whatever reason, the ONT was still expecting the same old router on that port and wouldn’t allow the new router. As soon as I moved it over to port #2, I got an IP.

Other users have also indicated that some modems\gateways\ONTs have a similar memory for devices that will be cleared when the device is unplugged for an extended period so that the RAM clears.

Might be worth a shot. :man_shrugging:

1 Like

how would i download the beta firmware to the wyze router though as i cant connect to it/set it up? thanks!

Start the App then…

  • Go to Account
  • Go to About
  • Go to Beta Program
  • Select Edit - Top Right
  • Scroll down through the list and toggle / Check the Mesh Router Pro (MRP) option
  • Select Save at the bottom

This will enable the Beta Firmware for the MRP. You can also select other devices if you are so inclined.

Then go to Firmware Update page in Account and see if an update is available. You can also go to the MRP on the Home Screen, select Settings icon, top right, and scroll down to Device Info. From there you would select Firmware and see if there is an update for you. Note: you may be prompted for the update when you start the MRP

If you would like to take the Next step and Beta Tests apps, you can go here and sign-up:

Become a Beta Tester – Wyze

1 Like

If the router fails to install and never shows as an “Online” device in the App, there is no way to manually flash firmware. The router must be installed and online to get the OTA Production or Beta Firmware updates.

Have you tried shutting the ISP Modem down for an extended period with nothing attached to clear the RAM, then turning it on with the Root attached but off, then turning on the Root with both nodes off and trying the install again?

That is True. What I had done in the past is setup the router on my existing network with a different SSID as a different network. I then connected to it and performed the update. I did this as a test when I received the Standard Wyze Mesh Routers. Wanted to play with them before I did the switch. :slight_smile:

1 Like

Yes, if another network or ISP Modem is available for the install, and the install is successful, this is a viable workaround route just to get them online so the OTA Beta update can be applied before factory resetting and starting again from scratch on the problem ISP modem.

1 Like

yes i had a few in depth phone calls with wyze support where we went thru several attempts of power cycling/shutting down all components for extended periods and powering up specific pieces in timed intervals… alas no joy - support was very quick to offer me a credit and im returning the units… which is sad as when the units worked, they were blazing fast!! - but the bigger question is when it will be safe to reorder - when a newer firmware fixing this issue is applied to the routers before they ship.

I worked around this issue by using the app to set it up until I reached the “unable to obtain an IP address” error message.

Then I plugged a cable into the other port on the wyze router and connected my mac. I renewed my DHCP lease on my mac and got an address in the 192.168.50.* subnet. Then I was able to connect to and access the web interface for the router. From there I could set a static IP address for the router in the subnet my modem was using internally.

After that, I needed to go back to the phone app for the rest of the setup.

1 Like

Just curious…do any of those having this problem have any active firewall rules blocking pings? I had a similar issue and once I modified my firewall to allow ping packets the problem went away. Seems it was a known issue with the Wyze engineers.