Mesh Pro Router Installation Fail

My Mesh Pro routers arrived today. I plugged in my Fios Ethernet cable into the 2.5G port, powered it up, was able to connect to bluetooth, gave it a name and password, then it just sits on the “setting up your wifi. This will only take a minute or two.” message. 10 minutes later, I cancel it.

Now I have a device added and there’s no way to delete it from the app. Every time I open the device on the app, it tries to save the network setting and times out and pops a retry window.

So I tried it again with the other router, and got to the same point, waited 15 minutes this time before cancelling it.

Now I have two devices in the app that I can’t delete.

I’m ready to pack this crap back into the box and send it back.

To delete it from the app and try again, go to the home tab, then select the pencil icon on the top right and select Edit devices, find the Mesh Router Pro and select the red circle with a minus sign on the left hand side.

I had a friend who had to go through setup a second time too. I am not sure why that has happened to some people and not others.

Also, feel free to contact support if you need some help:

1 Like

Thanks for the delete help. I created a support ticket.


I had some issies with mine connecting at first as well. One of the issues I discovered was that the install phone has to have the BT and GPS Location service on for it to work.



You are never alone. There’s always some here that will help. And they usually are spot on with a fix.

And here’s a back pocket idea/tip in case you need to use it to test with. Create a new Wyze account, different email address. Then try that one to insure there’s not something in your account that is contributing to the problem. And to create a new account, you can do that on a PC on the Internet, if you need to. But don’t forget to not just close the app on the phone, you need to log out of the app on the phone, so you get a fresh login screen for the new account.

Sometimes just knowing there’s an alternative helps the first one work - I think.

BT and GPS are on.

I have Verizon FIOS.

I do not have TV service from Verizon. There is no modem supplying internet connectivity, the LAN cable comes right off the ONT. Should that be connected to the 1G port or the 2.5G port? Would that matter? The app is current. It says if it is a Mesh Pro, then connect to the 2.5G port. That is the port I am using.

My current modem uses DHCP.

The instructions do not distinguish between a flashing orange light vs a flashing green light. That could be better. I had to push the reset button a couple of times to get the green flashing light.

Once the green light is flashing, I AM able to connect the app via bluetooth.

I AM able to enter the name and password for the router. Once I complete entering that information, it hangs and never completes. The blue light just keeps flashing while the app says “setting up your wifi. This will only take a minute or two.”

Support sent me a generic list of things that could cause a variety of different problems. A bot could have returned that information.

I tried again this morning and it hangs on the same step.

I use FiOS as well. make sure you remove and turn off the other router on your network, Simply unplugging it from the WAN port will not work.

I would restart the process, unplug the Wyze Router from the WAN Port and press the reset button for about 15 seconds or so, the light will start blinking orange / red, I believe (Red green color blind, sorry for the confusion here). After you see that, unplug the power cord to start fresh.

Start your App, add device, select Home, the Mesh Router Pro. Follow the instructions.

Basically, plug in your power and Wan Cable into the Ethernet port next to the power port ( this is where I plugged mine into), Then it is a waiting game. If I recall, the router will eventually start blinking white. At this point, you would be able to full connect and proceed.

Note: When setting up the Wireless Node, you will need to be near the main router, once connected, you can then move it to the desired location.

@R.Good , did I miss something on the setup of the Mesh Router Pro?

Here is a link to the install.

Note: It says you will need to wait about 3 minutes for the light to blink. Be patient, they are not exaggerating. :slight_smile:

Wyze Mesh Router Setup Guide – Wyze

Here is a video: Around 5:55 is when they start talking about the Mesh Router Setup

How to set up Wyze Mesh Router - YouTube

1 Like

I watched the video. It reminded me that I have a wifi repeater upstairs which I unplugged. So with that unplugged, and my Fios router unplugged, I tried it again. It’s still hanging at the same step.

Do you have the Pro version? It has two ports for the LAN, the app indicated I should use the 2.5G port (closest to the USB port)which is what I am using. I tried it using the 1G port last night and that didn’t help either.

I have the Pro as well. I connect my Wan to the port closest to the Power Port.

Did yours start to blink white? I had to plug my the WAN cable in and power and then waited for a bit. This ensured I got connection from Verizon’s ONT.

Make sure your BT is on as it will step your through the process when setting up the WiFi. I am sure you have done this.

@spamoni4, Is your LAN cable coming straight off the ONT or from your Verizon router?

I have my Wyze Mesh Router Pro plugged into LAN Port 1 of 4 on my ONT and into the 2GB port on the Router.

During setup, I had multiple attempts when the router could not acquire an IP address from the ISP. I had to repeat setup repeatedly until it got the IP.

Some time after initial setup, after a reboot, I again lost internet because the router lost IP config w\ the ONT. I left the router powered and power cycled the ONT to fix it.

You might try powering up the router and letting it boot. Then power cycle the ONT and let it boot. Then try the setup.

Thanks for that clarification. Support is telling me I need to keep the Verizon router and plug the Wyze router into it. Kinda defeats the purpose IMO.

1 Like

Does not sound like a response based in fact.

I had a TPLink Archer A6 prior to the Wyze. I pulled it off Port 1 of the Fiber ONT and plugged in the Wyze. I have my HMS plugged into the second port on the Wyze. Except for the IP issues and the BT setup requiring GPS, everything operates within specifications. My second Wyze node went much smoother.

The run from my ONT to my router is long, so I am just using the ethernet cable that VZ installed. I unplugged it from the VZ router and plugged it into the Wyze router. I’ll try the ONT reboot once I get a break from work.

We didn’t know there was a long run. Not that it should matter, because you should not be having these problem regardless. But, I would recommend moving the root router closer to the modem until after you have it setup. Then move it to the place you need it.

So I plugged it back in, got a solid green light
Rebooted the ONT, Wyze started flashing red, then solid green, then flashing green
Went through the BT pairing, flashing blue, named my networks, then waited…
After 5 minutes, I rebooted the ONT, still flashing blue, waited 5 minutes, gave up

Yeah, I think my last try will be to plug it in at the ONT using the Wyze Ethernet cable and see if that does anything.

Yes, from the ONT to the Router. However, are you setup for Moca or Ethernet on the ONT?

I had mine changed years ago for better performance. I have a Gigabit connection.

No need to do that.

Flashing blue is the BT Connection. It needs to go to blue when setting it up. did you try to do the setup when flashing blue?