Latest App Update(s) a Bust! - Addendum

Turns out the last several app updates are from 2017. Tap on the app title, which is on the same page as the “update” link, then scroll down to “About App”, there you will see this is a very old version from 2017, which accounts for the total non-functional result after updating. I don’t know if this is someone’s idea of a really bad joke or what, but from here out I will always check the “About App” link before downloading. The really crazy part about this is that the same update available link has appeared at least a half dozen times now. Save yourself some grief and always check the “About App” link for the release date before downloading. Final note: The latest base unit firmware update is safe; WCO hasn’t been around long enough to throw an old update into the mix - still not sure exactly what it “fixes” though. I’m sure it is specified somewhere; I just never saw it.

Clearly you don’t know what you are talking about. 2017 is the date the original app was released… 2017 is not when the latest update was released!!!



OK, so I’m the only person getting prompts for an update that renders the app useless. It is completely illogical to list the app inception date in the “About App” release date section of an update. Let’s hear it for the Devs!. I never said 2017 was when the latest app was released, quite the contrary. I’ve got pretty thick skin, so if you are trying to get under it you’ll have to do better than that.


Android or iOS?
I can’t find what you are describing.,

Android. It’s one of the standard prompts that pop up when the app is opened from time to time advising of a pending update. I’ve gotten so many lately that I would not be surprised If another came through soon. If & when it does, I’ll try to get & post a screenshot. If it is just me getting them, then my account might have been compromised by some malicious hacker. I’ll be sure to keep you posted should it happen again. You will know what I’m talking about if you tick on an update that disables your app, &/or you check the release date (Which you should probably do 1st anyway) and it shows 2017.

could you maybe post a screen cap of what your seeing? Or maybe a version number?

I am on iPhone, but it looks good to me


I will get & post screenshots of everything related to it. It’s unsettling to say the least, particularly since I’m not seeing anyone else mentioning this.

1 Like

Also could you share the make and model of you device.


In case I forget: Fire HD 10, 7th & 9th Generations - It has shown up on both. The 7th Gen is stock w/Amazon ads, I’m running “Automate” on the other, which is stripped down (no bloatware) w/very few other apps.

Running WYZE on an Amazon Fire is always a crap shoot. It is unsupported.
For example, the last beta version I tried wouldn’t load my cameras at all. I couldn’t even add cameras.

1 Like

Good on you Dicky, some cannot read between the lines… At least you’re proactive

Gatta be honest here. Running many apps on the kindle fires is… a crap shoot. Don’t get me wrong, I have one for everyone in my family but they are used for E-readers, abc mouse and that kind of thing. Apps for an older audience seam to get neglected on kindles.

With that being said I haven’t tried to put wyze on any of mine.,

During the early days of using Wyze (well over 2yrs ago) I had some issues, but determined my WiFi was at fault. I have long since resolved those issues and have had at least 98% reliability running five V2s, one Pan, and most recently a WCO. My 9th Gen Fire 10 is running about as pure Android/Fire OS as you can get. I’ve removed everything Amazon from it, so if you are saying they are unsupported, you’re kinda saying they are not Android compatible. That has not been my experience. Sure I’ve had, and have some glitches every now & then, but then hasn’t just about everyone? I could be wrong, but I don’t think the bogus app updates are related to the devices I’m using at all. I am not an Apple basher. I wear practical shoes, and for me Apple just isn’t practical - too much $$$, & a somewhat locked cybersphere; wait, Is that a word?. You know what I mean. I’ll be sure to post those screenshots if it happens again. I’ll give it another week or two, then I’m @ least changing my password.

1 Like

The problem is that android is more like Linux than windows. Just because something is running Android doesn’t mean it has much in common with any other android device.

Google puts out the framework then Other vendors are free to make any changes they want, without any restrictions. This, in the case of kindles, results in it being unable to run other android apps sometimes.

Like I said before, it’s a dice roll. If wyze doesn’t officially support it, there isn’t much we can say.


Short & sweet: It’s not a “Kindle”, and it works.

I’m confused here, Android apps don’t announce updates, the Play Store does, kinda. The app does announce firmware updates, is that what you are referring to?
Are you running beta app / firmware versions?

I can’t see how any of this could be related to a hacked account.

1 Like,

I hear ya. I’m confused too. I’ve done my fair share of app updates; you know, swiping right on the Play Store home page for “My Apps” to see available updates, and I agree prompts to update the firmware is generally all you will see from within the app itself. Something went sideways because the last half dozen or so update prompts (way more than usual in a short period) have taken me to the app update page which turned out to be an old 2017 ver of the Wyze app. When I logged into the forum I expected to see a bunch of chatter about it, but there was nothing, so apparently it was just me. It seems to have stopped for now, but I promise you I’m not just making this all up - it happened at least 5 or six times. I’m growing weary of discussing it - ready to put it, and myself to bed. The Wyze app is working just fine on both of my tablets for now. If it happens again, rest assured I will post everything I can capture about it on the forum.

I am running beta app ver 2.12.33 on both tablets.

The current beta is 2.13.115.
I am running 2.12.29 on my Fire HD 8 because 2.13.xx wouldn’t work.,,

Interesting. The version you are running doesn’t work on my Fire 10 HD - See scan
of page that opened after uninstalling ver 2.12.33 & installing 2.13.115 - Was too large to insert as inline pic. I suppose I could get it to work if I wanted to start from scratch by reinstalling all of my cams, but considering everything works well with the 2.12.33 ver, I simply reverted back to it, and all is well for now. I now fully appreciate what Wyze is saying about it not being supported (fully) on Fire devices - just counting my blessings that the previous app version works reasonably well at all. Please excuse the poor quality of the scan; I literally scanned my tablet screen. The prompt in the middle of the page reads: “Add new device”.

Results of 2.13.115 Dwnld from 2.12.29 001.bmp