Lamp Socket won't stay on - after working for 4 months

The run down…

Camera setup, operating for last 4 months or so. Follows rules/schedule and comes on at the set times, goes off at the set times…

Today I come home to find lights out??? WTBlip???

Ok… go into camera, hit the light bulb to turn on socket… They come on… Close out… go inside… just as an afterthought and I check… the LIGHTS ARE OFF AGAIN!? WTblip??? And contrary to what some other post I found in search about the turning on via the lightbulb icon being temporary while viewing, that has NOT BEEN TRUE here. I’ve turned them on during setup closed out, and they stayed on.

Rinse repeat the above, several times… Now thoroughly agitated…

Turn on socket, stay on camera.the socket stays on… URRRGHGHG…

Start digging out things

I changed out the lamp socket… No change

I changed out the cord from camera to socket. using new and existing socket, No change.

I plugged in the socket, NO CAMERA, Light comes on and STAYS ON. Plug in the camera… BLIP… socket goes off after about 1 minute.

Go into the Lamp Socket settings, Set it to ON for the socket, STAYS ON.

Tried POWER CYCLING Camera/Sockets

As a test, I set the SOCKET to ON mode, setup a Test rule turn on at x, for y minutes… That worked, stayed on, and went off…

I reran the above, with the change to SOCKET OFF mode… Schedule runs, turns the light on, then it goes off. URRRGH…

I reran the first test, SOCKET ON, schedule… and it works… So I guess the temp fix is put it to ON MODE… but I know I did not have this set that way, and is COUNTER to the listing on screen " rules will still take effect…" Ummm no they are not for some reason…

SOP Disclaimers apply :

YES, as usual this worked fine till tonight…

YES, I have MADE NO CHANGES to my rules/schedules. Other than the testing rule above.

YES I pay the feature vig aka Camera+

YES, I am not in a good mode over this.

NO, I’ve made no firmware updates in the last 4 months, I am actually no longer updating firmware as I don’t consider it safe.


Sockets - 3 SYNC’D
NO “groups/clusters” of devices
Software / Android / 2.48.1(381)
Camera Firmware is: LATEST - checked
Plugin Version :
Socket Firmware is: 0.9.029 / LATEST - checked
802.11 2.4GHz - GOOD SIGNAL…
Light bulbs are LOW WATTAGE “bug bulbs” and have worked fine for 4 months with out issue. 7W bulb = 60W these:

I even tried some of the bulbs I wanted to use, the “flickering flame” again these are something like 7W bulbs… but these screwup the motion detection in the camera, at least in the V3.

So NO it is not over current or heat related.

Socket Mode: OFF - I set it here normally, and the schedules/rules take control on at x, off at y.

The ONLY thing I’ve not changed out tonight, is the camera… Well that will be changed out as soon as a new one gets here.

This really makes no sense if it is the camera… What would change in the camera??? :man_shrugging:

Any ideas??? Other things to try??? I guess Sun after I change out the camera we will know its the issue… :man_shrugging:

Firmware updates change. It could be a glitch occurring from a recent firmware update. If I recall correctly, V3 cams have something like >4,000 lines of code dedicated to Accessories control. When a V3 gets a firmware update for other things, including security checks improvements, it’s possible the connection functionality can require some tweaks.

I’m not saying that’s the cause, I am just answering the question of why something with the camera could change to make the accessory function differently. It’s also possible that it involves various other things, including backend changes with the rules engine or something.

I look forward to hearing what you discover with this.

I guess I should have worded this out a little… more…

Yeah… a firmware update would… BUT (always that word! :slight_smile: )


NO firmware updates to EITHER socket or camera have occurred.

All firmwares ARE CURRENT. based on the software stating it…

That I will NOT UPDATE any device firmware, based on the dubious nature of said updates in recently.

So given that I’ve walled this off… that was my question…

What could have changed given that I’ve done, nothing to change config, settings, schedules/rules etc… :man_shrugging:

The only thing in this that would make sense would be “firmware corruption” of some sort, but again how??? No updates done, or attempted…etc… EMP? I’d have noticed that :slight_smile: :wink:

That was my point…

We will see what happens on Sun… so long as amazon really is going to put the spare on my door on Sat…

As the camera is the ONLY item not changed in testing

Changed sockets
Changed cables
Used original cables with original/new socket
Used NEW cable with original/new socket

Its just such a random change to occur really…

So again, the last piece in the puzzle is the camera, and if its the issue, that puzzles me more… … :man_shrugging:

Well to keep things updated…So for SUN 1/14/24 ) this mess took a turn to fickle.

Ok… amazon (pfft - yes I got it here in time, I’ve got other issues with them before now, and with another delivery which really PO’d me ommmmmmmmmmm I am not a fan to start and less so of late… really wish there was more Geek Depots around or at all! anyway… ommmmmmmmmmmm )

Any way… I am setting things up… SD card in… getting ready to test some options in re camera… and I notice the lights are ON! WT??? Ok… turn them off via the button… ok… BLIP! BACK ON! off again… BLIP BACK OFF (via the icon in the camera view)! Ok… rinse repeat this enough times to look like I am practicing my Morse (which is non existent anyway… ) Ok… switch it to OFF MODE as I had it setup before… let the cycle run for the day…

All seems “BACK TO NORMAL!” WT???

So I am going to let this run a few days to see what happens… Maybe having a “spare” camera “scared it” to work properly… I don’t know… but reading a couple other messages on some other foibles in the same time period… My conspiracy brain has kicked in… and I think there was something that affected this…

Especially since the “OFF” rule on SAT before I was to test on SUN did work, but at some point they decided to COME BACK ON due to it being set to “on” in the auto/off/on setting… Which why???

The whole think wreaks of WHY??? WHY WHY???

Am going to let this run as I had things before, with the existing setup equipment and rules and on the next RDO if there is a change or failure swap cameras… I can use the spare in another situation to test out something elese which is a failure point…