Keep repeating "ready to connect" Cam v3


Just bought Cam v3. It keeps repeating “ready to connect” and doesn’t scan QR code during the setup

Sounds like the camera is having problems reading the code. Try moving your phone closer or farther away to see if that works. I had issues initially getting the image in the right place for the camera to read it.

I had the same thing yesterday. Had to slowly move the QR code closer and further away from the camera and it finally worked. I don’t know if taking off the lens film first helps with the QR code recognition.

Just got off the phone with the customer support, they ended up having to replace my v3. I have 6 in total and this one would say “qr code scanned” and the app would say configuring and 5-7 seconds later the camera would say “ready to connect”. Seems like a quality control issue. Just call customer support and if they can’t successfully walk you through setting it up they’ll send you a new one.


I purchased 3 v3s, and the last one wouldn’t scan the QR code after several reboots, different distances, different angles, flipping it on its side and upside down, etc. Nothing but an endless stream of “ready to connect” messages. Ended up in chat with Wyze, and at one point he asked me to do a factory reset. According to him the process was unplug the cam, press and hold the Setup button while powering it back on, wait for a yellow light, and release. That didn’t work, and there was never a yellow light. It just rebooted until it was repeating the “ready to connect” message, but the support guy said that should do it, so he was sure the camera was bad. Anyway, while he was getting ready to get an RMA ready, I decided to hold the Setup button well after the “ready to connect” message was playing, and after several more seconds the IR lights flashed, and the status light eventually went solid. At that point I released the Setup botton. It then went to flashing red, so I started the setup in the app, and it worked!

So, if you get stuck on “ready to connect,” try doing a factory reset, but make sure you hold the Setup button long enough the IR lights flash, and the status light goes solid red. Maybe it will save you the trouble of having to send it back.


Same problem, your “fix” didn’t allow mine to scan the QR code. Unbelievable of Wyze to release a cam this bugged out.

Hi, I had the same problem and I it was because the RESET button was stuck. I fixed it by removing the little rubber on it.

I removed some rubber with a knife, put it back and it works.

1 Like

I had to put the QR code up on my large screen TV and it immediately connected and successfully finished setup.

1 Like

Same thing for me. The camera wouldn’t read the QR Code on my iPhone SE 2nd generation. When I retried with my iPad, the camera immediately connected.


Tried that and I think it worked! Haven’t heard the dreaded “READY TO CONNECT!” THANK YOU!! Hope it doesn’t start acting up again!!

Upvote for displaying QR code on larger monitor - I tried forever with an iPhone 5SE. Following the above advice: Did a screen capture, emailed to myself, displayed on laptop - instantly read the code.

1 Like

UPDATE: Called customer service about the “ready to connect” issue. After doing some troubleshooting, they sent me a new V3 and it is working with no issues.

Ditto for me. Both iPhones could not connect after numerous tries, tried the “reset” which didn’t work, but connected right away with the iPad.

This happened to me and it was definitely because the rubber button cover was pressing up against the reset button underneath it.

You can use a tiny screedriver to pop the button out. Then I used an exacto knife to shave off a tiny but of the button from the bottom then it worked as it should and stopped trying to reconnect.

Hope this helps someone.

1 Like

Same thing is happening to me now. Thing is, this camera was working fine most of the summer. I moved it indoors and it automatically went to, “ready to connect”

This worked for me.

Thanks a lot. That worked!

I had the same issue for hours and hours and then emailed the QR code to myself as a large format screengrab. Using an old iPad I was able to scan the email attachment and the camera recognized it immediately.

I owned my camera for about 6 months and now it keeps resetting itself back to “Ready to connect mode” it like it is resetting itself on its own for some reason. After I reset it up and scan the barcode after 10 minutes for so it reset back to “ready to connect”. Please help! I am unable to contact anyone from customer service and it’s confusing on how to submit a helpdesk ticket.

Hi- I’m no expert but it sounds like your Reset button is stuck. Try following this advice from TSLHI:

Good luck!