Hung on 'Getting Video Data'

I have two cameras setup, both running firmware (and I’m running iOS app version 1.2.48).

On one of the cameras when I try to connect from outside of the house it will connect, authenticate then sit at Getting video data for 15 or so seconds, then it goes back to connecting, authenticate and sits at Getting video data. This just cycles around and around.

On the other camera it connects, authenticates and gets the video data right away. Ironically this camera is further away from the access point in my home.

Anyone has similar issues or suggestions on a resolution?

Sometimes just force quitting and restarting the Wyze app will fix this. If not, try power cycling the camera.

I have the same issue and have just been restarting the app which is inconvenient but seems to work.

It could be some WiFi interference. What make/model is your router? Are you using WiFi extenders?


how old is your pug?

I ended up re-starting the camera when I got home and it is working now. I was able to eliminate the router from being an issue because the other camera connected with zero issues. Hopefully this is a one off issue, worse case I could hook up a wifi enabled plug and remotely power cycle the camera to get it connecting again.

I did try to re-start the app but kept getting the same results.

And Buster is 11 now (we’ve had him since he was just over a year old). He is not a typical pug (somewhat anti-social) but still an amazing little guy.

Yes, I’m seeing the same thing on 1/3 of the cameras I currently have. Started after the f/w update. Can’t power cycle the camera when I travel. Force quitting the app and then restarting has no effect so far. Bummer.

Same thing for me about 60% of the time.


Same version 2.30 Had 3 cameras that were working fine until upgraded to this version. Afterwards, 1 camera would never connect and the other two would. Went to bring the 3rd in the house from the garage and it fell off the shelf while unplugging it and it hit concrete floor. Bye bye. Went away this weekend and neither of the other two would connect. Got home and immediately they connected when my phone connected to my home wifi. Tried flashing one camera back a version and both were still ok on my network. Went out and tried cell/4g and several different wifi connections and neither would connect. Very upset with Wyze right now for not fully testing before they send out f/w updates. I now have 2 useless cameras.

I am running firmware version and I have the same issue. After updating to the latest firmware, I cannot connect to my wyze cams using mobile data, I get the ‘Getting Video Data’ and that’s all. Once I connect to a wifi network, then I can connect. Seems like the latest firmware has an issue?

I have the same issue. Connects to one camera but not the other- not without restarting the app and/or camera.


Definitely a thing I experience regularly. Connecting to the cameras has been flaky since I got them, get’s very frustrating when viewing local playback, because of how cumbersome the timeline scrubber is.

I am having the same Issues. It is a brand new cam with the door sensors and motions sensors… took some time to get it started up and worked for few hours and now no video streaming at all…

The sensors are still giving notifications but no vide streaming regardless of LTE or Wifi 2.4

what kind of wifi speeds do you have?

and also, what device and version of android are you using?

Over 100 Mbps on 2.4 at the phone… LTE over 200 in avg

and what device are you using?

I Have a very decent internet connection that has loads of bandwidth for what im testing it with. It is on a bell fibe 1Ghz connection. So I did all possible checks on the router , app, restarting and power cycling the cam and router and app… using the app on a SG 8+ and LG G5. Same results. No video stream … just an annoying message

and what firmware and app version are you using?

V2.5.36 app and firmware

did you have the need to use the hardware accelerator when it was part of the app?