Hung on 'Getting Video Data'

I did not do anything like that but got it working now for the moment by resetting long press for 5 seconds it deleting from the app and adding the device again. But don’t know for how long.

So annoying It stopped working this afternoon again.

Do you think it is a defective unit? Should I change it or return it? Only the streaming function is not working. The door sensors and motion sensors work really well

that is odd. the fact that it works for a while is what is perplexing me. it wouldn’t hurt to start a support ticket.
here is the link to do that.


@Newshound @StopICU33 @WyzeJasonJ might one of you have an idea on this?

Sounds like a malfunction to me, but just to confirm, what is the annoying message? “Getting video data”?

Curious that the reset fixed it for awhile. BTW, I usually have to hold that button for more than 10 seconds to get it to start the reset.

Do you have an SD card in it? Might be worth popping that out and trying the reset again. Then leave the card out and see how long it runs.


I concur with this, I have seen SD cards make them act up.


Getting video data is the message yess. And yes I did try popping out the SD card and trying to get things up and running. I just feel like there is something wrong with it because I have a really hard time getting it to read the QR code. Had to try different devices everytime. Last thing I tried was a galaxy tablet and scanned it in one shot like it should, but not anymore. I called Amazon and they are gladly replacing it for me. I feel like I have exhausted all the options.

1 Like

It sounds like it, I am glad Amazon is replacing it for you.


glad its going to work out for you.

1 Like

Thank you all for all the support… !

Got my new cam… had no issue right out of the box… did not struggle to read the QR code at all… always connects within 3 seconds… This cam is awesome when you get one that works. (Most of them do) firmware upgraded and everything works well…