HELP! Frustrated & Tearing My Hair Out: Wyze Pan Cam v3 Won't Connect or Won't Stay Connected

I’m at my wit’s end and am in dire need of help.

TL;DR: An eternally mounted Wyze Pan Cam v3 that is less than 1 foot away from an AP inside the house is not connecting to or failing to maintaining a connection. Tried another Wyze Pan Cam v3 but it’s not working either. Other cameras further away work just fine.

I’ve got a number of cameras in & around my house (including three Wyze Cam Floodlights) spread across 2 access points (APs) each of which supports over 300 simultaneous clients & is broadcasting an SSID on the 2.4GHz spectrum specifically for the cameras that should be connected to it. For example, the SSID Wyze2ndFloor is for all the cameras on the second floor and the Wyze1stFloor is for all the cameras on the first floor. Happy to explain why I did it this way in a separate thread. All of my Wyze cameras are connected and work fine.

I recently mounted 2 Wyze Pan Cam v3 (WCPv3) outside on opposite sides of my house, and for some reason they won’t maintain a connection to the AP they’ve been setup for. For one of the cameras the AP it’s been setup to connect to is less then 20 feet away and the only obstruction is the outer wall. Both cameras might connect for a few minutes but then disconnect randomly. Anecdotally it seems like it disconnects when the camera pans or tilts, but I have no hard data to prove that.

I’ve spent 2-3 weeks troubleshooting this doing everything I can but these two cameras continue to exhibit the same behavior:

  • WiFi heat maps inside & outside (specifically while holding my phone next to the mounted camera)
  • Speed tests inside & outside (again specifically while holding my phone next to the mounted camera)
  • Different USB cables
  • Different power options
  • Different SSID’s
  • I even purchased two more WCPv3’s in case my 2 were bad

Using a spare older Google Home AP, I setup the guest network (which broadcasts on 2.4GHz) to broadcast the same SSID as the AP closest to the WCPv3 that’s not working and placed it as close to the camera as possible. The Google Home AP is literally right next to the camera, just on the other side of the outer wall. Despite this, the new WCPv3 camera still behaves the same. Curiously one of my floodlights which is maybe 40-50 feet away with several obstructions, connected to the Google Home AP and it’s working just fine.

Although two cameras are not working, I’ve been focused on just one of them and I’m tearing my hair out trying to figure out why it won’t maintain a connection. I’m nearly desperate for help.

How are the cameras setup?
One camera is using a 25 ft USB cable that’s plugged into the USB port on a Wyze Cam Floodlight.
The other camera was also connected to the USB port on a Wyze Cam Floodlight but when that didn’t work I tried a different strategy. Following some advice, I found in another Wyze forum post here, I’m using a 40ft flat power cable plugged into a 4.8A 24W USB Wall Charger to power the device. It powers on moves around etc. but don’t connect - or doesn’t remain connected- to the network.

Here’s a picture to help you visualize the placement of the access point and camera.

1 Like

Thanks for the in-depth explanation. How do the cameras do when they’re plugged in using the supplied power supply and USB cable? I do know the pan v3s are very finicky when it comes to being power and that’s usually the first thing I aim towards whenever there’s troubleshooting similar to yours with the V3 pans.

/Edit in later…

One foot away yes, but if you look at what’s in between the two is an exterior wall of some type construction, with maybe wires, other stuff that could be attenuating the signal. What is the exterior of the house made of? What type of siding?


Have you tried taking the access point off the floor and putting it on the window sill (left, middle and right side) as a test? Might be worth a try. Yes, I know being that close you shouldn’t have to.


Hey @Omgitstony and thank you so much for taking the time to reply.

How do the cameras do when they’re plugged in using the supplied power supply and USB cable? I do know the pan v3s are very finicky when it comes to being power and that’s usually the first thing I aim towards whenever there’s troubleshooting similar to yours with the V3 pans.

When I got them out of the box I configured them all using the Wyze issued USB cable and all is well. Even using a non-Wyze issued USB cable connected to the USB port of a display monitor works fine, at least long enough to power it on, get it connected, do some basic tests etc. When I pull the cameras down & use them in the house they’re perfectly fine.

Because of the placement of the camera - about 14 feet high and 17 feet across from the power outlet - I can’t really test it using a Wyze USB cable unless I take it down. The camera was plugged into a “Nekmit 4.8A 24W Thin Flat Dual USB Wall Charger I picked up on amazon” but I’ve switched to using the Wyze issued adapter and it’s no better.

What is the exterior of the house made of? What type of siding?

The exterior house is made predominantly out of wood and as far as I can remember (I was around during the construction) no brick/stone and no metal. The siding is vinyl.

One foot away yes, but if you look at what’s in between the two is an exterior wall of some type construction, with maybe wires, other stuff that could be attenuating the signal.

I’m with you here and I had considered that as well. But what strikes me as odd is that I have 3 Wyze Cam Floodlights mounted outside, all 3 are connected to the same SSID (serviced by the AP upstairs) and despite all of the obstructions (multiple walls) all 3 are essentially rock solid. That said, it seems like the corners might be some sort of “dead zone” for whatever reason.

I’m going to try to move the camera further away from the corner & see how that goes.

Hi @StevenA ! Thanks a bunch for the reply. You know what, that is a really good idea at least for testing purposes! I’ll put it up on the sill towards the right (closest to the camera) and maybe even rotate it so it’s on its side to see if that helps.

For sure, there’s plenty of signal in general on the outside of the wall. I’ve used my phone to run speed tests and WiFi Signal strength tests while it was right next to the camera and it works fine.

1 Like

I am going to chime in. I had a Wyze v3 mounted 5ft from the router powered by the same Nekmit adapter that you have and 40ft flat USB cable. That camera was constantly dropping from the network. I changed the cable with Wyze supplied 6ft and that camera never dropped. The Nekmit adapter has enough Amps to feed the camera but the 40 ft long cable will drop the voltage to something around 4.6 to 4.8V, and that is not enough to power the camera with all the bells and whistles. I am 100% convinced that the voltage drop is causing your cameras to loose connection.

Hope this helps and you have a way of shortening the length of you power supply.


hey @StevenA I moved the Ap a bit but still didn’t help. I also moved the camera about 10 feet away from the corner but that didn’t seem to help.

1 Like

Good afternoon @habib & thanks for chiming in, I really appreciate it. Also huge thanks for your post here. I was wondering about the possibility of a drop in voltage, but I could not find any information about maximum distance before encountering that.

Do you know how long a USB cable can be before there’s a drop in voltage? Considering Wyze sells a 20 foot USB extension cable that would be plugged into a Wyze Cam Pan v3, which itself uses a 6ft cable, my guess is that it’s somewhere in the neighborhood of 30ft. But again, I’m just guessing.

I’ll try the 6ft USB cable & go from there. This is not ideal as my power outlet is 17 feet away from where I’d like the place the camera, but I guess I don’t have much choice.

If you find voltage drop is not an issue, the next step might be to determine what firmware version your pan v3 cameras are on and manually flash to a different firmware version. Looks like there are 3 versions available on the Wyze site. It appears Wyze was tweaking connection stability in the different versions.

Wyze Cam Pan v3 Firmware (April 24, 2023)

  • Improved Wi-Fi connection stability
  • Fixed an issue that caused dropped frames
  • Fixed a bug that prevented recording Events to a microSD card (February 20, 2023)

  • Improved Wi-Fi connection stability

Note: This is releasing to 10% of customers on February 20th. We’ll release to more customers over the following 3 weeks. If you don’t see the update now, don’t worry! You’ll see it later. (January 30, 2023)

  • Improved stability for playing Event Videos
  • Fixed a bug that displayed the wrong time zone
1 Like

Nice find and suggestion @StevenA! I just discovered that the Wyze cable is just long enough for me to plug it into a wall outlet (into a Wyze power adapter) in the room and dangle it out the window. I’m going in the process of moving the camera there to see what happens. If that doesn’t work, I’ll focus on signal strength and firmware.

1 Like

It would depend on the cable quality, such as thickness and copper purity. I have one of these meters to help me determine voltage/amperage drop:

I would still use the Nekmit adapter, much more superior than Wyze’s and higher Amps.

1 Like

This is solved! Ok so the issue for sure was the USB cable, either the length or the poor quality of the cable. Instead of running the 40 ft cable from the outlet outside the house neatly tucking the flat USB cable under the vinyl siding and behind the gutter, I ended up using the stock Wyze cable and running it through a window in the house and plugging it into an outlet using the Wyze adapter. Immediately the camera worked and after a full day of this setup has been rock solid. While this is not ideal from an aesthetics standpoint, as it looks a little odd, I’ll get over it.

Huge thanks to @Omgitstony @StevenA @habib and @IEatBeans for helping narrow the scope of this issue that’s been driving me mad for about 3 weeks. I’m so thankful for your help and guidance here.


Thanks for the follow up and I’m glad that this is working for you now! Hopefully folks that have same or similar issues to this see this topic and the troubleshooting and are able to figure out their own problems. Thanks again!


2 of my V3s stopped working due to the cable end of the cameras getting corroded. I went with 25 foot cables and they’ve been fine.

Where did you have the camera mounted? Which end was corroded? The camera pigtail? Or the micro USB or the usb-a end of the cable?

Outside in the open about a foot off the ground for viewing critters at night. Both the camera’s pigtail and the cable’s micro USB end were corroded. I threw away the cable and replaced the camera’s connector with a USB A connection and refocused the lens (what did I have to lose?) and it is now my up-close flying squirrel cam.

Was the boot in place? Did the silicon boot not cover the connection correctly?

1 Like

Yes - it is just not enough to really prevent moisture from getting in.

I would look into and work in a drip loop, somewhere not near the boot/connection.

I use empty prescription medicine containers. I tuck the connections up into them and make sure they are facing down. So far so good.