Failing Mechanical IR Filter or a Bug?

After applying the latest public firmware release (v4.9.3.64) I have one camera that stubbornly refuses to turn ON the IR filter. It works perfectly transitioning from daylight to night (you can hear the multiple clicks as it gets progressively darker). However, re-entering daylight is a bust - the filter does NOT kick in and it stays in a quasi-night mode.

The funny thing is that manually cycling through night mode (off/on/auto) resets the device and it works - until the next nightfall. This camera is pointing into very bright light, so lux isn’t an issue. It’s indoors pointing outside through a double pane insulated window (but so are my other half dozen setup like this that work perfectly).

Any ideas? I hate having to go thru the whole RMA mess for something that seems to work manually.

Thanks all!

On the chance that it’s firmware, you could try flashing the firmware:

I would suggest starting a support ticket anyway to get yourself in the queue.

is there any magnet around the camera ?

It’s had this issue through the last two firmware updates, and now still has it with the new one. And no magnets anywhere near there (I’m aware of how the device works mechanically and made sure it was isolated from any potential interference). The really strange thing is how I can flip the filter manually by toggling the settings from the app…

And fwiw, I tried opening a ticket via the app yesterday but when I select the email option it goes nowhere…

Thanks for the replies/help!

Isn’t there a magnet in the base of the camera stand?

The magnet in the base of the camera isn’t close enough to affect the IR filter. However, the IR filter is electromechanically activated. If you hold a strong magnet against the sides or top of the camera, you can cause the filter to change states.

This does give me a thought though: That camera is sitting in the fully down position. I’m going to raise it up so that the base magnet is a little further away and we’ll see if there is any difference. I’ll report back in.

1 Like

I was going to ask if that position had possibly changed and now being affected by an unusually strong base magnet. It was just a idea.

Nope, the camera has been in the same position pretty much since it was installed. This will be an interesting test…

yep, test extending the leg and see if it makes a difference…

Welp, no joy with the raising of the camera away from the magnet in the base, same exact results. One thing I didn’t mention is that, when it gets light, the IR LEDs turn OFF even though the IR filter is not engaged. Sounds more and more like a hardware problem, but if so, why in the heck can I manually turn it off/on every single time without fail…?


Since the mechanism seems to work when triggered manually, I’d tend to suspect a firmware problem. Have you tried to flash the firmware as described in my post near the top of this thread?

Hey Rick - no, haven’t had a chance to do that yet, will try it today. For some reason I assumed that the push firmware updates I have been applying would act like most other devices I manage and be a true hard update. We’ll see how it goes, I’ll report back.

Tick off another possibility anyway. Is there an internal diagram or cutaway so I can see the mechanical issues being discussed?

Hopefully, the firmware flash will do the trick.

I was actually planning on disassembling the camera and monitoring it’s IR filter through the changes if this firmware doesn’t work. Might do it anyway.

I seem to remember someone posting a breakdown with the parts labeled. But I’m not finding it now.

I guess my gigantic fuse box cover would qualify as a magnet hehe.

I think this thread may be related to Camera shows Black & White Video void of color

Thanks. I also found this video of the Ir filter workings on a different type of camera. The Secret Behind Good Night Vision security cameras (IR Cut Filters) - YouTube

He takes it apart so you can see the filter flip in and out. I would think the mechanics are the same.

1 Like

There was a better one at one time, but that was the only one I could find. Hope it helps a little bit.