Error Code 90 With Firmware Update (3.30.2023)

Got the firmware update message with my two V3 cams, so updated both. After reboot I get error code 90, the cameras are offline, and the firmware version listed for the cameras still shows as Power cycling does nothing.

Does anyone test these firmware updates? Honestly, after 100 days of firmware madness over these cams this is ridiculous. How much should be expected of your customers? How many hurdles of increasing size should a consumer be expected to overcome just to get firmware updated?

Yes, I know, remove the cards, reformat, reinstall, blah blah.

Fool me once, shame on me. Fool me month after month…

I am a volunteer community member, not an employee

Sorry you are experiencing issues with your Wyze Cam V3. I see you are on FW version

I am not experiencing this issue with My V3 Cameras. Can you provide additional information:

  • Device you are using (iOS or Android)
  • Wyze App Version you are using
  • Do you have Cam Plus, Camplus Lite, Cam Protect, or none

Depending on the Device you are using, there could be other options.


Note, you can always sign up for the Beta Updates and provide your feedback and help with testing. The Beta FW for the V3 Cam is:

here is the link for you to check out

Wyze Cam v3 & Pan v2 Firmware Beta Test 3/23/2023 - Beta - Wyze Forum

No Cam Plus, Camplus Lite or Cam Protect. Very generic install.

You mentioned:

This may be the version that was pushed to my cams, however I am not in the beta program. With the cams being down at the moment I have no way of retrieving the version but will try later today.

This is not the first time I have had trouble with these two V3 cameras. Last time I went around and around trying to get updated or even Beta firmware on them to no avail. None of it makes sense! I’ve formatted Samsung-branded cards, tried older versions, etc., and finally just gave up. Unfortunately this time it was not really a surprise, just another blow. If there is some other data I can grab from the firmware version or whatever I’d sure go looking for it.

Edit: I get “connection timeout. Please rescan QR code” but when I show the QR code to the cam it never rescans, so I have to go through the loop again just to get to the same error message. That’s a problem. The cameras are sitting in the exact place where they have been for a year and the wifi has not changed. Yes, my android phone is connected to wifi.

Edit 2: Something else is up. I am looking at the SDcard on my PC and the camera has been happily recording events in spite of the problems it has connecting to the app. I posted yesterday, and yet the camera has events for the entire week, including today.

But something is really wonky here: at this moment, it is 2:25pm, but the events stored on the SDcard have timestamps of 9:13pm. In fact, all folders since the firmware was pushed are like that. Any recordings from last week are correct. That is: morning events have an a.m. timestamp, night events have a p.m. timestamp.

Question: How can I confirm what fw version is on my cameras? I’m guessing it might be in a file somewhere?

If it was, it would have had to been publicly released. Not sure it has been yet.


I would also try a Factory Reset on the Camera. When I had issues, similar to this in the distant past, Wyze had me do that and everything started to work again. You can do a Factory Reset by doing this:

How to reset your Wyze Cam v3 – Wyze

Well, we got one working with factory reset. The second one is not as happy. It gets to the point where it scans the QR code, then within 5 seconds says, “connection timeout” which seems pretty fast. This is consistent over three or four tries. Hm.

Incidentally, the firmware pushed to the cam that is working (after the reset) is

Thanks, for the help.

Many factory resets later, both cams are working. Was able to factory reset with the SD card out, then drop the card back in and have both cams recognize the 4054 firmware version.

1 Like