Doorbell Pro Restart Function

Is there a reason why the Doorbell Pro doesn’t have a restart function besides flipping a breaker or unmounting it and performing a restart?

[Mod Note]: Your topic and associated replies were moved to the #wishlist category for better visibility. Please remember to scroll up to the top and click the VOTE button to show your support.

We have have 4 of them from day 1 and never had to power cycle them at all

1 Like

Video Doorbell Pro needs a way to restart from the app

The Video Doorbell Pro really needs a way to restart from the app (like the cameras) since mine is hardwired and it requires I flip the main breaker to power cycle the unit. The lack of a restart / reboot within the app is long overdue and important to hardwired customers.

The reason I need to restart the camera is that if often (almost weekly) looses the live video feed, but continues to record and provide workable recorded videos. This means I can watch the package after it arrived at my doorstep, but not as it is arriving.

I didn’t think flipping the breaker would do anything since it has a battery. I don’t have mine hardwired [yet], but I charge it with a USB cord, and when I unplug it from power it doesn’t reset/reboot. Are you guys certain it reboots by flipping the breaker? I’m thinking the battery should keep it running when the breaker is turned off.

Regardless, a reset/reboot option would be nice for everyone, especially since almost every other camera has this. It should be kept consistent for this camera too, especially since it has a battery and seems like manually removing power wouldn’t normally resolve the need anyway as is possible with other cameras.

1 Like

I have seen the same issue, because of the battery it does not reset when the breaker is flipped as it just looses power (wired) and it runs off the battery.

I need to fully remove the doorbell when I see the Live Video not working and have to fool with the power button to restart the unit.

I just want to tell it to “reboot” or “restart” like I can do with the cameras to force the unit to reload the config and reconnect to WiFi hoping that will bring back reliability.

1 Like

As well as helping customers this would also help save the time of Wyze support agents when doing diagnostics. I recently had to contact support about my Doorbell Pro and we wasted a lot of time with flipping the breaker, finding the security screwdriver, and removing the doorbell from the mount to access the power button.

I’m posting this because I can’t believe it worked and this could help others. I installed a VDBPro at my mother’s home about 2 hours away. I used the wired/powered setup. Two days later, it stopped loading the live feed, the app throwing the IV22-20004 error. It also wasn’t triggering detections. I tried some of the tricks with enabling and disabling night mode, etc. Nothing would kick the camera back on. Device info showed the chime signal at two bars and the doorbell at one. Her router was less than 30 feet away. I told her to move the chime box to an outlet closer to the doorbell under the window less than 5 feet away. No help. For three days I waited hoping it would just come back online, as I’ve seen occur with some other VDBPs I have. But getting her to reboot it was not a viable option. Even if I thought a 76 year old could get on a step ladder, she is not at all technically inclined and nothing I read confirmed that even interrupting the power to the VDBP would restart it as it has a battery.

I read a few posts that people were using rules to schedule daily reboots to fix other past problems. So I looked at creating a shortcut I called “reboot mom’s cam” and sure enough the shortcut flow listed her cam and one option was restart.

I triggered the shortcut and nearly fell off my chair when the cam started responding again a few seconds later. I had suspected the chime and cam were still communicating but something was wedged. This seemed to prove that.

I still believe there is an underlying signal strength issue I need to resolve but if your pulling your hair out trying to get a very very remote VDBP to restart, this may be worth a shot.


To RESTART you need to unplug the CHIME, has noting to do with the actual doorbell. I agree these things [Mod Edit] and I’m going to dispute the charge with my credit card as I am still in the 60 days. WYSE does NOT like chargebacks.

MOD NOTE: Post edited to conform to the Community Guidelines.

I think maybe a decent work around is to use a typical wall outlet timer and set it to shut power off for a minute or two daily and plug the chime into it. Wyse definitely has a serious issue with these as a simple Google search for Wyze doorbell 20004 will pull up DAYS worth of reading with no apparent answers.

Not exactly. Unplugging the chime only resets the network connection from your wifi AP to the chime and chime to the doorbell cam. If the doorbell cam itself hangs, as is often the case when there is weak(er) connection from the chime to the doorbell, resetting the chime doesn’t fix anything in my experience. (The cam does not come back online.) You have to reboot the doorbell cam itself either by temporarily pulling the wired power or if in battery mode, turning it off which requires taking it off the mount).

I found on three different Doorbell Pro’s in 3 different homes, moving the chime closer to the doorbell always works better than moving the chime closer to the wifi. The chime to doorbell is the weaker communication link. Get the chime positioned where you consistently get at least 2 bars for “Doorbell Signal Strength” and “Chime Signal Strength” in Settings>Device Info over time (at least a few hours of observation but a day or two is even better) and the experience will be significantly better. If you only get one bar for “Doorbell Signal Strength”, the doorbell cam will drop out or hang constantly.

(The only other thing worth diagnosing if you are using wired power mode is the voltage output of the transformer. But I have not see that cause a communication issue, just doorbell cams that flip back and forth from battery mode to charging or otherwise just run the battery down and shut off.)

My chime is less than 10’ away from the doorbell. Even last night when I removed device and re-installed it, I had BOTH in my office less than 2 feet apart from each other and 5 feet away from my ASUS RT-AC88U that is one of 3 hooked in our AIMESH via backhaul, Doorbell worked for about a two hours then I started getting the 20004 again. We have 9 wyze cams not including the dumbell that basically never have connection issues and some are are outside more than 50 feet away from any router. This doorbell is normally mounted with the chime 4 feet away from one of the routers and the chime is then less than 10 feet away from the doorbell.

This morning I was fed up with it and initiated a chargeback with my credit card, then I moved the mess from my office back to its normal location. Been working ever since.
The doorbell NEVER stopped working as a doorbell it was just impossible to see the camera online.

BTW it all worked perfect until last weeks firmware update. Planned obsolescence maybe?

So by your solution I need the chime on the back side of the wall directly behind the doorbell. When in my office and they were 2 feet apart with clear view in between I still had no internet connection. BTW one of the 3 ASUS routers is IN my office maybe 8 feet from last nights re-install.

The chime controls the internet connection and connects to the doorbell via Bluetooth.

As SOON as the chime came back up this morning I could see it from any device, phone, pad and PC via BlueStacks.

I fully expect it to loose connection again and I fully expect unplugging chime for a few seconds will fix it again.

I will report back if that is not the case.

I have a wyze light bulb that was an endless pain as well, it was cheap enough to hit the trash can. I paid enough for the doorbell I expect it work as good as a $20 camera does.

Pretty much 99% of the issue I have been finding/studying on these cameras is nobody can see the cameras on their cell phone, endless error 20004 which is an internet connection issue. My doorbell has never once stopped working as a doorbell but it constantly stops working with the wifi. I now have a restart shortcut so I’ll see how that does. Bottom line nobody needs should be buying the doorbell pro and they have shut down leaving a review for it on their website. I have been loosing confidence and appreciation for wyze the more I deal with them. I would tell people use wyze cam V2, V3 and stay away from the rest of their stuff. I have not even tried my new OG cameras but suspect I will regret them, as I bought them same time I did this dumbell in late Nov. 23. The dumbell worked fine until it did firmware update sometime last week.