Delayed notifications

Today I received a notification roughly two hours after the event time in the video. The camera was working great for weeks and then all of a sudden it was having connection issues. So, I moved it to a router that should have less obstructions in the signal’s path. It’s still not great, 76% signal strength per the app. Several times I’ve tried to do a restart device from the app and that fails probably 95+% of the time.

So, that’s the situation, but today’s delayed notification raises some questions. Is the notification generated from the phone or the AWS server? I was thinking it was the phone and was separate from the Event, because I would frequently get push notices before the video was available to view. Then today, everything was delayed two hours. For just that camera from what I can tell. Other notices continued to come through. Can anyone explain where that notification and Event was hanging out for two hours?

1 Like

The lag is often the server, the event push will show up before the data has been uploaded to the server depending upon your connection speed. You might try raising the height of the router to increase signal. We had similar issues until we relocated the router to 1,5 m in height (5 ft). Things seemed to improve after we raised the router. Not sure about the 2 hours after the event notification can’t really say on that portion. Although, sometimes we get notifications after they occur because we lost connection, when we regain connection the event notifications push again.

Hope this helps,




@Loki @DreadPirateRush

Do you know if there is any buffering/handshaking at the camera level with the AWS servers?

I think that depends on which process you’re referring to. Connections on uploading events, connecting to livestream or playback via the app, setting up the camera…

Yeah, go get technical on me. lol Sorry, I meant loading Events to AWS and push notices. I’m not sure if I’m confused or … well, no, I’m confused. I’ll admit it. I guess it goes back to expecting notifications and not getting them. So I thought, if the internet is down, they time-out and just go away. Then today, one shows up two hours late. So, it seems improbable there isn’t some handshaking between the camera and the server, but is there?

1 Like

I can tell you that I have had my modem disconnected while a motion event occurred. Reconnected the modem several minutes later and still have that event show up on the cloud. So there must be some amount of buffering going on.

1 Like

Yeah, I haven’t really paid attention to that scenario. I guess I’m going to have to reboot my router, and then try to trigger an event before it comes back up. I think my problem is with the amount of cameras I have, and having a range extender, that I’m used to all kind of oddities.

1 Like

And that’s what I would expect, but today I walked in front of my camera, see the motion tagging in the playback, but never got the notice or Event. Then later, a motion from two hours before shows up and I still didn’t get me walking in front of the camera.

I did the same walk in front of the camera just a while ago, even more on the edge of the zone (less motion) and it shows up in Events.

I don’t have a bunch of cameras (5), but I also have an extender. The camera worked great for weeks, then it didn’t, so I switched routers. Things got weirder. If I didn’t have a need for the cameras, I could deal with some oddities, but I’ve got teens roaming the neighborhood. One of the reasons I haven’t signed up for beta.

I do know on Android that event notifications are through Google notifications, and are separate from the actual upload of the alert video to the cloud. I don’t know about iOS, but I would expect it to be a separate process, too. Have you gone into events to see if there is an event video without getting a notification on them?

My other problem is my VERY limited internet connection. (12 down, 5 up)

Yes, I did look for the video even without the push notification. Just looked again and still not there. Just noticed I have two Events from around 7AM that are listed in Events, both without thumbnails and one without a video.


Yeah, that’s why I’m not a good use-case contributor for some topics because most people have a better connection than I. I just don’t know what it’s supposed to look like for them, just what it looks like for me. But, on the other hand, I can sometimes call B$ when people say a minimum of 100Mpbs plus is required to use these cameras.

1 Like

Some of the weirdness in Events I’m seeing:

Seven minute delay, not that big but…

No thumbnail.


No thumbnail.




No thumbnail.

A bigger question is what am I not getting.

1 Like

Okay, I can shed light on some things here but not everything. @OverWatch, this may be something that you want to work with our support team on. Here’s the link for your convenience!

To the best of my knowledge, the push notifications are generated by the cloud when a video is uploaded and not when the camera detects something. So if there’s a delay in the video reaching the cloud, there will be a delay in receiving the push notification. It’s possible (maybe even likely) that the connection issues you’re describing are leading to this. I don’t really have info past this point, though.

1 Like

Here is the logic.

When an event is triggered it will upload to the cloud. It will send a picture and a video to Wyze Cloud. It usually takes less than 5s to upload a 12s video to the cloud. After Wyze Cloud receives the event thumbnail+video it will send a notification to the user. If there is any failure, we will retry a few times before calling it failed. When it ends up with failure, Wyze will not send you a notification however you can still see an entry in the event list. If you click on it, it will say ‘video not exist’

Your issue is likely either a firmware issue or hardware defect. Very likely your videos failed to be uploaded to the cloud. This would match your words about intermittent connectivity issues with your camera. Do you only have one camera having this issue? That is more likely a hardware issue. We need a firmware log for it. Can you do following?

  1. Go through event list and check if there are any recent videos that can’t be viewed. The more recent the better (say in last 24 hrs). The old log may be overwritten already.
  2. Once you identify an event or a few events, please take down the date and time of the events.
  3. Insert an SD card inside your camera, once you hear the chime sound, take out the card after 5-10s. Take it out and send the log_XXXX.txt file. The XXXX should be your device MAC address plus a timestamp. In your email, please also mention your missing events info collected from step #2.



Thank you for explaining the logic, that corrects a few of my incorrect assumptions. Yes, it is only one camera, which seemed to be working fine in its same location and on the same wifi extender the other 4 cameras are on. Suddenly, I started noticing connection issues and moved it to the main modem/router, which normally has better connectivity on my phone for the camera’s current location. Switching wifi didn’t seem to help and “This video doesn’t exist” errors even seemed to increase. Jan 29, I noticed several "video doesn’t exist” errors (screen grabs above) from overnight and the previous day (Jan 28). I started a trouble report from the app, included the logs and left it sitting in my email draft folder. That log should correspond to the listed errors. I’ve update that draft with the events and sent it including the log to the above address. QUESTION: If I include the log from Jan 29th, do you still need me to perform step 3?

Tao and Gwendolyn did a better job of explaining it than I did (obviously). :smile:


Well, you said “Android” and everything just went dark. Did you say something after that? :stuck_out_tongue_winking_eye:

It does sound a little more streamlined now.

1 Like

Apparently, saving the log file in a draft doesn’t work. I would put the frown face, but I really want the :&@#$^&%: face.