Cordless stick vacuum power floor brush problem

I took apart the power brush attachment for cleaning - using the green button to slide the roller out. Removed all hair and dust from roller and from housing.
No matter how many times I reinsert the roller and how careful I am I can’t get the brush to operate again. The head powers up as evidenced by the LEDs coming on but the roller never spins. No unusual sounds.
The unit seems pretty simple and I’m pretty handy with things so I don’t really think that there’s anything I could be doing wrong - unless it’s something completely non-obvious in how this thing operates.
Any suggestions before this thing heads to the discard pile?

Make sure e erything is lined up and make sure the brush is pushed in all the way.

Aside from that, I’ll try to remember to come back tomorrow and take photos of mine when I take it apart to clean it.

I did mention being somewhat handy and I also mentioned that the “head” is getting power. Sigh. Thanks for the reply but the brush is seated fully, it locks in place and the roller appears to only go in one way - unless there is some secret to it having to be in exactly the right rotational orientation to mate properly with the drive - so maybe if you spin the brush while cleaning it you screw up the orientation… but that’s pretty weak on the designer’s part if it isn’t clear or it doesn’t self-locate.

I had a similar issue once where it wouldn’t turn and it was pushed in and clicked. Let me look at mine tomorrow and see if I can remember what got it working.

So just to put this one to bed - today I had another chance to look over the parts of the roller. Upon close examination I discovered that the cap end of the roller that is released by the green button is removable. It’s not at all obvious and I have not seen this mentioned anywhere but this turns out to be the source of the trouble. Upon removing the cap I discovered that there was hair and dirt absolutely PACKED under it. Not quite clear on how hair and dirt enter this area but there it was and it was nasty. There is a tiny bearing under the cap and then an open space that receives part of the cap. The hair and dirt were so tightly packed that it had become almost a solid mass. Removal required scraping with a small sharp blade - think X-Acto knife - and even then it was not easy to clear every trace of the packed material. I want to stress that this vacuum has only been used a handful of times and really for touch-up style cleaning as we have a Dyson for whole-house style vaccuming. I’m not impressed with the design of this thing AT ALL. Once the dirt is trapped it starts chewing away at the plastic and I don’t see this thing holding up very well in the long run. Not that the run will be all that long - I just don’t see this vacuum holding up to even casual use.
I completely understand the need for cleaning the hair and fibers that get wrapped around the roller. That’s part and parcel of any vacuum with a spinning roller brush. What I don’t understand is how this thing is drawing hair into what should be a sealed area and then PACKING it tightly such that it stops the brush from turning. #fail #poordesign
If Wyze had any kind of responsive customer service I’d be looking to return this thing as I’m so disappointed with the design of it. Maybe I’ll give them a shout.


I got mine out a few minutes ago and I remembered the problem I had was then cap, too! And then promptly cleaned the hair from under around it before it seized up on me again.

Glad you got it sorted out!


Just to chime in here for others’ future reference. Last night, the rotating brush piece of the Cordless vacuum stopped rotating for me, but the lights still came on. I did a lot of troubleshooting and found there was a TON of hair clogging up the inside of this piece (picture taken after I removed all the tangled/clogging hair). Worked fine after I did that.

Again, I pulled out the brush part and took off that cap and somehow there was a bunch of hair tangled around that little metal piece. I just pulled it off (it came out pretty easily), and everything worked as normal again (so if yours has a similar issue, consider checking and cleaning out that part, and your issue might resolve too :+1: ).


Had this exact same issue. I have two of these and narrowed the problem part to the roller as transferring it to either vacuum had the same stoppwd roller effect. It also raised the teeth on the opposite end of the roller. I cleaned the cap full of hair and compacted debris but after it started working the smell of burning :fire: plastic and hair! Cleaned the cap again and may have to after each use… but the bearing was way too hot to the touch that it could cause burns as it’s so hot it’s burning the roller plastic and any hair it touches. Our Dyson doesn’t have this problem, wyze may nwed to provide replacement revised roller cap designs!

I’m having this exact issue. This is the answer to “why my roller isn’t spinning” on the wyze cordless vacuum. There might be other reasons, but this is where everyone will end up if they don’t clean it fastideously after every use or two.

There needs to be a long term solution or I’ll have to stop recommending wyze vac’s I’m afraid. I’m going to see if there’s something I can cobble together myself or maybe 3d print. I don’t see buying a new roller (to get a new bearing) and new cap being a real solution. Mine lasted me almost a year of fairly regular use, other than this, no real concerns and quite happy with it. This is an engineering flaw though and the bearing style needs some sort of redesign to either seal it or help it reduce heat more efficiently - the plastic on the end cap melts so much that it became stuck to the roller.

We would appreciate feedback from Wyze. Or is this now a pattern of the dame Wyze that allowed their v1 Camera owners in the dark with known security issues for years :frowning:


 Please respond.
1 Like

Thank you for all your comments guys. I was going to order another one before I saw this. Seems like it’s waste of money at this point and it’s rather better to throw it.

I had the same issue. The hair on that tiny metal piece made it lock so that the brush wouldn’t spin. I had to use quite a bit of force to twist that piece off. After it was cleaned it spinned just fine

I’m now experiencing same issue, i alteady clean it after every use as there is long hair in the family. This time I smelled burning rubber and checked the brush but it was clean. I disassembled it using the green button, removed the brush, cleaned the ends and popped off the end with the pin…clean. I put brush back, hear the click, start the motor, it clicks when i start it but brush will not rotate. I take brush out, turn on, the rotating end goes around without the brush in so its getting power. Put brush back in…same click, but brush will NOT budge. Anyone else get to this.point? Without a fix?

1 Like

Thank you for posting this photo! I tried to follow @Onslow’s advice above, but this picture was super helpful! Removing this cap and cleaning it out solved the issue I was having with my brush head not working either. I also had the bad smell from it overheating.

1 Like

I have the same issue and it’s to the point where no amount of cleaning will fix it. What I suspect is happening is if you don’t catch this issue soon enough, eventually a stuck roller will wear the gear down enough so that it no longer spins the teethed shaft that goes into the roller. At least not reliably. With the roller out, the shaft spins perfectly fine, but with it in it seems like the weight of the roller is just enough to cause the shaft to now slip within the worn down gear.

Anyway, the real reason I’m here is the replacement heads have been out of stock on the website for over two months now. Does anyone have any idea when they are expected to be back in stock?

My suspicions seem to have been correct, as tonight I super glued the teethed gear shaft to the gear driving it and I just vacuumed my whole house without the brush ceasing to spin. Hoping this serves as a long-term fix and I don’t see why it wouldn’t, but even if it just makes it until the heads get back in stock, I’ll take it.