Contact sensor alert open for X minutes?

In the settings for contact sensors I can’t get the alert for open/closed for X minutes to actually save. when I go back into settings it’s cleared.

And testing condition it indeed does not alert for it either.

Yes - I and others hAve been experiencing this. Wyze sent me new sensors, but this seems to be an app problem…

1 Like

Reinstall app? Restart phone help at all?

Nope tried all including restarting and replacing hardware. This is on Android, not sure about iPhones. What are you using?

Pixel 3, Android 10, Wyze app 2.11.40 but I am not experiencing this issue. This sounds like the cloud is not updating or super slow to update the app with it’s current settings, or the app isn’t displaying what the saved settings are from the cloud. Do you have a different device (Android or iOS, anytype) to log in and see what happens? Another thing I would try is to even turn off your phones wifi, use mobile data and open the app fresh and check to see if you can view the correct settings (or turn off mobile data and use a wifi source). To see if lag or latency in your devices connection has any part in this. At the very least when trying these troubleshooting ideas, stay in the menu and making a settings change for a moment, let the app have a sec to update the cloud with the settings change. I’ve experienced (many app versions ago) that if you make a camera setting change,and then leave the menu right away the command to go back a menu leapfrogs the setting change your tried to make therefore nullifying it. I don’t know if that’s what exactly happened but that’s the best way I can explain it.

2.12.3 on samsung s20. these are brand new contact sensors, but even my long existing ones same problem.

edit: maybe they broke it in beta

Looks like you are using the beta app. Have you looked in the beta forum for similar experiences? And it being the beta app, there still may be kinks being worked out in it.

I’m using the same Beta version and haven’t experienced any problems with my contact sensors. Doesn’t make sense. Pun intended! :grinning:

I would try using a different device if possible.

1 Like

This is a problem I first saw in a beta, but also in the current stable version.

1 Like

Yeah, it’s a firmware issue. "Is left Open"or “is left closed” doesn’t work right with the latest firmware, but if you roll back the firmware to the previous version it will work again (I’ve tested and confirmed it).

If you don’t want to roll back the firmware, a temporary solution is to create a new rule that does something if the sensor is left open for a certain amount of time. For example, as soon as the new firmware broke the is left open notifications on my sensors (again), I just decided to set up a rule to turn on a certain lamp to warn me the door was left open again.

For now, if you keep that firmware those 2 notifications won’t work.

Eventually Wyze will fix it when they get sick of customer service sending out free sensors (they sent some to me too). But if you don’t want to wait, just revert to the previous firmware and it all works as normal again. Those are your options right now.


The original poster is having trouble saving the notification settings, not creating a rule. Everytime they attempt to create and save a notification setting, it reverts back and doesn’t save. Does your solution fix the problem of the settings actually saving? And the sense contact sensors don’t have firmware, what devices firmware are you talking about?

Have you been in the same wifi with your device each time you’ve been testing this? My gut is saying connection latency or connection error. Have you tried other phone/tablet devices? Other wifi networks/mobile data only?

Yes, I know it won’t save time limits on the “is left open” or “is left closed” for any amount of time set on the app. You can change it all you want, hit back and it doesn’t save for those 2 notification options, but it will save adding notifications for opens or closes. That is the same issue I am talking about.

When I had that problem it suddenly worked again as soon as I rolled back the camera firmware to an earlier build (the camera that the bridge is plugged in to). Suddenly the “is left open” notifications option would save in the app and I could finally get the notifications to save in the app and finally show up on my phone. (You could just roll back the firmware on the 1 cam with the bridge attached.)

I only stated that adding a rule to do something if it’s left open is a temporary work around to still have some kind of prompt for now while you wait for them to fix the firmware. The fact that the rule works and can tell how long the sensor is left open proves that the sensor actually works properly, the problem is something else (firmware, since everything works fine with earlier builds).

I hope that helps to clarify.

(Some people have needed to do a different version of the app too, not just the firmware.)

thanks for the confirmation. maybe i’ll rollback the camera FW.

Here’s the original thread for this issue first occurring:

After this issue persisted they revoked the firmware causing the issue… Then they published a new firmware and the issue is back again.

Thanks for the update and sharing your experience! Makes sense (pun intended), hopefully this helps the original poster get things fixed.

Yes, this is definitely a firmware issue. This thread has more details.

1 Like