Can't remotely connect to live stream

Just set up my Wyzecam v2 yesterday. Everything seems to working really well except I cannot connect to the live stream when I’m away from the house. I’ll try to connect and it’ll spin forever. Sometimes it’ll stop and I’ll get an error that says something to the effect of power cycle the camera: error -90. However, when I get home, I don’t have to power cycle the camera and I’m able to connect to the live stream just fine.

I guess in short, it seems I have no problems as long as my phone is on my wifi. When I’m not on my wifi, I can’t connect to the live stream. Also, when I’m not on my wifi, I can still view my notification videos.

Any ideas?



Hello, there may be a number of variables preventing remote LiveStream viewing.

Are you experiencing these issues when on cellular, on public wifi, in the office, etc.

<p style=“text-align: left;”>It would be on cellular.</p>

thanks, would you be able to test with your phone on another wifi network (i.e. library, Starbucks), and see if can remotely access LiveStream.

if remote LiveStream works while you are on another wifi network, that may indicate a possible connectivity issue over cellular.

if remote LiveStream does not work while you are on another wifi network, that may indicate a possible configuration issue with your router/ISP gear.


So I tried connecting to live stream using the rec center’s wifi and then again at the grocery store’s wifi. I could not connect to livestream at either place. Although I could still view the notification videos.


1 Like

So, any other ideas? You mentioned an issue with the router/isp gear. Is there something I can check with those? I’m not very tech savvy, I generally just plug and play.

1 Like

one way to determine whether the issue related to your wifi router/isp gear, is to test the camera on another wifi network.

are you able to temporarily setup the camera on another wifi network (i.e. friend, neighbor, relative) and see if you can livestream remotely.



ok. So I took the camera and my phone and connected them to a different wifi network. While connected to that network everything worked as it does at home. However, when I turned the wifi off on my phone forcing it to use cellular, it still wouldn’t connect to livestream.

So what next?

thanks, with the camera back on your home wifi network, can you test remote livestream with a device other than your phone; i.e. load the wyze app on an ipad or another android/ios phone, log in with your credentials, and test livestream from the rec center wifi.

<p style=“padding-left: 30px;”>I too cannot connect remotely. Cameras work fine on both wifi networks at house but impossible to connect remotely over the cell network. As such, changing alert conditions and notifications is also impossible while away from the units. HELP !!!</p>

1 Like

ok. So I took my old Droid Turbo to the rec center and, although it was slow, was able to connect to the livestream. I then tried my current phone again and was unable to connect.

So there must be some problem with the phone I’m using. It’s a Samsung Galaxy S8+ running Android 8.0.0.

Any ideas of what to check on the phone, settings and such?



1 Like

aside from meeting the minimum OS requirements (android 5.0), the app should be able to livestream locally and remotely.

what version of the wyze app do you have installed on the galaxy s8.

I just downloaded it so I think it’s the most current. App Version 1.3.162

you are correct, that is the latest version. i am unclear whether the issue is specific to the phone (samsung) or customized version of android (8.x), however, can you try to remove and reinstall the wyze app on your s8, keeping an eye out for security prompts requesting access/acknowledgement to mic, etc. if that does not resolve the issue, i would recommend going into the settings area of the phone and reviewing any possible app (security) settings which may be preventing the app from working on a cellular/remote wifi network.

ok. I’ll do that. Thanks for your help.

I’ve had similar issues. I am running 3 Wyzecams and when at home on the WiFi I can connect at least 95% of the time, there are odd times when it won’t, I’ll go to a different camera and back again and it will work.

When out and off the WiFi using a really solid 4G connection it often takes a long time to connect if at all. Maybe 50% success rate. I’m using a Samasung S9+. My wife is running an iPhone and it is worse for her.

I really want these to be good because I love the product, but this unreliability is a killer.

ok. So I uninstalled and reinstalled the app. And it wouldn’t connect. I then decided to just keep trying to connect as I was out and about. And it finally connected to livestream! I continued to try throughout the day yesterday and I’d say I was able to connect about 1 out of every 10 tries. Sometimes, while connected, it would disconnect. But at least I know I can connect to livestream.

Now to figure out why it’s so intermittant…

thank you for the update, good to hear that you made progress on getting remote Live Stream to work (though intermittently) on the s9. did you also open a ticket with the support team. they may be able to provide additional assistance; i.e. use of routethis to perform diagnostics.

No, I haven’t opened a ticket with the support team. I’ll look into that.

Thanks for all your help!

check that cellular data is turned on in the wyze app