Cannot Re-enable Wyze Alexa Skill "link expired"

I have been a Wyze user for years. Recently my password manager suggested I update my Wyze password. I did that and upon arriving home I was notified by Alexa that my account link between Alexa and Wyze had expired ( Makes sense because I changed the password). Using the Alex app and attempting to relink gives me this error, "We’re sorry, an unknown error occurred. Please try again and contact customer support if this continues. (With a request id) “. Looking at recent reviews of the Alexa skill this appears to be an ongoing issue, someone suggested linking through the Wyze app integration menu. Trying that leads to the following error, " service temporarily unavailable, please try again later”.

Now I have tried everything, logging out and uninstalling both apps, clearing cache and data, trying on a different android phone, trying on ios, ect. I reached out to Wyze support this morning and they pointed the finger at Amazon, and when contacting Amazon Support of course they pointed the finger at Wyze. Our whole house is controlled through Wyze and Alexa so this issue is a big pain.

Im wondering if anyone here has experienced this and has a work around? I’m willing to try anything at this point.

1 Like

No. But I believe this will work around the problem and you can still go back to your previous way later.

Simply create a new Wyze account, then use it to link Alexa to the new Wyze account. What have you got to lose trying this? :slight_smile:

Interesting, Ill give that a shot now.

I have now tried setting up a new Wyze account but the issue persists. Its possible the issue is caused by Amazon but the error definitely comes from the Wyze side of the response.

Ive now tried both a new wyze account and a new amazon account with the same error.

I was going to suggest sharing all your Wyze Devices to a secondary account then linking the Alexa skill to the secondary Wyze account. It sounds like you tried this and it didn’t work?

Some other thoughts of things I would personally do if I were in your situation:

I would try changing the password again. Perhaps there is some kind of symbol or structure causing the issue between them. (some require or don’t allow certain symbols in different locations, some won’t allow a number to start or a space to be in there at all, or various algorithmic issues like that which could cause 3rd parties to be upset with each other).

Make sure you completely unlink the Wyze Alexa skill first. Totally delete the Wyze skill from Alexa. Then try to add it back in from scratch.

It’s possible that there is some kind of delay in recognizing the update/change for some reason. If it’s been more than a day, then this almost certainly isn’t the issue, but if it’s been less than a day, it could just need a little time.

My last attempt would be considering changing the email address on one or both accounts and trying again. This shouldn’t be needed and would be a pain, but in theory, if there is some kind of authentication issue being caused by one of the systems thinking that email address is already linked somehow, then it could in theory overcome that issue by reading a different one. If it works, you can always change back to the original email address later.

It could also be that there is currently an issue going on. A couple of days ago my Wyze Alexa routines were being delayed by a good 30 minutes, indicating there was some kind of issue currently going on. It could be something like that which would just require waiting for things to get back to normal so it will work normally again.

(You mentioned you tried some of these already)


I very much appreciate the reply, I think we must be like minded. I tried both a new email/new account with Wyze and amazon/ alexa, and the error continued. I also thought of the password thing so I tried multiple less complex passwords to no avail.

I do believe it may have to do with unlinking and relinking the skill, but unfortunately when it loses credentials its auto disabled from alexa. So there really is no way to “delete” it before retrying the enable process.

Its been a few days so I’d assume the system would have updated the status in that time. I also posted to the official Wyze discord and it seems i’m not alone with this exact problem. The Wyze team on discord said they would elevate it for troubleshooting.

1 Like

I just read your post in Discord. Jimmy is pretty good about reaching people who can really look into abnormal issues like this, whereas support would mostly run through standard troubleshooting, so it’s good you posted there. Man, that would be frustrating. I wish I could think of anything else, but you obviously have thought of trying most of things I would’ve come up with too. I am inclined to think that at this point someone from Wyze needs to connect with their Alexa contacts and see if they can figure out between them (sharing access to logs, etc) what is causing this so it can be resolved.

The next time you try connecting, consider trying to submit logs to support for both companies and posting the reference numbers for them either in Discord with your other post or something so that both sides can look at the log and see what is happening. Having a good example might help them figure it out.

I’d keep trying intermittently until then.

I’m making far stretches with unfounded hypotheses at this point but maybe there is some weird conflict from a testing issue or something. For example, months ago Wyze did a fairly public, but closed beta test (allowed people to sign up for it and post about it publicly here in the forum) where they were testing an update to the Alexa skill testing out being able to control the Robot vacuum…there were some weird things that occurred by using the same Wyze account on the regular skill and the testing skill. It made things a little buggy for a bit with some weird conflicts causing things not to work right. While I’m not saying this same situation is currently happening here now, I could potentially see Wyze doing some other similar test with another skill we don’t know about to test some things out, even if just for their product developers, and Amazon spazzing out that there are multiple skills using the same time, you know, some kind of authentication safety concern on Alexa’s side noticing a conflict or concern based on similar patterns or something weird like that. I experienced some weird conflicts and bugs resulting from having 2 Wyze skills active on my Alexa account, and so I have seen something similar from Alexa in the past. Maybe it is doing something similar to Wyze directly in general for some weird reason (instead of individual accounts).

I’m not going to test removing my Wyze Skill and seeing if it lets me back in…but IF there are lots of other people having Alexa skill logging in issues, then in some ways that is good news for you because it means Wyze will continue to get more reports of this happening and more incentive to see it isn’t an isolated case and make sure it gets resolved so new people can use Alexa again.

If it suddenly starts working post back with an update.

1 Like

Must be the season. My Leviton skill decided its link was expired a week ago, after something like 2 years. In my case the relinking was fairly painless once I found my password.

Interested to see how this goes for you. I think the "let it sit for 24-48 hours and see what happens* technique is promising since that seems to solve many Alexa issues.


Reading your posts, I think you have done a remarkable job in trying to get past this problem.

One more thing, you can create a family member account in Amazon that grants Prime permissions to the secondary account. Might be worth trying that. Create the account and grant permission from your main account to the new Amazon account. Then use you Wyze account and try the link. Frankly, I don’t know if it will help with your devices, but it might.

This fixed worked for me.

1 Like

Having this same issue

Alright, I thoughtfully read over all the comments and I can ensure you that I tried everything with no success. As suggested I believe the issue lied between Amazon and Wyze, Possibly the redirect that takes place during skill enabling.

Surprisingly after a few days I woke up this morning and gave it another shot exactly as I have been repeatedly doing and WHAM it worked! My assumption is someone at Wyze saw the posts and made some tweaks but I’m sure ill never know. Just happy it works again :slight_smile:

I want to thank everyone that popped in with suggestions, The responsiveness and helpfulness really shows how awesome this community is!


This is extremely less likely an explanation than is:

It would seem there are customers with the same issue for multiple weeks, Hundreds, on the amazon skill page, just seems unlikely they are all facing server side updates stuck for weeks. Possible, just seems unlikely.

Oh, okay, that makes sense. I thought you meant saw the posts in this one thread.

Well, whatever the reason is, I’m glad you’re up and running again! Thanks for the follow-up so we could get some closure too. :slight_smile:

1 Like

By chance do you have a VPN? If so try is turning it off and then re!inkiing. You can turn VPN back on after.

Me too! And my doorbell went offline too!

Try again, it was temporary.