Wyze wont authorize Alexa Skill

My Wyze skill stopped working, I get a notice that my account pairing has “expired” and I need to re-enable the skill. When I go to type in my username and password it does nothing- no error, no enabling- nothing. I cannot use my Wyze ecosystem with my Alexa anymore.

1 Like

Have you tried removing the Wyze skill and readding it?

No because I am unable to. There is no “remove Skill”. It seems not to exist until I search for it. Then I get a popup that says the account link expired. and to re-enable. Hitting re-enable takes me to Wyze auth page, which does nothing after credentials are correctly entered.

Never heard of such pairings “expiring”? Hope you’re not being phished.

No this is all happening within the Alexa app on my phone.

When you go to the wyze skill it says " The link between accounts has expired. To continue using Wyze with Alexa, click Enable to Use and link your accounts again".

Clicking the normal Enable under the skill, takes me to “oauth.wyzecam.com”, where my email and account are entered. After hitting “sign in” nothing ever happens.

You have to pair the skill with the Wyze app. This is absolutely common and necessary and is no way a phishing attempt.

Both my Wyze app and my Alexa app are up to date.

1 Like

HA. Someone pushed an update. I just did the same process of entering in data as usual and suddenly a different popup came up, and it actually authorized. I’ve been trying mindlessly over and over for three days now. Literally worked 20 seconds ago but not 40 seconds earlier.

Hmm, interesting. This (ancient) post says the token expiration is determined by the developer.

Somewhat coincident with the AWS outage, but no one else has mentioned this problem so far as I’ve seen…

I actually found a post on reddit from 3 days ago where someone had the same warning. maybe on /r/wyze?

Any word on a fix from either Wyze or Amazon?

Mine just finally worked.

Enable and disable skill in alexa app.

Having the same problem. I put in my credentials, and click sign-in, and nothing happens. I’ve tried another phone, multiple browsers on PC, removing the app (both Alexa and Wyze) and installing it again, chatting with Amazon support, and I’ve gotten nowhere.

Anyone gotten anywhere with this?

I’m having a very similar issue, except with IFTT, the oauth page does nothing when I sign in. The problem with trying to just remove Wyze from IFTT is I’m worried it will delete applets (I realize that’s an issue with IFTT, and not Wyze).

Edit: I took a chance and disconnected from IFTT, and IFTT “archived” any of the applets with Wyze. Unfortunately, the oauth page still does nothing when I try to connect.

oauth.wyzecam still not working when connecting services with ifttt and Google home. Inspecting the page after logging in has no response, it’s definitely broken. I tried re enabling 2factor but same results. Logging into the app and website work fine.

I had this problem for a while and recently discovered this. Go into Account Settings on Wyze app, select Smart Integrations and link Alexa.


It worked. Thank you