Cameras no longer connect away from home

I have Gateway XB7. What specific settings should I be looking for in 10.0.01?

So disabling the firewall entirely on the xb7 through the Web interface seems to have resolved things for me. Rather than clowning around some more, I’ve just enabled bridge mode on the xb7 and am using my TP Link setup behind the xb7 for wifi and firewall.

I suspect what broke things was a firmware update pushed out to the xfinity routers that doesn’t play well with how wyze does camera connections to the live feed. Sadly, disabling the firewall is isn’t going to be a very good option for those who are using their ISP provided xfinity routers for wifi.

Thanks to all who’ve been posting helpful suggestions!

Sections of Firewall, Software, Hardware and Advanced section. It is highly likely the Firewall section is the main problem.


There are no settings in the software, hardware or advanced sections.

You can try what @boosty mentioned by going to Custom Security and try disabling it first to see if the camera work first. Once you are able to confirm that is the culprit then you can start narrowing down what you can do afterwards.

I’ll try that next. Thank you for the suggestion.

Under custom security, it was the very last box to check to disable firewall.

I don’t suggest running for too long like this and I would definitely suggest you leave your computers turned off while you’re doing this test.

I suspect like myself, after disabling the fw you’ll be “fixed”.

Good luck!

If you have to disable the firewall to make things work, why not just get your own router and connect it to your modem?

Just if someone is keeping track…

I have no issues viewing cams with AT&T. I can view from Europe or from down the street over wifi or 5G. I was hoping someone narrowed down the issue by finding the provder as the cause.

.