Came doesn't connect to FranklinT-10 hotspot

I purchased a Wyze Cam3 and connected it to a Franklin T-9 hotspot (Sprint network). It worked well. Recently I received a new Franklin T-10 hotspot as an upgrade (T-Mobile network). Trying to switch the camera to the T-10, the Wyze Cam3 goes through the setup but says the connection failed even though the T10 hotspot shows it as a connected device.

I have compared the settings of the two hotspots, and they seem to be the same.

Any help is appreciated.

1 Like

Every time someone mentions T-Mobile I think of IPV4 and IPV6 because that usually seems to be the issue. The WYZE devices only use IPV4 unless something changed. You should ask T-Mobile if it supports IPV4 and how to change it. Or maybe you have to turn off the 5.0 GHz network to set up the camera then turn it back on??? This may be of interest:


Thanks for the reply and the attached reference.

Both hotspots have the same settings, including IPv6. That’s what puzzled me.

The Franklin T-10 has a T-Mobile SIM, and my Old T-9 has a Sprint SIM. That makes me think it is indeed a T-Mobile issue. There is not much I can do about that, and I don’t know if there is a workaround.

Too bad, I like the Wyze Cam3

Where I live (Kenya) the ISPs usually have the IP address, login name, and password on the bottom of the router. And with a little knowledge, one can login to the router and change things here and there - like disabling IPv6 on the DHCP service in the router. You can also rename the 5GHz SSID to something more relevant.

Were you able to get the Camv3 working with your T-Mobile Franklin T10? I have the same issue but have had several Wyze products running for years. I have an IT management background and talked to T-Mobile and Wyze support at length. Currently Wyze is telling me to contact T-Mobile about:

  1. Hardcoded DNS blocked
  2. Client isolation was enabled

I will post any updates.

Yes, I did finally get the Wyze Cam3 to connect to the Franklin T10. The old T9 sprint account eventually went offline so I tried once more to connect to the T10 T-mobile account. It worked! I have no idea why it worked but I have been using it for several days.

Ironically, today I had to power cycle the T10 and now the Wyze Cam3 is not connecting. Adding insult to injury, I ordered another camera that will arrive today.

1 Like

After ~3 hours with T-Mobile, my ISP, and Wyze with not much help, they now all connected. The only thing that I can think of is that the Franklin T10 was reset by hand by the button next to the battery. I previously reset the hotspot through admin dashboard. This has been pretty frustrating… Please let me know if a reset by hand works for you! Maybe it will help me out in the future!

Thank you for keeping me informed of your progress. I am happy for you that your cameras are finally connected. No such luck for me, though. After several attempts using the manual reset and the T-10 back to factory settings, the Cam v3 is still not connecting.

Hi, I happen to use my T10 hotspot to work with my V3 camera last weekend. It appears to me that everytime you boot up T10, better wait for 10-15 mins for it to “warm up” even you see it has full signal bar. Or it will give me unstable connection (like drop wifi connection or simply no internet at all). So right now whenever I want to connect my cellphone or V3 to that hotspot, I will boot it up first and let it sits there for a while and then connect everything to it. Never drop then. Hope this info helps.

1 Like

Well the T-10 and T-Mobile proved to be unstable. At one point the problem as just fixed for two days and went out again. Once or twice the manual reset worked and then I just gave up. Wyze support blamed the provider and T-Mobile blamed Wyze… I was let in the middle with no help. Starlink finally arrived and I’m done with hotspotting it. The timing was fortunate but it was extremely disheartening that both companies wouldn’t help… Good luck

1 Like

Yes, I have found the T-10 to be a little flaky. I am still using the T-9 for the Wyze cameras. I use an old phone with no cell service connected to the T-9 to monitor the cameras. It’s a pain but it works for now.

1 Like