The Long Road Out of Mobile Data Hell (T-Mobile?)

Hi all,

I have a problem others have written questions for with no clear solution.

I just bought a Wyze Cam v3 because I could not fix a D-Link problem.

Basically, the D-Link android app worked on a Sprint network, but since T-Mobile bought Sprint, the app only connects over wi-fi.

I assumed the problem was the D-Link+T-Mobile compatibility, as others have the same unsolved problem.

Yet lo-and-behold, I cannot connect Wyze+T-Mobile either.

I suspect there is a common cause for Android users to be revealed.

Turn off IPV6 and use only IPV4 networking.


I’m not tech savvy enough to know what @bryonhu said, :thinking: But it sounds smart.

I am just letting you know I am on the T-Mobile Wireless network w\ Mint and have been since starting some time back w\ Wyze. Running Android 11. Never had any issues connecting Wyze app to the cloud.

The only connectivity issues I have when not on WiFi is when I forget that my VPN app is on and blocking Wyze (and everything else) from using mobile data. But that’s on me. :kissing:

Like SlabSlayer, I am using T-Mobile’s network (via Mint Mobile) and have no issues accessing my Wyze cameras on my Android Phone while connected via cellular data.

1 Like

Me three (although not on Mint). Apps like Wyze are pretty network agnostic and T-Mobile is pretty neutral / generic. You might want to reset your phone or try another one.

If this were a common problem I think we would have read about it earlier? You mention “others” - link please?

Yeah, there are other complaints out there about T-Mobile being Video Camera Stream unfriendly going back to 2018. Cannot access when on external network. Not sure if it is a regional prioritization issue or a bandwidth issue. But there have been considerable changes to their network since then… 3G 4G 5G LTE…

At any rate, it isn’t a new phenomenon. But, if it is happening, I know I don’t know how to solve it.

Okay, that thread ends with a link to a specific Wyze outage that was resolved in November 2018. I’m not seeing any real information about TMobile issues or throttling. It’s possible but I haven’t seen it.

Can you be more precise?

If this is an Android connecting to the Wyze, I presume you mean phone IPV4 and not the wi-fi network the camera sits on.

How can a ‘smart enough’ non-technical user implement IPV4 for mobile data access?

search attempts:

To the others with T-Mobile success, my impression is a common if not universal problem on their network.

I’m on Pie (9). My reason for suspecting the network started with seeing others locked out.

When you don’t know the ins-and-outs of devices and networks, troubleshooting is more trial-and-error with changes.

  • Maybe it is the device?
  • Maybe a different carrier?
  • Maybe any phone on Verizon or AT&T would work?

If it is a setting as @byronhu suggests, this is an expensive glitch that begs adjustment.

But it’s not? Again, please link to where you see others with this problem. I’ve gone through multiple phones, all on T-Mobile, and have never had to do anything special for the Wyze app to work (other than turning on hardware acceleration for better video).

I’m starting to think your home router may have extra dumb firewalling features turned on that are preventing P2P apps from functioning.

I am not sure if this makes a difference, particularly for support, but T-Mobile is the network, not the carrier.

I went to my local T-Mobile store and demonstrated the problem. I will go again if they can put me on IPV4.

I can’t tell if you are interested and in a position to solve the problem or if you’re just challenging me, which I do not have time for. I have been cooberated here. You can search both Wyze and D-Link forums to see the problem.

Your suspicion brings me back to the old mobile Sprint network working. The camera’s wi-fi network has not changed. I’m typing this in Linux without a firewall.

No you have not. The one time issue linked above was solved four years ago. You come in here asking for help with zero information, despite repeated requests, and then have the nerve to complain we’re wasting YOUR time?!

1 Like

I think I found an answer to my question to @byronhu:

I need to test it, not convenient at-the-moment in a mobile data dead zone. If the problem is just IPV6 this will be a big relief, though I have low expectations.

If this works I could return the Wyze, though I am thinking of keeping it for no harm in a 2nd camera. My only other big frustration with D-Link is event trigger notices.

D-Link does a good job of capturing events. One feature I like over Wyze – I have it set to record 6 quick snaps shots and send them in an e-mail with no event limits. Wyze seems stuck on video with the timeout period, and the only recovery options are local or cloud. But the D-Link over-triggers and e-mails stop working until some arcane correction I need to implement again. Trade offs.

Anyway, I might just keep two different brand cameras pointed at the same area for insurance, assuming they’ll both work with IPV4 or a new Android device.

We provided you T-Mobile specific APN instructions two days ago.

I am having the same issue, not able to access my Outdoor Cam via the app over T-Mobile network. I am pretty tech savvy. I have switched my phone to IPv4 from IPv6 and it DID NOT fix the problem. I can access the camera just fine over any wi-fi network. I also have a weather station that I can access via app over the T-Mobile network, so I do not believe it is a problem with my ASUS router, but I am open to suggestions on what to check in the settings.

When I try to access the camera it gets to step 3/3 Getting video data, it tries to connect 3 times, then am told the connection failed, and to try restarting the app and power cycling the camera. Which I have done, many times, with no effect.

This has been a problem on two different phones, a Galaxy S9 and now a Galaxy S22+. I have reinstalled the app a few times as well.

I have also tested and compared the speed of my home wi-fi to the mobile network, and the mobile network is at least twice as fast, so fairly positive it is not a network speed problem.

Any other suggestions?

Sounds like T-Mobile is blocking that port

Any idea which port it uses? Then I could check if it uses that one or investigate if it is one T-Mobile blocks.