Cam use to see memory card, but no longer does

So I have 9 Wyze Cameras, 8 standard and 1 PTZ. All nine have memory cards, 32 GB, two different brands, all brand new. All 3 cameras inside and 4 of the outside cameras can no longer access the installed SD card. The cameras were all purchased since February so they are not that old. Half the units are firmware, and half are, all say they are up to date. The SD card issues are on both versions. Anyone have any ideas what is going on?? If there is anything else that can help in troubleshooting this, let me know.

Thanks All

I gave up. People said to use Wyze branded cards so that’s what I got with the cameras. Completely unreliable. These days people are advising to make sure you have “high endurance” class 10 or better cards. Good luck. I just pretend the cards aren’t even there anymore since I got tired of trying to convince the cameras that they’re installed from one day to the next.

Edit: Of course I went through reformatting and/or reinserting plenty of times. It gets tiring and rarely works more than a few days.

This has been my experience with the cams and SD cards. I recently had an event in my business and when I went to view the video, the card hasn’t recorded anything, even though it says the card is recognized and it used to record reliably.

Are you folks waiting for the camera to connect and show a live stream before going into the local storage settings or anything? I can force my cameras to show that it doesn’t have a SD card. If I click a camera, wait for the count up to finish and the live stream to start, then go into local storage settings it shows my card correctly. If I click into a camera and then go into local storage settings before it connects, it shows I don’t have a SD card. Make sure you give the app time to connect.


Yeah. It doesn’t seem to make a difference for me. I tried lots of approaches but the sheer unreliability gets old and, as I said, I gave up. A bunch of wasted $10 cards sitting in $20 cameras.

Now I notice (since I’m paying a little more attention) that the normal cloud recording is unreliable too. On the same delivery today, two cameras 5 feet apart, one recording stored and the other utterly failed. IOS says “doesn’t exist or still being uploaded” while the Android app just says “Download failed”, both showing a single frame.

Issue has been going on for some time now without much response from the company.

Check out the other thread here:

1 Like

I had this issue after the last update, the camera was in a group. Delete the camera from the group, Delete the Camera, Go out to Camera and Manually Reset and Re-Install Camera as if new.

Works great now. No issues. I’ve since removed all cameras from Groups as Group is broken for IOS on. IPhone 6+ and older IPad 4…Cameras don’t connect in any reasonable fashion when in a group and yet work within seconds when UnGrouped.

I had bought a small number of the Wyze branded cards, and none lasted very long. Now, all 19 of my cameras are using this card, and so far none have failed. Only use High endurance cards. Even those will fail - particularly if you have continuous recording selected (I do on all 19 cameras). Just the nature of the technology.


@Omgitstony - That’s interesting - I tried to duplicate your results but my app (IOSBeta) won’t let me into the local storage at all until the cam connects. I get the “spinning wheel of death” until the cam connects, Yet, randomly it seems, I do get the “no SD card” message.
Any ideas?

This thread has a lot of info and discussion about cards and related problems. Check it out…

Thanks everyone for your replies! To answer a few questions, Yes, I wait for the wheel of death to finish spinning before trying to view recordings. Yes the memory cards were working, and I used two brands so its not brand related. I did end up rebooting and cameras that were not working, and once I did they memory cards were seen by the camera again. What I lost was the last four weeks or recordings!! So when will these damn things be able to be recorded by third party software??? That my friends, would fix it all!