3 new cams, SD's not recognised on all 3

I recently added 3 new cams, SD’s not recognised on the 3 cameras…
SD cards work fine on other cams and PC, anybody had a similar situation ? If so how did you solve it.

any help is welcome
warm regards


What are the specs on the SD cards?

Just in case it may help, here’s a link that has the supported SD card specs.

1 Like

Yes, got the same “cards not recognized” problem on several cams from my recent order.
Search for the SD card problem threads here.
There are several of them reporting the exact same problem.
It seems there’s a bad batch of V2’s being delivered lately. All seem to be originating from the Wyze whse.
I’d contact the support chat and troubleshoot with them.

1 Like

Have you tried inserting the card and restarting the Wyze App?

I had trouble with a Wyze cam recognizing the SD card until I shut the App down and restarted it.
Then I could go ahead and Format the SD card.

If you’re asking me, then yes:

restarted the app
re-installed the app and cams
factory restored the cams
re-flashed the firmware

Nothing made a difference

I had issues in the past, for mine i needed to update the firmware (beta) and that worked at least for the issues i was having to format new cards.

cards were bought with the cameras trough the wyze store.
I did check with working cards from my other Wyze cams.
these 3 cams do not recognise cards, no matter what I try.

yes the same here, tried it all… they just do not recognise any card

Start a support ticket!

I bought them through the Wyze app store. together with a couple off Sense kits to play with

I did and am waiting for a reply, they responded quickly and I send the the Log files for each camera

I had this issue. Got a new cam today, and found the issue with my “bad” cam.


these are card bought from Wyze, but it is not the cards. The 3 cameras do not recognise any cards

Wow Rick, really surprised by your findings!!! :astonished:

1 Like

thanks Rick, hopefully i get them replaced… I do not have these skills…

No resistor on mine either, only opened one to double check…


Thanks for the confirmation!

I’m having this exact problem with 4 new cameras I bought recently. The cards work in computers and the Pan I bought in the same order. Formatting in Pan or PC, resetting cams or app makes no difference.

The missing Resistor is enlightening. Really hope Wyze can correct this quickly. I’ve already installed two before I detected this. Pain in the arse to get the ladder out again to unmount them.

1 Like

Quite confident they must have had a bad run of V2’s that won’t recognize the SD cards. Unfortunately my latest addition to my system has the same issue.
I tried two different WYZE cards in it, it cannot find either. Trying the same two cards in a different WYZE cam and they work.
I’m not going to open it up and see if it is missing the resistor as I’m not able to fix it if it is missing. What to do?