SD Card not recognized in new V3 camera

My newer V3 Wyze cam has decided to not see an SD card… I have performed the following troubleshooting actions:

  1. Tried a known good SD Card.
  2. Reformatted the original SD Card.
  3. Restarted the camera via power down, both with the SD card inserted, and without the SD card inserted.
  4. Cleaned the SD Card contacts.
  5. Used some canned air into the SDCard slot on the camera.

The camera appears to be working well in all other aspects. The SD card has been intermintant over time from day one.

Have I missed anything? Time to call Wyze?

I’d definitely reach out to Wyze, especially if you’ve tried different SD cards (assuming you’re using the correct SD card capacity). I think they can only use up to a certain capacity.

What brand, model, capacity SD card?
What version of the app?


Thank you.

32 GB SD card, and latest version of the app. As an aside, the SD card was from Wyze, and included with the order.

1 Like

Try 1-844-999-3226 or (206) 339-9646 (I’ve two numbers for them) as soon as they open Monday - Friday 5 am - 6 pm PT

Saturday 8 am - 4 pm PT.

1 Like


I am having the same problem. V3 Camera was recording to SD and then stopped. Says no card. I put in a new card same thing, no recognition. 32g SD cards.

There’s a bug here somewhere.

Mine is doing the same thing. Recognized the card all day and now tonight it’s saying no sd card inserted.