Wyze cam v3 not recognizing micro sd card

Wyze cam v3 not reconizing micro sd card. The same card works fine in both my v2 cams and my pan cam. Why is this?
Firmware issue?
Poor engineering?
Either way very it is very disappointed since this was replacing my main security camera. Kind of pointless if it isnt going to be able to record. Anyone else have this issue or found a fix?


The v3 doesnt work with cards the same as the previous ones.

First remove the sd card and try updating the v3 to the latest firmware put it back in and see if it reads. They’re working towards the v3 being she same as far as memory cards, but its not quite there.

If not, the card needs to be reformatted as FAT32 for it to work. (If 32 gig or less you can do this with your computer. If larger, you need another program - this is free https://www.softpedia.com/get/System/Hard-Disk-Utils/FAT32format-GUI.shtml )

1 Like

I can confirm that this was my problem as well. I had 64Gb SD cards that worked on v1 and v2. Putting them in v3 (without any changes) did not work.

I formatted FAT32 from exFat and it work. Disappointing engineering.

1 Like

I can’t find the link now, but someone here offered a good explanation for this, and for me, it makes sense.

It claims exFAT is a proprietary property of Microsoft. FAT32 isn’t. To forestall future legal claims, it seems Wyze limited V3 to FAT32.


Mine worked with card (Sandisk Ultra 32 Gb) and 2 days later it says no card installed. I turned camera off and on between each step, tried removing and inserting card around 5 times, checked card in computer and it seemed fine and was only 50% full,

Oddly could not turn off detection or notification (they just instantly turned back on) so with the camera unplugged I held the setup button for 30 seconds (have no idea if this does anything but I’m grasping at straws at this point) and when I hooked it back up I was able to disable detection and notifications. After this I installed the card and it recognized it (have no idea exactly which step fixed it) and I went ahead and re formatted the card in camera.

Funny thing is I had a very similar issue with my second outdoor cam, I even bought a new card for it (the card in it worked in my second outdoor cam) and suddenly it started working. Oh, and it would not work with the card from the second outdoor cam.

I am not sure these things are ready for prime time. I have all kinds of issues with everything but my 3 V2 cameras. My outdoor cams both have playback issues (they play for 1 second then the scrub bar below the video just bounces between 0-1 second mark non stop) I think this is an app issue (happens on both my iPad and IPhone). While the V3 cameras detect motion that is a speck of dust even at detection setting 1 and so the detection goes every every 2-3 minutes all night.

I was very pleased at how my V2’s work and ordered 2 of each of the new cameras but right now they are not really useful and I am about ready to jump the WYZE train.

What I find odd is with samsung pro endurance cards, in both v2 and v3 cameras, I haven’t had to reformat them to fat32. Actually when I tried, using the instructions in the threads here, I never was able to get one formatted to fat32.
I’m sure the fat32/exfat support thing is a problem where it costs more to make a device that officially supports exfat and larger cards, but I think wyze needs to make that change, as well as start selling the samsung cards or the equivalent.

1 Like

I was having the same problem with both a card previously used in a v2 WyzeCam and a brand new samsung 64GB. I finally solved the problem by formatting the card with “Initdisk”, a free formatting utility from Gibson Rearch labs (GRC.com). Formatting with the Windows tool or another windows freeware utility didn’t work.

1 Like

Having the same problem with my V3 camera. Card worked fine in V2, no go in V3. I wish I would have known about this before pre-ordering!

Try formatting the SD card with initdisk which you can get (free) at GRC.com. It worked for me.

1 Like

I formatted a Micro Center Premium 256GB microSDXC Card UHS-I Flash Memory Card C10 U3 V30 4K UHD Video A1 Micro SD Card on a Mac Computer as FAT32 and my WYZE CAM V3 does not recognize the card. Firmware on CAM is which WYZE APP says Camera is up to date. Prior to the Mac computer format I tried formatting the card on my WIndows 10 laptop using the Command Prompt using Format /FS:FAT32 D: and stuck for an hour at 35%

Windows command prompt wont format anything higher than 32gb as FAT32, you’ll need a third party program (not sure about a mac because I dont own one)

Also folks have had mixed results with cards higher than 128 working in a V3 even with FAT32 but it seems the firmware updates are fixing some of that.

1 Like