Wyze Cam V3 not recognizing SD card

My cam V3 does not recognize a SD card. I took an SD card out of my other V2 cameras and the V3 cam would not see either card. I reformatted 1 of them on a PC to Fat32 again and it still would not recognize it. In setup it says No microSD card found.


My V3 is doing the same thing.

See this post by @dr.know, people have had lots of success.


My other 2 Wyze cams recognize the 2 SD cards I tried on my V3.

1 Like

Manually reformat in DOS-FAT format

I was having the same issue! Tech support told me to factory reset and now it works! Hold setup button for 12 seconds and then reinstall the camera

I tried the suggestion to re-set, but am having the same issue. I tried taking a micro card from an existing V2 camera and it was not recognized - though when i put it back in the V2 camera it works. I also did a full format and got the same result.
I’m tried using both a 64 and 128gb card – they both work in a V2 camera. I have not filed a support ticket since i suspect they will say the card is larger than they recommend…

I tried something different. I couldn’t get a card to work no mater how I formatted it, with another Wyze camera or computer. I took the SD card out of my Vantrue car DVR and it worked. I then reformatted it with my V3 camera and the format failed and it would not see the card again. I then reformatted it with my Vantrue camera and it worked again in the V3. The V3 writes to it and seems to work once it sees it.

I haven’t had any issues using the Samsung PRO Endurance 32GB MicroSDXC cards in my v3 cams. I have 3 cams and I literally took the SD cards from older Samsung cameras and the Wyze v3 cams picked them up and started using them without any issue. I did do a reformat in the Wyze app on all 3 just because, but again, no issues.

You can pick up this SD card on Amazon for $9 each. They’re specifically designed for video surveillance. Usually SD cards would die in my various cams after about a year. I purchased the 3 that I’m using in my v3 cams over 2 years ago and they’re still working fine.

HTH someone.


You got it @Skolvikings :slightly_smiling_face: Just to add. .


I should add that I’m doing continuous recording on my cards. So they’re getting completely overwritten about every 3 days and still going strong.

1 Like

The 3 cards I tried were Sandisk ultra 64gb, Microsd 64gb, and a
Sandisk 32gb. None of the would work until I formatted them with my Vantrue camera. If I formatted them with a pc or another Wyze cam a V2, V3, and pan cam they would not work in the V3 camera but they would work in the other 2 cameras. After the V3 sees the card it uses it with no problem.

1 Like

I’m having the same problem:

microsSD in, V3 says “microSD card not found”. If I pop the card out, then back in, it sees it fine, and records to it. If I restart the camera, it loses the card again. This is consistent across 2 V3 cams and 3 microSD cards.

Here is an interesting post - a bad batch of v3s?

I’ve opened a ticket, and asked about this. We’ll see.

1 Like

Could folks experiencing this please send in logs? I’d like to get these to the devs. Sorry for the trouble!

To send in a log, please recreate the issue and then go to Device Settings > Wyze Support > Submit a Log. When you’ve sent it in, please post the log number here and I’ll send it to the team!

1 Like

Just submitted log 73711.

I had microSD connectivity, restarted the cam, and lost it, right before submitting the log.

Matthew White

1 Like

@bumbulbe @cmsouth Welcome to the community forum! :slightly_smiling_face:

Please submit a log file per WyzeGwendolyn’s instructions. You too @sig5197

@mwhite Thank you Matthew White for your quick response.

Log 73736

V3 can not recognizing SD card.
Tried 3 different 32gb SD cards, all class 10, swapped from working v2 cams.
Have one pan cam, four v2 and one v3.
V3 is the only one giving me problems.


I can’t create a log file. To make it fail I have to format the card and after that it does not see the card. When I unplug the card and plug it back in it will not write to it.

The log file is created within the Wyze Application and sent to Wyze direct with a file number.
You could make 2, one for each error with a description. 1)does not see the card. 2)does not write.