Doesn't recognize SD card

I have 3 cameras running. They all have SD cards and all recorded video for playback. This week they need firmware upgrades. Now they don’t record and the message is that there is no SD card installed. I restarted them many times but that didn’t work. Anybody else experience this? And any fixes?


Have you tried formatting the cards on a different machine, then reinserting them?

Others have reported that SD cards are no longer recognized. It appears that some Wyzecams cause SD cards to become permanently non-functional. Details here:

If reformatting the cards (as suggested by camera2) fixes your problem, please let us know.

I have refrained from updating my cams with the latest firmware update.


I have 5 cams with SD cards …class 10 32gb … 3 of them are bricked. Corrupt … will not reformat on Android or Windows etc … Silicon Power Elite from Amazon … I have other devices with them and they are fine.

Ok…same problem here…

I ordered my sd cards from Wyze so I hopefully wouldn’t have a problem.

Set up one cam with card. As I remember, it formatted ok. Couple days later I wanted to review what was recorded and nothing. Tried reformatting,…app says sd card not inserted or not found whatever. Unplugged the camera, restarted my phone, etc and still no luck. Last couple times tried it, message was format failed.

I inserted another sd into another camera, and would not work first several times, and finally did. I will check later to see if it is recording.

Very frustrating and a lot of money spent on Wyze cards.

Sorry to hear about the SD cards. This article might be useful for others, will add the link here for reference.

Thanks but the problem only showed up after updating the software version. The sd cards worked until then. Is there a way to go back to the previous software version in the cameras?

You can revert camera firmware by following the instructions here:

@offset123 Have you contacted Wyze support about the faulty card(s)? That’s probably your next best course of action.

In follow up to my previous post on Nov. 8.

Did some troubleshooting on the Wyze sd cards.

I purchased 5 cards.

2 cards work, 3 do not work.
I used 2 camsv2 to test.
The 2 cards that work, work in both cams tested.
The 3 cards that do not work, didn’t work in either cam tested.

So it appears to me that the 3 cards are defective.


If the Wyze cards are defective, the only way to get them replaced would be to file a support ticket. You can do so by clicking the Support link at the top of this page. Please be patient as there is currently a bit of a support backlog.

Thanks for your reply.

Much appreciated.


1 Like

My v2 camera also has SD issues. I tried an off brand 512 GB first then a 32 GB Wyze brand and both freeze the camera and cause it not to connect or only show the live shot for a second. Very frustrating because I want to record!


I would click the Support link at the top of this page and run through the troubleshooting section. If that doesn’t do it, and if you don’t get other help here from the community, file a support ticket, preferably from within the app while the bad camera is connected so that the logs are captured. You might want to submit the ticket right away because there’s somewhat of a backlog. You can always let them know it’s already resolved when they contact you.

I am collecting some info on similar issues. If you still have this issue not solved, can you check something for me? When you format the card in camera, check the “SD card memory available” before and after formatting. Before formatting, do you have a low number (eg. 1.x GB) available out of 29.x GB? The camera may report “formatting complete” but afterwards, it still says 1.x GB available. If the formatting was really successful, it should show 29.x/29.x available (IOW, the card is empty).

If you are seeing the same low available space number after formatting, then I believe your card is damaged and will not be able to be formatted even on a computer. If you want, you can remove the card and try to format it using the tool here:

SD Assoiciation

SD Memory Card Formatter 5.0 for SD/SDHC/SDXC

The SD Memory Card Formatter formats SD Memory Card, SDHCMemory Card and SDXC Memory Card (respectively SD/SDHC/SDXC Cards) complying with the SD File System Specification created by the SD Association (SDA).

I think you will find it report errors and fail to format. In this state, you can copy off what’s still on the card, but cannot format the card or write new data to it.

Let me know if this is what you’re seeing. This is what I’m trying to track down.

Thanks I’ll give it a try.

Ive had that issue a few times. Just took out the sd card and formatted it in my computer then back in the cam.

So after trying everything mentioned above i had no success. What i had to end up doing due to the cam corrupting my card and it not formatting on any reader i plugged it into was put the sd card into my phone, format on the phone, remove from phone, put into computer, format as exfat, turn off wyze cam, put card into cam, turn on cam, format card on cam, restart device, and success. Idk why it was such a hassle but if anyone else has a problem with your card not formatting on the computer you can try it this way.

1 Like

I had the same issue yesterday. I was using the Sandisk 32gb class 10.
When I kicked off formatting from the camera/app, it got stuck and after that the camera stopped recognizing the sd card. I tried formatting using a Mac and a windows pc but it didn’t help.
finally, i downloaded the formatting utility from the Sandisk site and formatted the sd card using their utility which did the trick. The key difference in formatting via pc/mac is that the sd card shows 29.5gb available while the out-of-the-box the sd card is 29.7gb free space. Formatting using the sandisk utility gives back the 29.7gb which the Camera is able to detect.

1 Like

I just moved a new Pan cam to a new location. After moving it, I decided to format it to clear it for new video. I got a notification that the format failed, then the camera wouldn’t recognize the SD card and said one wasn’t inserted. The card was not recognizable by my Mac, so I formatted it in a Canon DSLR camera, then reformatted it on my computer to ensure it was in exFAT. The camera recognized it, but showed it as only having 0.5 Gb available. I reformatted in camera and had the same problem.

This time, I put it back into the Pan cam right after formatting in my DSLR. This time it recognized it, and had full capacity.

Reformat in another device, then don’t reformat it in the Wyze Cam.

1 Like